Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Error in upgrading, help!  (Read 5384 times)

0 Members and 1 Guest are viewing this topic.

drownedgod

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 19
    • TV Screencaps
Error in upgrading, help!
« on: July 06, 2009, 02:18:51 am »

Hi guys,

I am upgrading my gallery http://tvscreencaps.com. But I am getting this error.. cpg14x_pictures exist, i see it in phpmyadmin.

Code: [Select]
While executing query "INSERT INTO cpg14x_pictures (approved, pid, aid, caption, filepath, filename, filesize, pwidth, pheight, hits, mtime, ctime) SELECT 'yes' as approved, p.pid, aid, msg_body AS caption, filepath, filename, filesize, pwidth, pheight, hits, mtime, UNIX_TIMESTAMP(ctime)FROM CPG14X_pictures AS p LEFT JOIN CPG14X_comments AS c ON p.caption = c.msg_id " on 0

mySQL error: Table 'c**_screencaps.CPG14X_pictures' doesn't exist

Code: [Select]
USER:
------------------
Array
(
    [ID] => bb7d7368d76ee28aa8d33eca954c6c66
    [am] => 1
    [lang] => english
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => Carlo
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 0
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg14x_filetypes; (0.001s)
    [1] => select * from cpg14x_plugins order by priority asc; (0.001s)
    [2] => delete from `c**_screencaps`.cpg14x_sessions where time<1246835276 and remember=0; (0.001s)
    [3] => delete from `c**_screencaps`.cpg14x_sessions where time<1245629276; (0.001s)
    [4] => select user_id from `c**_screencaps`.cpg14x_sessions where session_id = 'f5daa9c5b447b66334d01852cf0532df' (0.001s)
    [5] => select user_id as id, user_password as password from `c**_screencaps`.cpg14x_users where user_id=1 (0.001s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `c**_screencaps`.cpg14x_users AS u INNER JOIN `c**_screencaps`.cpg14x_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0.001s)
    [7] => SELECT user_group_list FROM `c**_screencaps`.cpg14x_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg14x_usergroups WHERE group_id in (1) (0.001s)
    [9] => SELECT group_name FROM  cpg14x_usergroups WHERE group_id= 1 (0s)
    [10] => update `c**_screencaps`.cpg14x_sessions set time='1246838876' where session_id = 'f5daa9c5b447b66334d01852cf0532df' (0.001s)
    [11] => SELECT user_favpics FROM cpg14x_favpics WHERE user_id = 1 (0.005s)
    [12] => DELETE FROM cpg14x_banned WHERE expiry < '2009-07-05 19:07:56' (0.002s)
    [13] => SELECT * FROM cpg14x_banned WHERE (ip_addr='222.127.95.105' OR ip_addr='222.127.95.105' OR user_id=1) AND brute_force=0 (0.001s)
    [14] => INSERT INTO cpg14x_pictures (approved, pid, aid, caption, filepath, filename, filesize, pwidth, pheight, hits, mtime, ctime) SELECT 'yes' as approved, p.pid, aid, msg_body AS caption, filepath, filename, filesize, pwidth, pheight, hits, mtime, UNIX_TIMESTAMP(ctime)FROM CPG14X_pictures AS p LEFT JOIN CPG14X_comments AS c ON p.caption = c.msg_id  (0.001s)
    [15] => SELECT COUNT(*) FROM cpg14x_pictures WHERE approved = 'NO' (0s)
)

==========================
GET :
------------------
Array
(
)

==========================
POST :
------------------
Array
(
)

==========================
VERSION INFO :
------------------
PHP version: 4.4.9 - OK
------------------
mySQL version: 4.1.20-max-log
------------------
Coppermine version: 1.4.25(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.28 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support:
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 4.1.20
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.1.4
Linked Version 1.1.4
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/usr/local/lib/php:/usr/local/lib/php/PEAR:/usr/local/share/pear | .:/usr/local/lib/php:/usr/local/lib/php/PEAR:/usr/local/share/pear
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | me@localhost.com | me@localhost.com
sendmail_path | /usr/sbin/sendmail -t -i  | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | -1 | -1
upload_max_filesize | 2M | 2M
post_max_size | 8M | 8M
==========================
Page generated in 5.124 seconds - 16 queries in 0.018 seconds - Album set : ; Meta set: ;
Logged

Nibbler

  • Guest
Re: Error in upgrading, help!
« Reply #1 on: July 06, 2009, 11:16:59 am »

This is caused by your own modifications. Table names are probably case sensitive.
Logged

drownedgod

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 19
    • TV Screencaps
Re: Error in upgrading, help!
« Reply #2 on: July 06, 2009, 04:20:26 pm »

thanks.

i got it working now.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Error in upgrading, help!
« Reply #3 on: July 06, 2009, 04:37:36 pm »

For the benefit of others with similar issues you're suppossed to resolve your thread properly by posting what you actually did to solve your issues. That's the point of a support board. Not doing so is selfish and rude.
Logged

drownedgod

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 19
    • TV Screencaps
Re: Error in upgrading, help!
« Reply #4 on: July 07, 2009, 03:40:02 am »

Sorry about that.

Anyway, I was following the installation steps of the "3.1.2 Upgrading from cpg1.1.x, cpg1.2.x or cpg1.3.x to version cpg1.4.x" when I should do this "3.1.3 Upgrading from cpg1.4.0 or better to version cpg1.4.25". Dumb me. lol

So I followed "3.1.3 Upgrading from cpg1.4.0 or better to version cpg1.4.25" and it worked.

Logged

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Re: Error in upgrading, help!
« Reply #5 on: July 07, 2009, 07:18:31 am »

Thanks for coming back and give an explanation to the issue.
Logged
Read Docs and Search the Forum before posting. - Soporte en español
--*--
Fabricio Ferrero's Website

Catching up! :)
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 20 queries.