Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: login succeeds, but not actually logged in  (Read 2120 times)

0 Members and 1 Guest are viewing this topic.

coders333

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
[Solved]: login succeeds, but not actually logged in
« on: July 02, 2009, 04:22:35 pm »

alright, iv searched through these boards and google for several hours to no avail (hope im posting in the right board).  i just attempted to login to my gallery last night for the first time in about a week, the login succeeds, but when you return to the index page it is as if you havent logged in at all.  there are no errors given during the login process.  the admin account does this, as well as other accounts; users can still register though.  after  you go through the login process, and try to manually access an admin page such as admin.php or pluginmgr.php directly it says you dont have permission to access the page as if you hadn't logged in at all.  i have tried with several versions of firefox, internet explorer, and safari, on different machines.  i have several other installations of coppermine on my server for other sites, none exhibit this issue.  have compared some tables in db from a working install with this one, cant find anything.  upgraded to 1.4.25 this morning, didnt solve either; could not access upgrade.php "you dont have permission to access this page".  my gallery is located at http://jctrips.personnet.info  i created a test user this morning via registration username: testuser pass: password; this acct exhibits the same problem.  your help is much appreciated.
« Last Edit: July 03, 2009, 07:53:32 am by Joachim Müller »
Logged

Nibbler

  • Guest
Re: login succeeds, but not actually logged in
« Reply #1 on: July 02, 2009, 07:55:36 pm »

Check that the groups table is populated. update.php has no access restrictions, so I don't know how you managed to get that error.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4849
    • Windsurf.me
Re: login succeeds, but not actually logged in
« Reply #2 on: July 02, 2009, 09:06:40 pm »

Probably because he was typing upgrade.php ;)
Logged
It is a mistake to think you can solve any major problems just with potatoes.

coders333

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: login succeeds, but not actually logged in
« Reply #3 on: July 02, 2009, 11:51:11 pm »

Check that the groups table is populated. update.php has no access restrictions, so I don't know how you managed to get that error.
sorry for the typo in my first post.  i had perviously successfully run the update.php.  checked my usergroups table against another coppermine install and found inconsistencies.  added the good table and now all is good.  thanks for the help.
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 21 queries.