Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Closed]: help me to install sef plugin in 1.4.25 cpg gallery  (Read 8880 times)

0 Members and 1 Guest are viewing this topic.

nitinp7

  • Coppermine newbie
  • Offline Offline
  • Posts: 3

i have installed coppermine software v 1.4.25 in my site http://thewallpapergallery.com/cgp1425/index.php

but when i install SEF_URLs plugin my site does not work and no photo and page gives error 404 error

please help me to solve this problem i am ready to pay for your help

please view my site condition and tell what charges you will take to help site to sef url friendly

nitin gupta
« Last Edit: July 02, 2009, 02:12:45 pm by Joachim Müller »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: help me to install sef plugin in 1.4.25 cpg gallery
« Reply #1 on: June 29, 2009, 10:22:50 am »

Are you per chance the same Nitin Gupta that already is registered on this board (http://forum.coppermine-gallery.net/index.php?action=profile;u=42923)?
Logged

nitinp7

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: help me to install sef plugin in 1.4.25 cpg gallery
« Reply #2 on: June 29, 2009, 08:47:36 pm »

Are you per chance the same Nitin Gupta that already is registered on this board (http://forum.coppermine-gallery.net/index.php?action=profile;u=42923)?

I AM THE SAME WHO REGITERED FIRST BEFRE PUTTING THIS POST
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: help me to install sef plugin in 1.4.25 cpg gallery
« Reply #3 on: June 29, 2009, 10:05:29 pm »

huh? ???
Logged

nitinp7

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: help me to install sef plugin in 1.4.25 cpg gallery
« Reply #4 on: July 01, 2009, 05:57:02 pm »

huh? ???
i am regestered as user not as freelancer.

i want help from freelancers. i have to register to put this reqest. please do not think that i am a freelance for this site


i want help
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1543
  • aka 'i-imagine'
    • Home Page
Re: help me to install sef plugin in 1.4.25 cpg gallery
« Reply #5 on: July 01, 2009, 06:35:32 pm »

You are on a windows server. Read the overview (at least) of this plugin: HERE

Server - Microsoft-IIS/6.0

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: help me to install sef plugin in 1.4.25 cpg gallery
« Reply #6 on: July 02, 2009, 12:56:36 pm »

i am regestered as user not as freelancer.
I understand that you're a user. I didn't say that you're a freelancer. I just noticed that there already is a user with the same real name as yours, so I just wanted to know wether you're the same person, which usually happens if users forget that they already have an account and register a second time. Hence my question. Nobody suggested that you have come here to help - it's totally obvious that you came here looking for support.


i want help
I understand that. But I haven't understood your question, so you should rephrase it.

You are on a windows server.
How do you know?

Read the overview (at least) of this plugin: HERE
That page only contains the text
Quote
Makes search engine friendly URLs for index, thumbnails, and displayimage.php on Apache-driven webservers
The actual announcement thread for the plugin is SEF_URLs plugin for cpg1.4.x

Server - Microsoft-IIS/6.0
If you're actually on IIS then you simply can not use that plugin. There is no point in that case to request the help of a freelancer - you'd need a miracle in that case and not just a skilled coder. The SEF_URLs plugin can only be used with Apache. It doesn't work with IIS.
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1543
  • aka 'i-imagine'
    • Home Page
Re: help me to install sef plugin in 1.4.25 cpg gallery
« Reply #7 on: July 02, 2009, 01:48:17 pm »

How do you know?

I use a very old freeware utility - located here GRC ID Serve

Unfortunately (for many users...) it is a windows based utility.

Here is an example result - for the server @ address forum.coppermine-gallery.net
Code: [Select]
Initiating server query ...
Looking up IP address for domain: forum.coppermine-gallery.net
The IP address for the domain is: 80.68.88.129
Connecting to the server on standard HTTP port: 80
[Connected]  Requesting the server's default page.
The server returned the following response headers:
HTTP/1.1 200 OK
Date: Thu, 02 Jul 2009 11:45:07 GMT
Server: Apache/2.2.9 (Debian) Phusion_Passenger/2.2.2 PHP/5.2.6-1+lenny3 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g
X-Powered-By: PHP/5.2.6-1+lenny3
Set-Cookie: PHPSESSID=78cc3436ab5ecb8fc689f19c9bafadc6; path=/; domain=.coppermine-gallery.net
Expires: Mon, 26 Jul 1997 05:00:00 GMT
Cache-Control: private
Pragma: no-cache
Last-Modified: Thu, 02 Jul 2009 11:45:07 GMT
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html; charset=ISO-8859-1
Query complete.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: help me to install sef plugin in 1.4.25 cpg gallery
« Reply #8 on: July 02, 2009, 02:11:26 pm »

Thanks for your reply. I'm aware that the webserver adds reference to the communication overhead. You can retrieve similar data by using any tool that can sniff/monitor the protocol communication data. Good idea to take a look at that - I didn't think of checking this piece of information in the first place - well done.
Personally, I use the Firefox add-on "Live http headers" - (download at https://addons.mozilla.org/de/firefox/addon/3829, more information at http://livehttpheaders.mozdev.org/). This is what I get when I visit http://thewallpapergallery.com/cgp1425/:
Quote
http://thewallpapergallery.com/cgp1425/index.php

GET /cgp1425/index.php HTTP/1.1
Host: thewallpapergallery.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Cookie: a2dc8c29ef6671f58ff867d1f2c8f385=8d3065343234fe198339ac3d81395970; coppermine_data=YTozOntzOjI6IklEIjtzOjMyOiI3ZDY2ODBiNjE3M2E4ODlhOWU5ZGNiN2JjNzBiNDhlZiI7czoyOiJhbSI7aToxO3M6NDoibGFuZyI7czo2OiJnZXJtYW4iO30%3D

HTTP/1.x 200 OK
Content-Type: text/html; charset=utf-8
Server: Microsoft-IIS/6.0
X-Powered-By: PHP/5.2.0, ASP.NET, PleskWin
P3P: CP="CAO DSP COR CURa ADMa DEVa OUR IND PHY ONL UNI COM NAV INT DEM PRE"
Set-Cookie: coppermine_data=YTozOntzOjI6IklEIjtzOjMyOiI3ZDY2ODBiNjE3M2E4ODlhOWU5ZGNiN2JjNzBiNDhlZiI7czoyOiJhbSI7aToxO3M6NDoibGFuZyI7czo2OiJnZXJtYW4iO30%3D; expires=Sat, 01-Aug-2009 13:21:14 GMT; path=/
Date: Thu, 02 Jul 2009 13:21:14 GMT
Connection: close
So yes, I can confirm your observation: Nitin appears to be running on IIS. Therefor, the SEF_URLs plugin can not be used. Marking thread as "closed".
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 21 queries.