Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Database connection problem  (Read 2674 times)

0 Members and 1 Guest are viewing this topic.

ricardojb

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Database connection problem
« on: June 25, 2009, 07:47:27 pm »

I posted this yesterday but the message dissappeared. I really have searched the forum and the documentation but I cannot find the same case.

The issue is simple, I am getting a connection error, however, the problem is not the wrong password, but that coppermine is not passing the password with the connection (using password NO).

I know you can change database parameters in the config.inc.php file, however, I cannot find anywhere how to make the app. connect with a password, nor I know why this was changed.

Thanks in advance (and I hope this doesn't get deleted).
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Database connection problem
« Reply #1 on: June 25, 2009, 07:59:59 pm »

If you specify a database password in include/config.inc.php, that password will be used.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4886
    • Windsurf.me
Re: Database connection problem
« Reply #2 on: June 25, 2009, 10:47:18 pm »

We never delete a thread unless it is spam, even when we are being insulted or abused we just sensor any bad words.

This did not happen in your case but we had some server problems. Please see the thread below. Our apologies for the loss of your first post.

http://forum.coppermine-gallery.net/index.php/topic,60323.0.html
Logged
It is a mistake to think you can solve any major problems just with potatoes.

ricardojb

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Database connection problem
« Reply #3 on: June 26, 2009, 04:11:55 am »

If you specify a database password in include/config.inc.php, that password will be used.

Hi Joachim,

I did specify the user name and pwd. I even compared with the sample file and with other config files in other galleries that are working, but for some reason the password is not passed accross.
Logged

ricardojb

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Database connection problem
« Reply #4 on: June 26, 2009, 04:13:07 am »

We never delete a thread unless it is spam, even when we are being insulted or abused we just sensor any bad words.

This did not happen in your case but we had some server problems. Please see the thread below. Our apologies for the loss of your first post.

http://forum.coppermine-gallery.net/index.php/topic,60323.0.html

no problem, since I don't post regularly I wasn't aware of the rules and I thought that maybe I was asking something that was answered before or something like that, some message boards don't allow that.

Thanks for your explanation.
Logged
Pages: [1]   Go Up
 

Page created in 0.033 seconds with 19 queries.