Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: █ █ Aggiornamento Coppermine 1.4.25 █ █  (Read 5708 times)

0 Members and 1 Guest are viewing this topic.

Davide Renda

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1427
  • aka "Lontano"
    • www.daviderenda.eu
█ █ Aggiornamento Coppermine 1.4.25 █ █
« on: June 23, 2009, 10:14:49 pm »

Il team di sviluppo Coppermine ha rilasciato un aggiornamento per risolvere un problema al sistema di upload via http. Il fix non riguarda direttamente la sicurezza, quindi se la vostra galleria funziona bene con la versione 1.4.24 non avete necessità di aggiornare. Se invece utilizzate una versione anteriore alla 1.4.23, dovete assolutamente aggiornare all'ultima versione a causa di seri problemi di sicurezza.

Come aggiornare:
Gli utenti di versioni anteriori alla 1.4.25 dovranno aggiornare scaricando l'ultima versione dalla pagina download e seguendo i passi per aggiornare dalla documentazione ufficiale.

Patch manuale:
Per chi desideri applicare una patch manuale alla sua galleria Coppermine, aprite il file include/init.inc.php con un editor di testo e cercate:
Code: [Select]
$keysToSkip = array('_POST', '_GET', '_COOKIE', '_REQUEST', '_SERVER', 'HTML_SUBST', 'keysToSkip', 'register_globals_flag', 'cpgdebugger', 'key');quindi rimpiazzate con:
Code: [Select]
$keysToSkip = array('_POST', '_GET', '_COOKIE', '_REQUEST', '_SERVER', '_FILES', 'HTML_SUBST', 'keysToSkip', 'register_globals_flag', 'cpgdebugger', 'key');
Supporto:
Se incontrare problemi con l'aggiornamento, utilizzate questo forum (in italiano) o la sezione Update support board in inglese.

Perché del rilascio della versione cpg1.4.25?
L'aggiornamento copre un bug sorto risolvendo la vulnerabilità nella versione cpg1.4.23.

Inoltre, cpg1.4.25 include le patch seguenti (non inerenti problemi di sicurezza):
  • Ulteriore fix PHP 5.3
  • Aggiornamento file di lingua Danese
  • Aggiornamento file di lingua Turca

Grazie a Nibbler per aver proposto la patch.


Grazie,
The Coppermine Team

Davide Renda

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1427
  • aka "Lontano"
    • www.daviderenda.eu
Re: █ █ Aggiornamento Coppermine 1.4.25 █ █
« Reply #1 on: June 23, 2009, 10:16:37 pm »

Gli utenti del modpack di Stramm, dotranno aggiornare alla 1.4.24 dal sito di Stramm e applicare la patch del post precedente.
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 19 queries.