Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Batch Add not working  (Read 6540 times)

0 Members and 1 Guest are viewing this topic.

hsm88

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Batch Add not working
« on: March 31, 2010, 06:22:14 pm »


A few month ago I couldn't batch add pictures via ftp anymore I only got a blank page or a 404 page. Then I remove www from my address and it worked after I had updated the page a few times. Last week I had to update the page ("searchnew.php") 10-20 times before I could bath pictures. Today that isn't working anymore.

I have read the doc file and this topic http://forum.coppermine-gallery.net/index.php/topic,64031.0.html but I can't solve my problem.

It worked fine to upload singeles file.

A few days ago I updated my gallery to version 1.4.26 and the new stramn modepack so maybe I did something wrong with that. I now that a lot of the folders that were created in subdirectoriey "candids/2010" have a few Capital letters and I have read that isn't good, but I don't think I can change that without reupload the pictures.

usernamn: testbf
password: testbf

site: http://www.breakingfree.se/bfgallery/index.php

Sorry if my english isn't correct. 
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Batch Add not working
« Reply #1 on: April 01, 2010, 08:31:39 am »

A few month ago I couldn't batch add pictures via ftp anymore I only got a blank page or a 404 page. Then I remove www from my address and it worked after I had updated the page a few times.
I can access the batch-add page as expected both with and without the leading www subdomain: http://www.breakingfree.se/bfgallery/searchnew.php works as well as http://breakingfree.se/bfgallery/searchnew.php
Anyway, if your issues are 404 not found errors with the leading www subdomain you should as your webhost for support.

I have read the doc file
The test user account you posted doesn't even have http uploads permissions, so what should we do with it? I don't get the impression that you actually have read the docs... ::) Read http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_support and do exactly as suggested there.
Logged

hsm88

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Batch Add not working
« Reply #2 on: April 01, 2010, 08:39:00 pm »

I have changed the testbf account to admin now so feel free to see if there're any problems.

Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1543
  • aka 'i-imagine'
    • Home Page
Re: Batch Add not working
« Reply #3 on: April 01, 2010, 08:56:56 pm »

I have changed the testbf account to admin

Never post an admin account publicly! I have changed the password so that someone can not do some damage to your Coppermine.

You were told before - you must read and follow all of the steps in this section of your documents when asking for upload help.
http://www.breakingfree.se/bfgallery/docs/index.htm#upload_support

hsm88

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Batch Add not working
« Reply #4 on: April 01, 2010, 09:28:31 pm »

Now I have done what I was told to do under "Upload Troubelshooting" and I got this:

Quote
USER:
------------------
Array
(
    [ID] => ee4edab96f0912842f75867854528076
    [am] => 1
    [lang] => english
    [liv] => Array
        (
           
  • => 24610
  • [1] => 24873
                [2] => 24933
            )

       
[lap] => 3
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => admin
    [groups] => Array
        (
           
  • => 1

        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 0
    [ufc_min] => 0
    [custom_user_upload] => 0
    [num_file_upload] => 1
    [num_URI_upload] => 0
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 0
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM cpg14x_filetypes; (0s)
  • [1] => select * from cpg14x_plugins order by priority asc; (0s)
        [2] => delete from `breakingfree_se`.cpg14x_sessions where time<1270146162 and remember=0; (0.001s)
        [3] => delete from `breakingfree_se`.cpg14x_sessions where time<1268940162; (0.001s)
        [4] => select user_id from `breakingfree_se`.cpg14x_sessions where session_id = '5ca4fc4a71286448c94d16c99f2d0b48' (0s)
        [5] => select user_id as id, user_password as password from `breakingfree_se`.cpg14x_users where user_id=1 (0.001s)
        [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.avatar_url AS avatar_url, u.enable_admin_email AS notify, u.auto_subscribe_post AS auto_subscribe_post, u.auto_subscribe_comment AS auto_subscribe_comment, u.user_group+100 AS group_id FROM `breakingfree_se`.cpg14x_users AS u INNER JOIN `breakingfree_se`.cpg14x_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
        [7] => SELECT user_group_list FROM `breakingfree_se`.cpg14x_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
        [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg14x_usergroups WHERE group_id in (1) (0s)
        [9] => SELECT group_name FROM  cpg14x_usergroups WHERE group_id= 1 (0s)
        [10] => update `breakingfree_se`.cpg14x_sessions set time='1270149762' where session_id = '5ca4fc4a71286448c94d16c99f2d0b48' (0s)
        [11] => SELECT user_favpics FROM cpg14x_favpics WHERE user_id = 1 (0s)
        [12] => SELECT count(*) FROM  cpg14x_pms WHERE owner=1 (0s)
        [13] => SELECT count(*) FROM  cpg14x_pms WHERE owner=1 AND showed='0' (0s)
        [14] => SELECT count(*) FROM  cpg14x_buddy WHERE user_id=1 (0s)
        [15] => SELECT count(*) FROM  cpg14x_buddy_req WHERE buddy_to=1 (0s)
        [16] => DELETE FROM cpg14x_banned WHERE expiry < '2010-04-01 19:22:42' (0s)
        [17] => SELECT * FROM cpg14x_banned WHERE (ip_addr='84.217.63.252' OR ip_addr='84.217.63.252' OR user_id=1) AND brute_force=0 (0s)
        [18] => SELECT aid from cpg14x_pictures WHERE pid='24940'  LIMIT 1 (0.037s)
        [19] => SELECT title,keyword from cpg14x_albums WHERE aid='384' (0.002s)
        [20] => SELECT COUNT(*) from cpg14x_pictures WHERE ((aid='384'  ) )   (0.001s)
        [21] => SELECT pid, filepath, filename, url_prefix, filesize, pwidth, pheight, ctime, aid, keywords, votes, pic_rating, title, caption,hits,owner_id,owner_name from cpg14x_pictures WHERE ((aid='384'  ) )   ORDER BY pid ASC  (0.008s)
        [22] => SELECT title,keyword from cpg14x_albums WHERE aid='384' (0s)
        [23] => SELECT COUNT(*) from cpg14x_pictures WHERE ((aid='384'  ) )   (0s)
        [24] => SELECT * from cpg14x_pictures WHERE ((aid='384'  ) )   ORDER BY pid ASC  LIMIT 16 ,1 (0.001s)
        [25] => SELECT title, comments, votes, category, aid FROM cpg14x_albums WHERE aid='384' LIMIT 1 (0s)
        [26] => SELECT name, parent FROM cpg14x_categories WHERE cid = '11' (0s)
        [27] => SELECT cid, name, parent FROM cpg14x_categories WHERE cid = '8' (0.001s)
        [28] => SELECT c.msg_id, c.msg_author, c.msg_body, UNIX_TIMESTAMP(msg_date) AS msg_date, c.author_id, c.author_md5_id, c.msg_raw_ip, c.msg_hdr_ip, c.pid, u.avatar_url AS avatar_url FROM cpg14x_comments AS c LEFT JOIN `breakingfree_se`.cpg14x_users AS u ON c.author_id=u.user_id WHERE pid='24940' ORDER BY c.msg_id ASC (0.001s)
        [29] => SELECT COUNT(*) FROM cpg14x_pictures WHERE approved = 'NO' (0s)
        [30] => SELECT title,keyword from cpg14x_albums WHERE aid='384' (0s)
        [31] => SELECT COUNT(*) from cpg14x_pictures WHERE ((aid='384'  ) )   (0s)
        [32] => SELECT pid, filepath, filename, url_prefix, filesize, pwidth, pheight, ctime, aid, keywords, votes, pic_rating, title, caption,hits,owner_id,owner_name from cpg14x_pictures WHERE ((aid='384'  ) )   ORDER BY pid ASC  LIMIT 11 ,10 (0.001s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
       
[pos] => -24940
)

==========================
POST :
------------------
Array
(
)

==========================
VERSION INFO :
------------------
PHP version: 5.3.2 - OK
------------------
mySQL version: 5.0.32-Debian_7etch11-log
------------------
Coppermine version: 1.4.26(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.34 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support: 1
GIF Read Support: 1
GIF Create Support: 1
JPEG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 5.0.32
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/run/mysqld/mysqld.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.3
Linked Version 1.2.3
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | /surely/you/must/be/joking | /surely/you/must/be/joking
safe_mode_gid | Off | Off
safe_mode_include_dir | /customers/breakingfree.se:/usr/share/php | /customers/breakingfree.se:/usr/share/php
safe_mode_exec_dir | /surely/you/must/be/joking | /surely/you/must/be/joking
sql.safe_mode | Off | Off
disable_functions | disk_total_space, diskfreespace, exec, system, popen, proc_open, proc_nice, shell_exec, passthru, dl | disk_total_space, diskfreespace, exec, system, popen, proc_open, proc_nice, shell_exec, passthru, dl
file_uploads | On | On
include_path | .:/usr/share/php | .:/usr/share/php
open_basedir | /customers/breakingfree.se/breakingfree.se:/var/www/diagnostics:/usr/share/php | /customers/breakingfree.se/breakingfree.se:/var/www/diagnostics:/usr/share/php
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | me@localhost.com | me@localhost.com
sendmail_path | /usr/sbin/b1sendmail -t -i | /usr/sbin/b1sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 12M | 12M
post_max_size | 12M | 12M
==========================
Page generated in 0.119 seconds - 33 queries in 0.055 seconds - Album set : ; Meta set: ;


I hope this is what you mean I shoud do.
Logged

hsm88

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Batch Add not working
« Reply #5 on: April 01, 2010, 11:04:33 pm »

I don't know if this have something to do with the problem I have and this is probably a stupid question. When you dowload Coppermine and then go to the themes and classic there's a file theme.php, but there isn't a file like that in the Stramm modepack so right now I haven't that file uploaded to my server. My questions is if I should upload the theme.php which I find i the Coppermine folder?
Logged

hsm88

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Batch Add not working
« Reply #6 on: April 02, 2010, 12:37:00 am »


When I did a version check I saw that seachnew.php had a red background with the number "5993". I uploaded the seachnew.php file from the new stramm mode pack again and run update.php, but it didn't help. It isn't just this file that has a red background all files that are in the coppermine (bfgallery) that comes from the mode back (admin, seachnew etc) have red backgrounds.

Is this something that is a big problem and if it's so, what can I do to fix it.




Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Batch Add not working
« Reply #7 on: April 02, 2010, 09:46:19 am »

Now I have done what I was told to do under "Upload Troubelshooting" and I got this:
No, you have not. You have done quite the opposite of what you're supposed to do. Re-read the instructions and follow them to a T.
Logged

hsm88

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Batch Add not working
« Reply #8 on: April 02, 2010, 11:53:07 am »

No, you have not. You have done quite the opposite of what you're supposed to do. Re-read the instructions and follow them to a T.


I have changed the settings in config under Maintenance settings and in the group panel and then tried uploaded a file and what I can see I didn't get any error message.

I have had problem to log in to my gallery a few times too. When I try to that it says "login was successful", but I only came back to the indexpage as I never had tried to log in. As I said before when I removed "www" I could access the gallery.

Now I remove the cookies and now I can access the admin cp without to remove www and I only have to update the "seachnew.php" once so maybe my problem was the cookies.

Logged

hsm88

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: Batch Add not working
« Reply #9 on: April 02, 2010, 07:24:26 pm »

I'll remove the test account for now. I think the whole problem is with my server because today I got a page with "500 internal server error" so I'll contact my webhost.
Logged
Pages: [1]   Go Up
 

Page created in 0.032 seconds with 20 queries.