Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Thumnails missing due to moved files  (Read 7585 times)

0 Members and 1 Guest are viewing this topic.

mearnscc

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Thumnails missing due to moved files
« on: June 10, 2009, 10:34:04 pm »

Hi,

I am a fairly inexperienced user however I had installed the FileMove Plug-in and had moved several files unsuccessfully with it. Unsuccessfully in terms of they were moved but to where god only knows, Francois thinks they have been deleted! Anyway as a result of these files being deleted the database thinks they are on the folder I moved them to however they never appeared in there and subsequently I deleted the folders as I decided the Filemove Plug-in was not for me. If I go into an album I am faced with an icon representing a "broken or missing" file and when I click on it, it gives me the option to delete however I get an error as the database is directing it to a location that does not exist, remember they were never there to begin with. I have tried deleting the album and I get the same error message in that it cannot delete as the file is not there, message is; Critical Error "Directory 'albums/userpics/TrialFolder/' is not writable, files can't be deleted"

Does anyone have any ideas how I can flush out missing files or even how I can delete/flush out all files and basically start again. The software was installed from my Web Hosting Companies Site using a Script/Tool for Coppermine so I am not sure how to go about installing from another source.

Any help appreciated.

Brian.
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1510
  • aka 'i-imagine'
    • Home Page
Re: Thumnails missing due to moved files
« Reply #1 on: June 10, 2009, 11:12:25 pm »

You would have helped yourself a lot more if you had followed the board rules for posting a help request.
  • Read the forum rules.  Post a link to your gallery
  • Read the docs, here or the ones that came with your gallery for troubleshooting and installation info.
  • Read the docs, have you tried running update.php?
  • Read the docs, your automatic installation is probably out of date and because of the issues encountered is not normally supported here

mearnscc

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Thumnails missing due to moved files
« Reply #2 on: June 11, 2009, 12:20:49 am »

You would have helped yourself a lot more if you had followed the board rules for posting a help request.
  • Read the forum rules.  Post a link to your gallery
  • Read the docs, here or the ones that came with your gallery for troubleshooting and installation info.
  • Read the docs, have you tried running update.php?
  • Read the docs, your automatic installation is probably out of date and because of the issues encountered is not normally supported here


Thanks for pointing out the error of my ways. I am not sure if you meant to come across as arrogant and self righteous as you have but that's how it appears. I said I was an inexperienced user so I don't think there was any need for the tone in your reply. I had used the search facility for various key words and it turned up not a lot for me, hence the reason why I posted a question.



Logged

mearnscc

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Thumnails missing due to moved files
« Reply #3 on: June 11, 2009, 12:23:02 am »

Logged

Nibbler

  • Guest
Re: Thumnails missing due to moved files
« Reply #4 on: June 11, 2009, 12:29:44 am »

Easiest thing to do is create the directory mentioned in the error message.
Logged

mearnscc

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Thumnails missing due to moved files
« Reply #5 on: June 11, 2009, 12:36:27 am »

Easiest thing to do is create the directory mentioned in the error message.

Thanks Nibbler, I had thought about that and what I would need to do is put (ftp) the image in there, I thought I might need to even fudge file names (normal/thumbnail etc) as if I reload the image it will not be in that location as far as the database is concerned. It appears to me the the Filemove Plugin has told the database where the file was moved to however as I mentioned that never happened and when I want to delete it the databse cannot find it to delete.

Thanks again,

Brian.
Logged

Nibbler

  • Guest
Re: Thumnails missing due to moved files
« Reply #6 on: June 11, 2009, 12:41:41 am »

Creating the directory should be enough. Alternatively you could use the 'delete all files' option in album properties or even clean the database manually using the phpmyadmin plugin.
Logged

mearnscc

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Thumnails missing due to moved files
« Reply #7 on: June 11, 2009, 01:10:35 am »

Creating the directory should be enough. Alternatively you could use the 'delete all files' option in album properties or even clean the database manually using the phpmyadmin plugin.

Nibbler, many thanks for your help, you were right creating the directory was enough however there was one other thing I needed to do and the clue was in the error message! "not writable", I had to change the properties of the Folders to be writable by "all users" and not just the owner, that seemed to do the trick as without it I was getting the same message.

Many thanks, I now have cleared the Albums out of missing files. Only thing now is I cant seem to delete the folders I created to mimic the old ones!

Cheers again,

Brian.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Thumnails missing due to moved files
« Reply #8 on: June 12, 2009, 09:18:01 pm »

This thread deals with support for a particular plugin. Moving accordingly from misc to plugin support board.
Logged

mearnscc

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Thumnails missing due to moved files
« Reply #9 on: June 12, 2009, 10:09:17 pm »

This thread deals with support for a particular plugin. Moving accordingly from misc to plugin support board.

The Plugin developer could not help me hence why I posted it here. Apologies.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Thumnails missing due to moved files
« Reply #10 on: June 13, 2009, 12:33:39 am »

Did you contact him directly? Did you post on the announcement thread for that plugin? You should have said so in your thread!
Logged

mearnscc

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: Thumnails missing due to moved files
« Reply #11 on: June 13, 2009, 01:07:10 am »

Did you contact him directly? Did you post on the announcement thread for that plugin? You should have said so in your thread!

Joachim, I was in contact with him on another thread related to another issue but connected to this and mentioned this to him. Francois was unable to take it any further.Whilst Filemove might have been the source of my problems I suppose any files deleted or moved over ftp could have similar issues as mine so i.e how to clear any broken files. I'll try and be a bit more careful where I post next time.
Logged
Pages: [1]   Go Up
 

Page created in 0.041 seconds with 21 queries.