Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1] 2   Go Down

Author Topic: Unable to upload files  (Read 12802 times)

0 Members and 1 Guest are viewing this topic.

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Unable to upload files
« on: May 24, 2009, 11:30:32 pm »

When I try to upload files (images) it doesn't work. It says "0 uploads were successful". :( the files aren't too big and I think i'm doing it right.... what do I have to change to make it work?


this is my debug info:
Quote
USER:
------------------
Array
(
    [ID] => 757cd2c66ed6dfa15a284ba023c910e3
    [am] => 1
    [lang] => german
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 0
    [user_name] => Guest
    [groups] => Array
        (
           
  • => 3

        )

    [group_quota] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 0
    [can_post_comments] => 0
    [can_upload_pictures] => 0
    [can_create_albums] => 0
    [pub_upl_need_approval] => 1
    [priv_upl_need_approval] => 1
    [upload_form_config] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [custom_user_upload] => 0
    [disk_max] => 0
    [disk_min] => 0
    [ufc_max] => 0
    [ufc_min] => 0
    [has_admin_access] => 0
    [group_name] => Anonymous
    [can_see_all_albums] => 0
    [group_id] => 3
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM cpg14x_filetypes; (0s)
  • [1] => select * from cpg14x_plugins order by priority asc; (0s)
        [2] => delete from `dusbbzek_rani`.cpg14x_sessions where time<1243196260 and remember=0; (0s)
        [3] => delete from `dusbbzek_rani`.cpg14x_sessions where time<1241990260; (0s)
        [4] => select user_id from `dusbbzek_rani`.cpg14x_sessions where session_id = '7afd40742faa2c6ef745c812590e5a1b' (0s)
        [5] => select user_id as id, user_password as password from `dusbbzek_rani`.cpg14x_users where user_id=0 (0s)
        [6] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg14x_usergroups WHERE group_id in (3) (0s)
        [7] => SELECT group_name FROM  cpg14x_usergroups WHERE group_id= 3 (0s)
        [8] => update `dusbbzek_rani`.cpg14x_sessions set time='1243199860' where session_id = '7afd40742faa2c6ef745c812590e5a1b' (0s)
        [9] => DELETE FROM cpg14x_banned WHERE expiry < '2009-05-24 17:17:40' (0s)
        [10] => SELECT * FROM cpg14x_banned WHERE (ip_addr='62.203.56.10' OR ip_addr='62.203.56.10' OR user_id=0) AND brute_force=0 (0s)
        [11] => SELECT aid FROM cpg14x_albums WHERE visibility != '0' AND visibility !='10000' AND visibility NOT IN (3) (0s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
    )

    ==========================
    Page generated in 1243199860.78 seconds - 12 queries in 0 seconds - Album set : ; Meta set: ;
and this my gallery: http://rani.nocturn-glare.net/gallery/

I'm new to coppermine and also not especially talented in technical stuff. I've read the upload trouble file but I couldn't find anything helpful for me there... also it's written in a very complicated way, for a newbie like me...

I'm aware that my problem is probably a common one and you're maybe tired of re-thinking the whole thing over and over again. But I so wanna make this work. I'm very excited about having my coppermine gallery at last...

Thanks a lot for your help! It is very appreciated.
Logged

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Unable to upload files
« Reply #1 on: May 24, 2009, 11:42:04 pm »

oh and I checked the troubleshooting file again... i've done everything like you said like the 777 thing... the only thing i haven't tried is the "php.ini" because i dunno where it's located and what i'd have to do.

also i feel the problem might be elsewhere too.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: Unable to upload files
« Reply #2 on: May 25, 2009, 12:15:14 am »

Could you do everything outlined in the following section of the docs.

http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_trouble

In future, please do not post debug output unless asked.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Unable to upload files
« Reply #3 on: May 25, 2009, 12:24:30 am »

i'm sorry. i didn't know. i saw that others did it so i thought it might help resolving the problem...

i read that file but it doesn't help me. it's too complicated for someone like me who's all new to this. plus, english isn't even my mother language.... :-[ i'll try again but i don't think it'll help.

Logged

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Unable to upload files
« Reply #4 on: May 25, 2009, 12:36:42 am »

ok i did as suggested. this is the more specific error message i get: the album doesn't exist or you're not allowed to upload file into this album.

unfortunately my gallery is in german, i dunno why, and i can't seem to change it into english... which makes the whole thing harder for me.

i also set up that test user (if i did it right). pm me for the password cuz i don't want to give it to anyone...



Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Unable to upload files
« Reply #5 on: May 25, 2009, 12:57:51 am »

In fact you're wasting our time: you have an identical thread open on the German support board. This only causes extra effort. Decide for one thread. Resolve the other thread by posting reference to the other thread. You have registered two days ago, but you have broken a lot of board rules already. Stop misbehaving.
Logged

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Unable to upload files
« Reply #6 on: May 25, 2009, 01:15:49 am »

well i'm sorry. nobody was willing to help me on the German board.

PLUS.... indeed, i'm only here two days so i'm not familiar with all the rules. Coppermine is very complicated and confusing for a newbie. Maybe you keep forgetting this because you more advanced than me.

i'm sorry if i do things the wrong way, i don't do it on purpose... i really try to follow the rules but i've never been on a forum that is so complicated with rules, files etc. there's no need to be rude with me...
i'm willing to do everything by rules. look above... someone directed me to the troubleshooting file and i did as they said... have a little patience with beginners. thanks.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Unable to upload files
« Reply #7 on: May 25, 2009, 08:34:52 am »

well i'm sorry. nobody was willing to help me on the German board.
That's a lie - just judging by the fact that nobody answered within minutes, aren't you? The forum is not a hotline. Allow days for answers, not only hours. The thread in question is Kann keine Dateien raufladen- Was mach ich falsch? and you got an answer only six hours after starting your initial posting.

PLUS.... indeed, i'm only here two days so i'm not familiar with all the rules.
You're not even allowed to start one single posting if you haven't read the board rules. You agreed to respect them when signing up. What's so comlicated about that? Being a newbie does not mean that you're allowed to post your questions right away. Being a newbie means that you should read first and only asked if reading and extensive searching hasn't helped.

Coppermine is very complicated and confusing for a newbie. Maybe you keep forgetting this because you more advanced than me.
I am aware that it is a non-trivial piece of software that requires some reading. It is not self-explanatory. That's why we provide documentation that goes with it.

i really try to follow the rules but i've never been on a forum that is so complicated with rules
That's a lie again: nearly every board in the world has got rules. You just never bothered to read them, that's why.

there's no need to be rude with me...
So far, I haven't been rude to you. However, the attitude you showed by your last reply deserves some snide remarks.

look above... someone directed me to the troubleshooting file and i did as they said
No you have not. Upload troubleshooting section says that you're suppossed to post a non-admin test user account. You failed to post that account. Instead, you offer to send it by PM, which is uncalled for. Do as suggested, it's not up to you to make up the rules.

Re-read the upload troubleshooting section that I told you to read in the first place and do exactly as suggested there if you want help.
Logged

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Unable to upload files
« Reply #8 on: May 25, 2009, 07:35:42 pm »

i'm sorry for bothering people here. to show that i do not intend to break rules i set up a protocol documenting exactly what i've done by the troubleshooting doc:

troubleshooting protocol

1.Enable debug mode for everyone DONE

2.Set the upload form configuration for all groups to "Single file uploads only"

   1. set File upload boxes to "1" (1)
   2. set URI upload boxes to "0" (2)
   3. set No. of boxes to "fixed" (3)
  DONE

3.post a link to your site and a test user account (the test user mustn't be in the admin group!)

user: test
password: coppermine

(i thought at first the test user had to be admin, thats why I hesitated to give the info at first)

4. you should disable admin approval for the group the test user is in

i'm not 100% sure what that means but i dont think i have that on.

5. you should get a more detailed error message that tells you what exactly goes wrong with your uploads.

detailed error message I got: the album doesn't exist or you're not allowed to upload file into this album


sorry if i was impatient. i'm having important exams for  med school coming up soon and time is totally precious to me at this point and i'm extremely stressed out at the moment, so i might've been out of place. sorry and thanks for the help you're offering.

Logged

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Unable to upload files
« Reply #9 on: May 25, 2009, 07:36:40 pm »

oh and this is the link to my gallery again: http://rani.nocturn-glare.net/gallery/
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Unable to upload files
« Reply #10 on: May 25, 2009, 07:49:54 pm »

The "Powered by Coppermine" is rendered invisible (white text on white background). You claim to be a newbie. yet the first thing you actually manage to do is crippling the output of the tag that is mandatory to keep. No support for you with the tag rendered invisible!
Logged

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Unable to upload files
« Reply #11 on: May 25, 2009, 10:14:46 pm »

I've already said that in the other thread. that's my first try in change the coppermine stylesheet and everything. I changed colors into the blue... I had no clue which tag was for which function. so it's not at all finished yet. I told the person in that thread that i'll change that later.

If you can tell me the exact spot in the stylesheet where the color tag for the coppermine link is located i'll immediately change that. I just don't have time to redo the whole css right now...

there's not always a bad thought behind everything.
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: Unable to upload files
« Reply #12 on: May 25, 2009, 10:37:46 pm »

I wouldn't normaly do a simple bit of css work for you but.

The colour of the text can be found here. Change #FFFFFF to your desired colour.

style.css (line 464)

Code: [Select]
.footer a {
color:#000000;
text-decoration:none;
}

And for when the mouse hovers over the link. Change #FFFFFF to your desired colour.

style.css (line 469)

Code: [Select]
.footer a:hover {
color:#FFFFFF;
text-decoration:underline;
}
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1543
  • aka 'i-imagine'
    • Home Page
Re: Unable to upload files
« Reply #13 on: May 25, 2009, 10:39:00 pm »

What version of Coppermine are you using?

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Unable to upload files
« Reply #14 on: May 25, 2009, 10:42:08 pm »

the newest i guess. i only downloaded it a few days ago...
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4885
    • Windsurf.me
Re: Unable to upload files
« Reply #15 on: May 25, 2009, 10:58:31 pm »

What version of Coppermine are you using?

We already know rani is using 1.4.23 but we need to get the footer sorted before we can help, that is why I posted the above code.

I know you are trying to help but please read earlier posts to see what has gone on before.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1543
  • aka 'i-imagine'
    • Home Page
Re: Unable to upload files
« Reply #16 on: May 25, 2009, 11:11:13 pm »

Apologies, the version was not readily apparent whilst viewing the page source with his default theme. The sample theme was more revealing. There is/was no intent of providing any advice when the footer issue is still outstanding.  :)

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Unable to upload files
« Reply #17 on: May 25, 2009, 11:29:06 pm »

Thank you Phill for the css hint. I've changed it now. I hope it's readable enough now!
(I'll change the whole layout to something darker soon. this is just a temporary thing anyway)

@i-imagine: thanks for trying to help anyway!  :)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Unable to upload files
« Reply #18 on: May 25, 2009, 11:30:13 pm »

I told the person in that thread that i'll change that later.
That's not acceptable to change that later. Change it immediately. You will not get support at all unless you restore it. I have had enough of your attitude - it stinks!
Logged

rani

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: Unable to upload files
« Reply #19 on: May 25, 2009, 11:51:54 pm »

maybe you read my post above :)
Logged
Pages: [1] 2   Go Up
 

Page created in 0.026 seconds with 20 queries.