Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Next version will only support php 5+  (Read 3680 times)

0 Members and 1 Guest are viewing this topic.

vuud

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1803
  • [cpmfetch.fistfullofcode.com]
    • Fist Full Of Code
Next version will only support php 5+
« on: May 13, 2009, 06:31:12 am »

Hallo all.

The rumors of my death / incarceration / mauling / change of planet have been exaggerated slightly.

I'm making slow progress on the next version of CpmFetch which is a ground up rewrite into a more pure OO architecture, with an aim to be more extensible into the different outputs, etc.  To the layperson this means it will not work with PHP4 and some early versions of 5.  With PHP6 looming on the horizon I have to see where my time may be best spent. 

Expect beta's within a month.  I am not sure they will be up to 100% functionality of the existing CpmFetch's feature set, but will hold amazing wonder for more advanced users of this.

I hoped this would be done now, but I ended up on some massive projects that have eaten up my life. 

Hope all is well, and take care in the meantime.

Vuud
Logged
Please post for help to the forum... PM me only if you are sending security related items (passwords, security problems, etc).

cpmFetch - Images, RSS feeds from CPG from outside CPG
New release notification signup also. 
See http://cpmfetch.fistfullofco

fangweile

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Posts: 103
  • Saranghaeyo ^_^
    • All Koreans - Home of Korean Actors and Actresses
Re: Next version will only support php 5+
« Reply #1 on: May 13, 2009, 09:15:24 am »

Hello vuud, I am glad that your back :D:, I am really happy to hear this great development from you. I am looking forward for it Vuud. Thanks again for your wonderful script.
Logged
[My Coppermine Galleries]
All Koreans, Lim Eun-kyeong's IFC
Saranghae 김태희

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4850
    • Windsurf.me
Re: Next version will only support php 5+
« Reply #2 on: May 13, 2009, 10:44:35 am »

We thought you had been kidnapped by aliens. Glad they returned you.

Looking forward to the new release. I've been using cpmfetch for ages and it is worth it's weight in gold.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

vuud

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1803
  • [cpmfetch.fistfullofcode.com]
    • Fist Full Of Code
Re: Next version will only support php 5+
« Reply #3 on: May 18, 2009, 07:28:14 pm »

We thought you had been kidnapped by aliens. Glad they returned you.

Looking forward to the new release. I've been using cpmfetch for ages and it is worth it's weight in gold.

Thanks guys, I appreciate it - hopefully the versatility will be worth the wait.







Logged
Please post for help to the forum... PM me only if you are sending security related items (passwords, security problems, etc).

cpmFetch - Images, RSS feeds from CPG from outside CPG
New release notification signup also. 
See http://cpmfetch.fistfullofco
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.