Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Fatal error:..... (tried to allocate ...public_html/gfxalbum/include/functions.  (Read 4833 times)

0 Members and 1 Guest are viewing this topic.

Conditor

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25

Hello,

Something strange happened to my gallery..
When i tried to visit it today i got this message on my screen:

Fatal error: Allowed memory size of 6291456 bytes exhausted (tried to allocate 282560 bytes) in /home/gfxcondi/public_html/gfxalbum/include/functions.inc.php on line 2095

I have 2 galleries on the same webspace and the other one works perfect.
I did a search here on the forums and what i've found so far is to chagne the php.ini.. But i'm not the server admin so can't reach it, and the other sollutions all offered to rezise the image before uploading.

But the thing is, i didn't upload anything.. i just tried to login.. The error points me to /home/gfxcondi/public_html/gfxalbum/include/functions.inc.php on line 2095 and on that line i find 
Code: [Select]
include('lang/'.$language.'.php');
I have no idea what to do to solve this..
If someone would be so nice to point me in the right direction. Maybe i just missed it.. or maybe i don't know enough about all that programming.. well i'm sure i don't know enough ;-)

Any help would be appriciated, thanks in advance!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de

Something strange happened to my gallery..
Not so strange. In fact quite common. To be exact: that's so common that we even have a sticky thread and a section in the docs about that error message. We have board rules as well that you should read first - I think we already told you so... ::)
Logged

Conditor

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25

Hello,

I did a search here on the forums and what i've found so far is to change the php.ini.. But i'm not the server admin so can't reach it, and the other sollutions all offered to rezise the image before uploading.

But the thing is, i didn't upload anything.. i just tried to login.. The error points me to /home/gfxcondi/public_html/gfxalbum/include/functions.inc.php on line 2095 and on that line i find 
Code: [Select]
include('lang/'.$language.'.php');
I have no idea what to do to solve this..
If someone would be so nice to point me in the right direction. Maybe i just missed it.. or maybe i don't know enough about all that programming.. well i'm sure i don't know enough ;-)

Any help would be appriciated, thanks in advance!

I did the search, and the solution offered there.. change the php.ini isn't possible as i write in the post since i'm not a server admin.

Also the other solutions can't help me.. To rezise a image you first need to upload one.. i didn't do that.. i get the error at the very first attempt of going to my gallery.
The 3th solution to use a program to rezise isn't possible either.. So as i asked polite maybe i missed something, or i overlooked something, so is there something i can do about it?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de

So as i asked polite maybe i missed something, or i overlooked something
Yes:
We have board rules as well that you should read first
You need to be told in detail obviously: where's the link to your gallery that you're supposed to post?

change the php.ini isn't possible as i write in the post since i'm not a server admin.
So what? Then ask the webserver admin - your webhost. How should we possibly be able to do that for you? If you don't have enough resources, then you probably can't run coppermine. To be able to tell you where you possibly could save resources we'd need to see your site, which we can't, as you failed to post a link to your gallery. I'm really not keen to have to beg for that simple thing constantly.
Logged

Conditor

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25

the link is no problem at all, here it is:

http://www.gfxconditor.info/gfxalbum

I'm not able to make a username and password since i can't get further then the first page where the error is displayed.
Sorry, i wasn't sure the link was needed in this subject. So sorry i didn't provide the link in the starting post.

Thanks for pointing me out what to do to get support.
Logged

Conditor

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25

and to add.. i did check the rights on the maps as suggested, they are 777 for all maps in "albums"
Not sure if the map albums is relevant in this error. Like i said.. cleuless
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de

I only get an empty screen no matter what page I try to access - even pages that burn no ressources at all are blank. Upgrade for a start, you appear to be running one version behind. I'm not sure though that this will cure your issues.
Logged

Conditor

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25

Ok, shall i inform u after the upgrade if the problem doesn't go away?
Logged

Conditor

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25

Hello,

Thanks for the help, i did do an upgrade to the recent version.. While i was doing that my host changed the memory usage in the php.ini from 6mb to 32mb.. so one of those solved the problem, most likely the change of the memory in the php.ini..

Thanks again for the support ;-)
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.