Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Categories Shows as Empty  (Read 2562 times)

0 Members and 1 Guest are viewing this topic.

mylogon

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 59
Categories Shows as Empty
« on: March 24, 2009, 07:50:06 am »

I installed CPM and had no problems with that, integrated it with Advance Guestbook, no problems, but for some reason, even though when I uploaded pics as aim using the XP upload script  -it decided to make them a user gallery.  I thought no problem, I will move the gallery up into the no category galleries.  Well, even though there is a user gallery and a non user gallery, when I go to categories it shows nothing, no user galleries and nothing else.  So the gallery shows up under my user admin name.   BAAAD. 

I have never had nothing show up under Categories, and not be able to move files before.  I even tried resetting to the default theme, but still no categories show up in the admin control panel.

Anyone have any ideas, as this is a memorial website for a friend that died over the week end and do not ant to lose the views before the service on Wednesday by trying to reinstall.

I have about twenty other installation that all work (installed through either Cpanel or Fantastico) and regularly move galleries with no problems.  But no galleries even are displayed?

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Categories Shows as Empty
« Reply #1 on: March 24, 2009, 07:55:41 am »

So the gallery shows up under my user admin name.   BAAAD. 
That's what happens if you as admin use personal galleries as well. Use public one instead.

I have never had nothing show up under Categories, and not be able to move files before.  I even tried resetting to the default theme, but still no categories show up in the admin control panel.
We've run out of crystal balls, so maybe you could post a link instead making us guess the URL your issue is about.

Anyone have any ideas, as this is a memorial website for a friend that died over the week end and do not ant to lose the views before the service on Wednesday by trying to reinstall.
Re-installing is pointless.

I have about twenty other installation that all work (installed through either Cpanel or Fantastico) and regularly move galleries with no problems.
Fantastico sucks. Auto-installers go unsupported. Make those galleries reallly coppermine-driven by performing an update as we suggest in our docs and promise you'll never use an auto-installer crap again ;).
Logged

mylogon

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 59
Re: Categories Shows as Empty
« Reply #2 on: March 24, 2009, 08:04:05 am »

http://www.ryanmcquade.net/gallery

I used the Cpanel install, and I know sometimes they have problems, but this is over 20 tims I have done without these problems, and as a web hosting provide there is no way I can count on users to update their installations with patches, so I am stuck with something that will tell me when a user does not update and then I can warn them, and either update or disable their installation.

I used the XP file upload script and had it set to no category, which should not have defaulted to a user gallery.  I did not think an admi could even have a gallery - but I never tried to create a user gallery as an admin...


Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Categories Shows as Empty
« Reply #3 on: March 24, 2009, 08:06:47 am »

XP Publisher is a tool meant for non-admin users. All uploads performed by XP publisher go into the user gallery.
You as admin should use FTP-upload plus batch-add, nothing else.

As I suspected, your gallery is outdated - so much for the brilliant cpanel install. Upgrade as we suggest in our docs.
Logged

mylogon

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 59
Re: Categories Shows as Empty
« Reply #4 on: March 24, 2009, 08:13:06 am »

What ftp upload, as most fail , from the nibbler script to the juplaod, at least half the time?  Even the batch upload crashs at least that often.  And yes, I have some servers that I do total manual installs, but still have the update problem, as no one has written either an rpm, or a user-enabled update script  -or even something that does a version check. to let you know you need to update.



Logged

mylogon

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 59
Re: Categories Shows as Empty
« Reply #5 on: March 24, 2009, 08:17:51 am »

And yes, you are correct that they are only on version 1.4.18.
Logged

mylogon

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 59
Re: Categories Shows as Empty
« Reply #6 on: March 24, 2009, 08:25:34 am »

I created a new category, uploaded as admin while viewing galleries as not standard, but still no categories show up in control panel. Are you saying this was a bug in 1.4.18, as I do not see that in the changelog.
Logged

mylogon

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 59
Re: Categories Shows as Empty
« Reply #7 on: March 24, 2009, 08:37:49 am »

FYI - I just checked two galleries, both use XP upload and neither go into user galleries, since they upload as admin.  Sometimes that is all I can train a user for....

If you have an idea where that data is stored, as I have checked in mysql and cannot find the pointers to what gallery  -but since even with three categories no show up in the category editor - I am thinking I am out of look.

Any thoughts, especially if they help, would be appreciated...

Logged

mylogon

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 59
Re: Categories Shows as Empty
« Reply #8 on: March 24, 2009, 08:51:28 am »

I manually created categories in mysql and moved the files.  Still curious if this is a old bug that is not listed in the changelog, though...
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Categories Shows as Empty
« Reply #9 on: March 24, 2009, 05:33:03 pm »

We're not ready to discuss the need to upgrade to the most recent stable. Either upgrade or fix things on your own. Your choice.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 21 queries.