Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: problem - 0 uploads were successful.  (Read 4488 times)

0 Members and 1 Guest are viewing this topic.

amccoy

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
problem - 0 uploads were successful.
« on: March 21, 2009, 03:58:19 pm »

I have looked around on the forum and have seen that people have had this problem but have not found a solution.

link to site : http://www.gwocni.co.uk/image_gallery

user details : username: "test" and pass: "pa55word"

Thanks in advance for any help
Logged

Nibbler

  • Guest
Re: problem - 0 uploads were successful.
« Reply #1 on: March 21, 2009, 04:02:11 pm »

You need to set your upload settings exactly as described in the upload troubleshooting section in the manual. Also, you need to update to 1.4.21, the current version of Coppermine.
Logged

amccoy

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: problem - 0 uploads were successful.
« Reply #2 on: March 21, 2009, 04:14:12 pm »

The thing i dont get is that it has worked for 290 images then it has suddenly stopped working. I am currently updating thanks for telling me about the update.
Logged

amccoy

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: problem - 0 uploads were successful.
« Reply #3 on: March 21, 2009, 05:47:16 pm »

I have updated to the latest (1.4.21) and the problem still exists. How come it stopped uploading properly when it got to 290 images and worked perfectly before that? hmmm.
Logged

Nibbler

  • Guest
Re: problem - 0 uploads were successful.
« Reply #4 on: March 21, 2009, 05:54:38 pm »

You're not providing enough information for us to answer that question. You need to configure your upload settings for troubleshooting as described in the documentation.
Logged

amccoy

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: problem - 0 uploads were successful.
« Reply #5 on: March 21, 2009, 06:06:17 pm »

USER:
------------------
Array
(
    [ID] => 03d1fc64e9702f3e61a54a1f1a871df4
    [am] => 1
    [lang] => english
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => admin
    [groups] => Array
        (
           
  • => 1

        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM cpg_filetypes; (0s)
  • [1] => select * from cpg_plugins order by priority asc; (0s)
        [2] => delete from `gwocni_copp1`.cpg_sessions where time<1237651604 and remember=0; (0s)
        [3] => delete from `gwocni_copp1`.cpg_sessions where time<1236445604; (0s)
        [4] => select user_id from `gwocni_copp1`.cpg_sessions where session_id = 'e8a52f4c68b6ce7828585c3fe113bdfc' (0s)
        [5] => select user_id as id, user_password as password from `gwocni_copp1`.cpg_users where user_id=1 (0s)
        [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `gwocni_copp1`.cpg_users AS u INNER JOIN `gwocni_copp1`.cpg_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
        [7] => SELECT user_group_list FROM `gwocni_copp1`.cpg_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
        [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg_usergroups WHERE group_id in (1) (0s)
        [9] => SELECT group_name FROM  cpg_usergroups WHERE group_id= 1 (0s)
        [10] => update `gwocni_copp1`.cpg_sessions set time='1237655204' where session_id = 'e8a52f4c68b6ce7828585c3fe113bdfc' (0s)
        [11] => SELECT user_favpics FROM cpg_favpics WHERE user_id = 1 (0s)
        [12] => DELETE FROM cpg_banned WHERE expiry < '2009-03-21 17:06:44' (0s)
        [13] => SELECT * FROM cpg_banned WHERE (ip_addr='90.213.6.171' OR ip_addr='90.213.6.171' OR user_id=1) AND brute_force=0 (0s)
        [14] => SELECT cid, name, description, thumb FROM cpg_categories WHERE parent = ''  ORDER BY pos (0s)
        [15] => SELECT aid FROM cpg_albums as a WHERE category>=10000 (0s)
        [16] => SELECT count(*) FROM cpg_pictures as p, cpg_albums as a WHERE p.aid = a.aid AND approved='YES' AND category >= 10000 (0s)
        [17] => SELECT cid, name, description, thumb FROM cpg_categories WHERE parent = '1'  ORDER BY pos (0s)
        [18] => SELECT aid FROM cpg_albums as a WHERE category = '0' (0s)
        [19] => SELECT count(*) FROM cpg_albums as a WHERE 1 (0s)
        [20] => SELECT count(*) FROM cpg_pictures as p LEFT JOIN cpg_albums as a ON a.aid=p.aid WHERE 1 AND approved='YES' (0s)
        [21] => SELECT count(*) FROM cpg_comments as c LEFT JOIN cpg_pictures as p ON c.pid=p.pid LEFT JOIN cpg_albums as a ON a.aid=p.aid WHERE 1 (0s)
        [22] => SELECT count(*) FROM cpg_categories WHERE 1 (0s)
        [23] => SELECT sum(hits) FROM cpg_pictures as p LEFT JOIN cpg_albums as a ON p.aid=a.aid WHERE 1 (0s)
        [24] => SELECT COUNT(*) FROM cpg_pictures WHERE approved = 'NO' (0s)
        [25] => SELECT count(*) FROM cpg_albums as a WHERE category = '0' (0s)
        [26] => SELECT a.aid, a.title, a.description, category, visibility, filepath, filename, url_prefix, pwidth, pheight FROM cpg_albums as a LEFT JOIN cpg_pictures as p ON a.thumb=p.pid WHERE category=0 ORDER BY a.pos LIMIT 0,12 (0s)
        [27] => SELECT a.aid, count( p.pid )  AS pic_count, max( p.pid )  AS last_pid, max( p.ctime )  AS last_upload, a.keyword FROM cpg_albums AS a  LEFT JOIN cpg_pictures AS p ON a.aid = p.aid AND p.approved =  'YES' WHERE a.aid IN (2, 3, 4, 5, 6, 1, 7, 9, 10, 11, 12, 14)GROUP BY a.aid (0s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
    )

    ==========================
    VERSION INFO :
    ------------------
    PHP version: 5.2.6 - OK
    ------------------
    mySQL version: 5.0.67-community
    ------------------
    Coppermine version: 1.4.21(stable)
    ==========================
    Module: GD
    ------------------
    GD Version: bundled (2.0.34 compatible)
    FreeType Support: 1
    FreeType Linkage: with freetype
    T1Lib Support:
    GIF Read Support: 1
    GIF Create Support: 1
    JPG Support: 1
    PNG Support: 1
    WBMP Support: 1
    XPM Support: 1
    XBM Support: 1
    JIS-mapped Japanese Font Support:

    ==========================
    Module: mysql
    ------------------
    MySQL Supportenabled
    Active Persistent Links 0
    Active Links 1
    Client API version 5.0.67
    MYSQL_MODULE_TYPE external
    MYSQL_SOCKET /var/lib/mysql/mysql.sock
    MYSQL_INCLUDE -I/usr/include/mysql
    MYSQL_LIBS -L/usr/lib -lmysqlclient 
    ==========================
    Module: zlib
    ------------------
    ZLib Support enabled
    Stream Wrapper support compress.zlib://
    Stream Filter support zlib.inflate, zlib.deflate
    Compiled Version 1.2.3
    Linked Version 1.2.3
    ==========================
    Server restrictions (safe mode)?
    ------------------
    Directive | Local Value | Master Value
    safe_mode | Off | Off
    safe_mode_exec_dir | no value | no value
    safe_mode_gid | Off | Off
    safe_mode_include_dir | no value | no value
    safe_mode_exec_dir | no value | no value
    sql.safe_mode | Off | Off
    disable_functions | no value | no value
    file_uploads | On | On
    include_path | .:/usr/lib/php:/usr/local/lib/php | .:/usr/lib/php:/usr/local/lib/php
    open_basedir | no value | no value
    ==========================
    email
    ------------------
    Directive | Local Value | Master Value
    sendmail_from | no value | no value
    sendmail_path | /usr/sbin/sendmail -t -i | /usr/sbin/sendmail -t -i
    SMTP | localhost | localhost
    smtp_port | 25 | 25
    ==========================
    Size and Time
    ------------------
    Directive | Local Value | Master Value
    max_execution_time | 30 | 30
    max_input_time | 60 | 60
    upload_max_filesize | 1000 | 1000
    post_max_size | 8M | 8M
    ==========================
    Page generated in 0.056 seconds - 28 queries in 0 seconds - Album set : ; Meta set: ;
Logged

amccoy

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: problem - 0 uploads were successful.
« Reply #6 on: March 21, 2009, 06:07:16 pm »

cant edit my posts and forgot to ask is that the information you need?
Logged

Nibbler

  • Guest
Re: problem - 0 uploads were successful.
« Reply #7 on: March 21, 2009, 06:36:43 pm »

Logged

Radek7

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: problem - 0 uploads were successful.
« Reply #8 on: March 22, 2009, 06:22:39 am »

Hi,
  I just had the same problem and in my case it seem to be missing Imagemagick. I am new to Coppermine, so I just change Config->Files and thumbnails advanced settings->Method for resizing images = GD version 2.x and everything is working.


             Radek
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: problem - 0 uploads were successful.
« Reply #9 on: March 22, 2009, 12:26:34 pm »

Hi,
  I just had the same problem and in my case it seem to be missing Imagemagick. I am new to Coppermine, so I just change Config->Files and thumbnails advanced settings->Method for resizing images = GD version 2.x and everything is working.


             Radek

Thanks for your readiness to help, but the error message "0 uploads were successful." can be caused by many things, as it is a generic error message. One of the possible reasons can be the wrong image library picked. However, that's just blindly guessing one of many possible causes for the error. This being said, the thread starter should do as suggested in the docs and set the upload configuration as suggested in the docs, which will lead to an actual error message showing through instead of displaying the generic "something is wrong" message. Posting the debug_ouput definitely doesn't fall into the category "doing as suggested in the docs".
Logged

amccoy

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: problem - 0 uploads were successful.
« Reply #10 on: March 22, 2009, 03:54:47 pm »

This being said, the thread starter should do as suggested in the docs and set the upload configuration as suggested in the docs, which will lead to an actual error message showing through instead of displaying the generic "something is wrong" message. Posting the debug_ouput definitely doesn't fall into the category "doing as suggested in the docs".
I did read the docs they told me to but it in debug mode and create a test user. Yet i still got the same error. I only asked as i had tried what was suggested in the docs and got no result and also searched the forum and got nothing that helped me.

I checked and it is already set to GD version 2.x Thanks for the suggestion though.

I uninstalled the image gallery and did a fresh install through Fantastico and i am now getting the error "No file was uploaded !

If you have really selected a file to upload, check that the server allows file uploads...

File: /home/gwocni/public_html/image_gallery/db_input.php - Line: 311 "

Here is what it says on that line "        if ($_FILES['userpicture']['tmp_name'] == '') cpg_die(ERROR, $lang_db_input_php['no_pic_uploaded'], __FILE__, __LINE__);"

I hope this is enough information for you to help me

AMcCoy
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: problem - 0 uploads were successful.
« Reply #11 on: March 23, 2009, 09:32:56 am »

I uninstalled the image gallery and did a fresh install through Fantastico
Auto-installers like Fantastico suck and go unsupported by us. Perform a real install or upgrade as we suggest in the docs we provide if you want support.

If you have really selected a file to upload, check that the server allows file uploads...
Does your server allow file uploads then? Did you check in phpinfo? Does a temporary PHP upload folder exist and is it configured to allow uploads by the user your account runs under? Check with your webhost.

link to site : http://www.gwocni.co.uk/image_gallery

user details : username: "test" and pass: "pa55word"
Test user account doesn't work for me.

also searched the forum and got nothing that helped me.
That's amazing. Searching for If you have really selected a file to upload, check that the server allows file uploads shows a list of results that is 4 pages long. Many of the threads on the results page apply to you, e.g. http://forum.coppermine-gallery.net/index.php/topic,58177.msg285877.html#msg285877 or http://forum.coppermine-gallery.net/index.php/topic,51800.msg251010.html#msg251010
It hurts, having to post the same answer over and over... ::)
Logged
Pages: [1]   Go Up
 

Page created in 0.032 seconds with 20 queries.