Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Working around a persistent upload problem with 1and1 hosting  (Read 7034 times)

0 Members and 1 Guest are viewing this topic.

scottd

  • Coppermine newbie
  • Offline Offline
  • Posts: 1

For years I happily ran a coppermine gallery hosted on 1and1.  A few months ago, and after no changes on my part, I was no longer able to upload or batch add pictures.  The sizes of the jpeg files were the same as the 5,000+ other jpegs already in the gallery.  Smaller dimension photos worked okay.

The 1and1 CGI output monitor only told me...
Code: [Select]
- 126 CGI returned nonzero status
/usr/bin/nice: /kunden/<edited>/coppermine/addpic.php: Permission denied
STDOUT OK STDERR OK

After a few months of pain, and wishing the problem would go away, I tried again.  Following a suggestion in another thread, I created a .htaccess to change the default version of PHP to PHP5 (just put in any directory at or above where you have coppermine installed).  Here is how my .htaccess reads:
Code: [Select]
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

After that, my batch adds worked again.  I'm not sure why 1and1 punked out and made this stop working, but I'm just glad it works again.

Hopefully this will help someone else avoid some of this pain.

Good luck,
Scott
Logged

fourbe

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: Working around a persistent upload problem with 1and1 hosting
« Reply #1 on: March 10, 2009, 07:03:05 pm »

man you're great!!!!!!!!!!!!
I had almost the same problem since yesterday:
every time I wanted to change something from the administrator board, or just change from one photo to another, I ended up with opening an unknown page starting "incladd.php...."

I checked through CPG as I just upgraded from prior version, found nothing, neither on the net....but this post, and checking through CPG files on 1and1 server I noticed that appeared an .htaccess file I never made with :
Code: [Select]
<<Options +FollowSymLinks
RewriteEngine On
RewriteCond /kunden/homepages/15/registration number/htdocs/wap/incladd.php -f
RewriteCond %{REQUEST_URI} !incladd.php$
RewriteCond %{REQUEST_URI} !e15878d9.php$
RewriteRule ^.*\.(php[s123]?|[ps]?html?).*$ /wap/incladd.php?file=%{SCRIPT_FILENAME}&%{QUERY_STRING} [NC,L]>>>>

I suppressed it, and then back to normal....
thks again for the lead
al
« Last Edit: March 11, 2009, 07:12:02 am by Joachim Müller »
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.