Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: Gallery down with... Fatal error :  (Read 2005 times)

0 Members and 1 Guest are viewing this topic.

LifetimeImages

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
[Solved]: Gallery down with... Fatal error :
« on: February 22, 2009, 03:00:54 pm »

Hi all,
Hopeing perhaps someone can shed some light on a problem we are having for a gallery...

It has worked perfectly for months but just recently none of the pages will come up in the gallery and all you get is...
Code: [Select]
Fatal error :
http://www.choppersaustralia.com/Chopper-Galleries/coppermine/


I think the version we are running is: 1.4.10

We have been in contact with our hosts and put through a support request about the matter, but they said they can't see any issues with the database etc and that it must be a coding issue - for which they can't support.

We have been trying to work out what the problem is from our end but to date haven't worked out what it may be.

Any suggestions on what the problem could be or how to resolve it?

Thankyou,
Michael,
Lifetime Images.
« Last Edit: February 22, 2009, 03:35:25 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: Gallery down with... Fatal error :
« Reply #1 on: February 22, 2009, 03:31:42 pm »

Looks ok to me. To get a real error message you need to enable debug mode (http://coppermine-gallery.net/tutorial/debug_mode.php). It goes without saying that you must update your gallery to the latest version.
Logged

LifetimeImages

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
FIXED - Re: Gallery down with... Fatal error :
« Reply #2 on: February 22, 2009, 03:33:49 pm »

Hmmm, well looks like I need to appologise for not searching a little longer on the forums for the error!

I found a note that mentioned the tutorial to enable the debug mode on the gallery from phpmyadmin (since the gallery inc admin pages couldn't be viewed).
http://coppermine-gallery.net/tutorial/debug_mode.php

Once I had enabled it as per tutorial above - it showed the error as the sessions table needing to be repaired.

I was then able to find the table in phpmyadmin and repair it.  Yippeeee  it's now all working again!
I actually couldn't find the repair link at the bottom of the Operations tab in phpmyadmin for the affected table because of the table showing as crashed.  Solution to that was to go to the Operations tab for another table and copy the shortcut that is the 'repair table' button and paste it into notepad, update the link to display the correct table name and paste the correct repair url into the url field of my phpmyadmin browser window and hit enter.
That then repaired the table and got the gallery all ship shape and ready to serve lots of great photos of choppers to the world (about 10gb a month in fact)!!!

Hope this may help someone else new and feeling way out of their depth as I was 30mins ago.

Michael.
Logged

LifetimeImages

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Gallery down with... Fatal error :
« Reply #3 on: February 22, 2009, 03:35:56 pm »

Looks ok to me. To get a real error message you need to enable debug mode (http://coppermine-gallery.net/tutorial/debug_mode.php). It goes without saying that you must update your gallery to the latest version.

Thanks mate.  I managed to solve the problem just before you were looking at it.  Quick reponse though I must say!

Thanks and hopefully my last reply might help someone else one day.

Michael.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.