Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problem with mail  (Read 8434 times)

0 Members and 1 Guest are viewing this topic.

dgitan

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Problem with mail
« on: February 13, 2009, 03:37:53 pm »

I have a real big problem....
I install the new version of CPG without any trouble . All works perfectly execpt the mail function.
I try everything ( sendmail, mail , SMTP , gmail as SMTP ) and nothing work.
I receive all the time the message ( with SMTP ) : SMTP -> ERROR: Failed to connect to server: Connection timed out (110)
with mail or sendmail no error message, but I receive nothing.

I check my hosting server with this code :

Code: [Select]
############### Code

<?

// ---------------- SEND MAIL FORM ----------------

// send e-mail to ...
$to="fake@mail.ch";

// Your subject
$subject="Test";

// From
$header="from: christophe <fake@mail.com>";

// Your message
$message="Hello \r\n";
$message.="This is test\r\n";
$message.="Test again ";

// send email
$sentmail = mail($to,$subject,$message,$header);

// if your email succesfully sent
if($sentmail){
echo "Email Has Been Sent .";
}
else {
echo "Cannot Send Email ";
}

?>

And this code works.

Maybe you can help me, I hope
« Last Edit: February 13, 2009, 04:16:51 pm by Hein Traag »
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Problem with mail
« Reply #1 on: February 13, 2009, 03:45:01 pm »

And you waited 3 minutes before quoting yourself?? Grow some patience.

** Deleted obsolete second post and edited email adres for user.
« Last Edit: February 13, 2009, 04:17:18 pm by Hein Traag »
Logged

dgitan

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Problem with mail
« Reply #2 on: February 13, 2009, 03:48:06 pm »

No sorry, I try to delete my message, because I leave my personnal email. And no possibilities to do that....
Logged

dgitan

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Problem with mail
« Reply #3 on: February 14, 2009, 08:49:41 am »

I put the version of the mailer.inc.php from v 1.4.19 instead of the new version, and now all works perfectly.
 :)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problem with mail
« Reply #4 on: February 17, 2009, 09:12:44 am »

That's not a good idea. There's a reason why mailer.inc.php was changed from cpg1.4.19 to cpg1.4.20...
Logged

banfa

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Problem with mail
« Reply #5 on: February 18, 2009, 11:37:23 pm »

I put the version of the mailer.inc.php from v 1.4.19 instead of the new version, and now all works perfectly.
 :)

Could you please send me a link, I can download v 1.4.19? I can find only 1.4.20. I have similar problem, however, the registration email works fine, but I can not send eCard.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problem with mail
« Reply #6 on: February 25, 2009, 09:55:01 am »

Do not use cpg1.4.19 - as I said above: there are reasons why it was modified. That's why we won't promote the outdated version by posting a link to it.
Logged

sk8connection

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Problem with mail
« Reply #7 on: April 21, 2009, 03:10:57 pm »

I run Coppermine Photo Gallery 1.4.21 (stable) and have the same problem, everything works exept email notification (on comments) does not work.

Is there a way to test it? A log where i can see where is the error?

Sincerely

sk8connection
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problem with mail
« Reply #8 on: April 21, 2009, 11:25:05 pm »

Locking...
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.