Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: debug error  (Read 1813 times)

0 Members and 1 Guest are viewing this topic.

junglejim42

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
debug error
« on: January 11, 2009, 02:36:52 pm »

I am using CPG 1.4.12
I transferred the cpg directory from one web host to another by using  cut and paste via my FTP program, although everything seems to work still I get the following debug info at the bottom of the screen.  Can anyone help please???

many thanks

USER:
------------------
Array
(
    [ID] => f2aedcf2cdcb30e39386e853b6aa7bd1
    [am] => 1
    [lang] => english
    [liv] => Array
        (
           
  • => 633

        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 8
    [user_name] => the_po_stoker
    [groups] => Array
        (
           
  • => 2
  • [1] => 101
                [2] => 110
            )

        [disk_max] => 1024
        [disk_min] => 0
       
[can_rate_pictures] => 0
    [can_send_ecards] => 0
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 10
    [num_URI_upload] => 3
    [can_post_comments] => 0
    [can_upload_pictures] => 1
    [can_create_albums] => 0
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Registered
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 2
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM cpg_filetypes; (0s)
  • [1] => select * from cpg_plugins order by priority asc; (0s)
        [2] => SELECT * FROM cpg_bridge (0s)
        [3] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg_usergroups WHERE group_id in (2,101,110) (0s)
        [4] => SELECT group_name FROM  cpg_usergroups WHERE group_id= 2 (0s)
        [5] => SELECT user_favpics FROM cpg_favpics WHERE user_id = 8 (0s)
        [6] => DELETE FROM cpg_banned WHERE expiry < '2009-01-11 14:31:21' (0s)
        [7] => SELECT * FROM cpg_banned WHERE (ip_addr='90.200.112.88' OR ip_addr='90.200.112.88' OR user_id=8) AND brute_force=0 (0s)
        [8] => SELECT COUNT(*) FROM cpg_pictures WHERE approved = 'NO' (0s)
        [9] => SELECT value FROM cpg_config WHERE name = 'theme' (0s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
       
[e] =>
    [admin_php] =>
)

==========================
POST :
------------------
Array
(
)

==========================
VERSION INFO :
------------------
PHP version: 5.1.2 - OK
------------------
mySQL version: 5.0.22-Debian_0ubuntu6.06.10-log
------------------
Coppermine version: 1.4.12(stable)
==========================
Module: GD
------------------
GD Version: 2.0 or higher
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support: 1
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support:
XBM Support:
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 2
Client API version 5.0.22
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/run/mysqld/mysqld.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.3
Linked Version 1.2.3
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | On
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .: | .:
open_basedir | /var/www/vhosts/romft.co.uk/httpdocs:/tmp | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /var/qmail/bin/qmail-inject | /var/qmail/bin/qmail-inject
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 2M | 2M
post_max_size | 8M | 8M
==========================
Page generated in 0.139 seconds - 10 queries in 0 seconds - Album set : ; Meta set: ;
Logged

junglejim42

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: debug error
« Reply #1 on: January 11, 2009, 03:34:56 pm »

I'm sure it must be an incorrect setting.  So if I delete the /include/install.lock file and run the install.php file again will I lose all my albums and attached info
Logged

Nibbler

  • Guest
Re: debug error
« Reply #2 on: January 11, 2009, 04:11:01 pm »

Disable debug mode in config. Current version is 1.4.19 - update your gallery.
Logged

junglejim42

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: debug error
« Reply #3 on: January 11, 2009, 06:28:13 pm »

Disable debug mode in config. Current version is 1.4.19 - update your gallery.
Carried out an upgrade to v1.4.19
uploaded and overwrote all files except anycontent.php -- /include/config.inc.php and album DIR. 
ran upgrade.php and all appeared fine.
After logging in as admin, I've carried a file comparrison check and anycontent.php is highlighted in red, the help file says I should upgrade this file as well????


Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: debug error
« Reply #4 on: January 22, 2009, 10:39:04 am »

After logging in as admin, I've carried a file comparrison check and anycontent.php is highlighted in red, the help file says I should upgrade this file as well????
Not very surprising if you have done as suggested and not replaced it during the upgrade. The upgrade board is full of threads that have asked this. The docs explain that as well. You shouldn't have posted your upgrading question here anyway, since we have a strict "one question per thread" policy that you agreed to respect when signing up.

Back to your initial question: what's a debug error? If debug_output bothers you, turn it off in coppermine's config.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 21 queries.