Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Undo watermarking don't work  (Read 6097 times)

0 Members and 1 Guest are viewing this topic.

Gorgias

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
  • de Gilead
    • ForoCompeticion.com
Undo watermarking don't work
« on: December 11, 2008, 10:52:18 pm »

Hello!

I'm trying undo the watermark, but I can't. After search and test, and more search and test... I found and read this Stramm instruccions in this message:
Quote from: Stramm
So if you turn off watermarking in config and rebuild normal and fullsized pics then they won't have watermarks anymore.

So I did it: I turn off the watermarking in Config, and in Admin Tools, I check "Update thumbs and/or resized photos (1)" and inside, "Both resized and full sized (if a orig copy is available)". But then, the watermark still is shown. Am I doing the correct proccess? I don't know what is happening.

You can see my test gallery in http://www.forocompeticion.com/test/copper/, and the examples of images (thumb, normal and original without watermarking, and the image with watermark), are attachment in a zip. If you need a test admin user, please, tell me.

Thank you in advance!

Regards!
Logged
Pallida Mors aequo pulsat pede pauperum tabernas regumque turres.
Vitae summa brevis spem nos vetat inchoare longam.

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Undo watermarking don't work
« Reply #1 on: December 12, 2008, 08:18:46 am »

Check if image and directory permissions allow overwriting the fullsized pic.

Gorgias

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
  • de Gilead
    • ForoCompeticion.com
Re: Undo watermarking don't work
« Reply #2 on: December 12, 2008, 09:36:58 pm »

Yes, I checked it too. And I changed CHMOD from 755 to 777, to test, but the watermark is shown yet. One question: I only have to apply that CHMOD to "edit" directory and files, inside "albums". Or have I to change other directories and/or files?

Thanks!
Logged
Pallida Mors aequo pulsat pede pauperum tabernas regumque turres.
Vitae summa brevis spem nos vetat inchoare longam.

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Undo watermarking don't work
« Reply #3 on: December 13, 2008, 09:25:00 am »

all albums within the albums folder (755 or 777 - depending on your setup), files the same ... (644 or 666) ...
check ownership as well (chown)

Gorgias

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
  • de Gilead
    • ForoCompeticion.com
Re: Undo watermarking don't work
« Reply #4 on: December 18, 2008, 03:32:30 am »

Nothing is work. CHMOD is correct (albums folder 777, and files 666). And I checked chown too, but all is correct. I was trying several times, but the watermark always is shown. When I update photos, all is marked as corrected, but instead, the watermark survives!

Thanks!
Logged
Pallida Mors aequo pulsat pede pauperum tabernas regumque turres.
Vitae summa brevis spem nos vetat inchoare longam.

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Undo watermarking don't work
« Reply #5 on: December 18, 2008, 08:40:54 am »

I checked one of the images in your test setup.
The backup copy already has a watermark on it
http://www.forocompeticion.com/test/copper/albums/userpics/orig_350z.jpg

This you of course can't undo.

You need to upload pics without watermark. Then watermark them. Before the script will proceed, it'll create the backup. When you disable watermarking and opt to redo the pictures, the fullsized pic will get replaced by the backup.

Gorgias

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
  • de Gilead
    • ForoCompeticion.com
Re: Undo watermarking don't work
« Reply #6 on: December 18, 2008, 04:09:31 pm »

No, that is no my watermark :) You found an imagen with a previous watermark, but of course, I don't want undo that, only mine watermark. You can see an example in the images in the file attachment in the first post. In that file I zip a thumb, a normal, a watermark and a original imagen without watermark.

Here you have a imagen with the watermark (at the bottom left):
http://www.forocompeticion.com/test/copper/albums/userpics/10003/rally%20santander_1.jpg

And here, the backup image without the watermak:
http://www.forocompeticion.com/test/copper/albums/userpics/10003/orig_rally%20santander_1.jpg
Logged
Pallida Mors aequo pulsat pede pauperum tabernas regumque turres.
Vitae summa brevis spem nos vetat inchoare longam.

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Undo watermarking don't work
« Reply #7 on: December 18, 2008, 04:12:56 pm »

So it's working for the intermediate but not for the fullsized image?

Gorgias

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
  • de Gilead
    • ForoCompeticion.com
Re: Undo watermarking don't work
« Reply #8 on: December 19, 2008, 02:31:41 am »

Yes, intermediate images don't show the watermark, but fullsize images, show it. chmod and chown are correct, and the steps to undo watermark are the same you said in the instructions.

Thats why I don't know what is happening.
Logged
Pallida Mors aequo pulsat pede pauperum tabernas regumque turres.
Vitae summa brevis spem nos vetat inchoare longam.

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Undo watermarking don't work
« Reply #9 on: December 21, 2008, 12:22:54 pm »

I'll check that on my setup later (if I can replicate your issue).

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Undo watermarking don't work
« Reply #10 on: December 24, 2008, 02:00:29 pm »

Tried that and it works on my testbeds without any problems (*nix + win with GD2)
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.