Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: CPG1.4.19 + Bridge for PhpBB3 not compatible with cpg1.4 modpack by Stramm?  (Read 7756 times)

0 Members and 1 Guest are viewing this topic.

Daino

  • Coppermine newbie
  • Offline Offline
  • Posts: 16

Hi all, I receive a "Fatal Error" when I install the ModPack Stramm to a CPG 1.4.19 bridged with Phpbb3 board.
Is possible resolve the problem? Whithin bridge, the ModPack go.
Isn't compatible?
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

The supported bridges are stated in the announcement thread. You could search the boardas well ... I've described how to make bridge files modpack compatible 2-3 times. It's not that hard!

abnev

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

stramm, could you or somebody explain where to find the instructions for making a bridge file compatible with cpg 1.4.20 and phpbb3.  I love the mod pack, but i need it to work with PPHPbb3
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

compare a original cpg bridge with a modded one and you'll see... pretty easy

Code: [Select]
'notify' => 'user_notify_pm',
'auto_subscribe_post' => 'user_notify',
'auto_subscribe_comment' => 'user_notify',
            'avatar_url' => 'user_avatar'
);

//mod define Avatar path
define('AVATAR_PATH', $BRIDGE['relative_path_to_config_file'].$BRIDGE['avatar_path'].'/');
define('PM_LINK', $BRIDGE['relative_path_to_config_file'].'privmsg.php?mode=post&u=');

that's the added part, the last entries define the PM link and avatar path. If you do not use a modded bridge setup you'll have to manually add these to the cpg database
the first for lines 'translate' coppermine/ modpack database entries that shouldn't get used anymore but similar entries from the users table of your forum app. These you'll have to enter here

Mannie_

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 51

I think i have the same thing going on. I have added that code here to the bridge file. Now when i enable the bridge i get Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' that error on line 103
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

A modded phpbb3.inc.php

Mannie_

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 51

Thanks stramm, you are the man :)
seems it bridged now
Logged

Mannie_

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 51

I spoke to soon, it is bridged, but the admin menu is gone now ?
Logged

Mannie_

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 51

I think i see what goes wrong, only don't know how to fix it myself. Right after bridging it is bridged but then there are 2 times mannie online, one with the right id and one that don't excist anymore.
Logged

Mannie_

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 51

Thanks for your work, but i switch to smf , users didn't excist when they try to login on phpbb afte i moved to the other server when they asked a new password, in smf that does work so i have no other choice to go with smf. Sorry for the trouble
Logged

WillPS

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: CPG1.4.19 + Bridge for PhpBB3 not compatible with cpg1.4 modpack by Stramm?
« Reply #10 on: February 25, 2010, 03:30:50 am »

I too am having the problem where it does not carry admin rights through. I'm scouring the code.

Sorry to trouble you Stramm, but if possible would you be able to post the section of code you added? Thanks ever so much in advance.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: CPG1.4.19 + Bridge for PhpBB3 not compatible with cpg1.4 modpack by Stramm?
« Reply #11 on: February 25, 2010, 07:43:02 am »

Locking
Logged
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 21 queries.