Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: 0 Image Uploading When Using URL Upload  (Read 2622 times)

0 Members and 1 Guest are viewing this topic.

angeljs

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
0 Image Uploading When Using URL Upload
« on: November 13, 2008, 08:43:09 pm »

I've made a search, I've read the DOC's, I've troubleshooted, but I still cannot upload via URL.  :'(

Also, for some reason, I have tried limiting the upload fields to just one, but several are still showing up on the upload page.

http://www.tombraidervault.com/forum/index.php?action=login (where to login)
http://www.tombraidervault.com/gallery/ (actual gallery script)

User: test
Pass: testing

Thank you in advance for any help.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: 0 Image Uploading When Using URL Upload
« Reply #1 on: November 14, 2008, 07:26:04 am »

http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_support
URI uploads may or may not work on your server setup. Nothing we can do about that. If regular file uploads work and URI uploads don't, ask your webhost for support. URI uploads is a silly feature in the first place that is scheduled to be removed in future versions.
Logged

angeljs

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: 0 Image Uploading When Using URL Upload
« Reply #2 on: November 14, 2008, 04:36:29 pm »

Hi, thanks for the reply. I did as you suggested and my host has been tweaking the server all day with no success. This is part of their latest reply:
Code: [Select]
All the modules which require the URL upload, are present on the server.

Please provide "Debug Info" to Coppermine development team and let us know the php directives which should be ON or OFF on the server.

Here is the debug info:

Code: [Select]
USER:
------------------
Array
(
    [ID] => 647dffef531ed101782dcc3f3ac57d3c
    [am] => 1
    [lang] => english_gb
    [liv] => Array
        (
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => admin
    [groups] => Array
        (
            [0] => 101
            [1] => 104
        )

    [disk_max] => 1024000
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 6
    [num_URI_upload] => 6
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrator
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 101
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg_filetypes; (0s)
    [1] => select * from cpg_plugins order by priority asc; (0s)
    [2] => SELECT * FROM cpg_bridge (0s)
    [3] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg_usergroups WHERE group_id in (101,104) (0s)
    [4] => SELECT group_name FROM  cpg_usergroups WHERE group_id= 101 (0s)
    [5] => SELECT user_favpics FROM cpg_favpics WHERE user_id = 1 (0s)
    [6] => DELETE FROM cpg_banned WHERE expiry < '2008-11-14 15:34:05' (0s)
    [7] => SELECT * FROM cpg_banned WHERE (ip_addr='90.200.25.4' OR ip_addr='90.200.25.4' OR user_id=1) AND brute_force=0 (0s)
    [8] => SELECT aid, title FROM cpg_albums WHERE category < 10000 ORDER BY title (0s)
    [9] => SELECT aid, title FROM cpg_albums WHERE category='10001' ORDER BY title (0s)
    [10] => SELECT COUNT(*) FROM cpg_pictures WHERE approved = 'NO' (0s)
)

==========================
GET :
------------------
Array
(
    [pload_php] =>
)

==========================
POST :
------------------
Array
(
    [URI_array] => Array
        (
            [0] => http://www.******/media/screen1.jpg
            [1] =>
            [2] =>
            [3] =>
            [4] =>
            [5] =>
        )

    [control] => phase_1
)

==========================
VERSION INFO :
------------------
PHP version: 5.2.5 - OK
------------------
mySQL version: 5.0.51a-community
------------------
Coppermine version: 1.4.19(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.34 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support:
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 2
Client API version 5.0.51a
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.3
Linked Version 1.2.3
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | /usr/local/php/bin | /usr/local/php/bin
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | /usr/local/php/bin | /usr/local/php/bin
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/usr/lib/php | .:/usr/lib/php
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /usr/sbin/sendmail -t -i  | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | -1 | -1
upload_max_filesize | 50M | 50M
post_max_size | 8M | 8M
==========================
Page generated in 0.318 seconds - 11 queries in 0 seconds - Album set : ; Meta set: ;
Logged

Nibbler

  • Guest
Re: 0 Image Uploading When Using URL Upload
« Reply #3 on: November 14, 2008, 05:05:19 pm »

The setting required is allow_url_fopen
Logged

angeljs

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: 0 Image Uploading When Using URL Upload
« Reply #4 on: November 14, 2008, 06:08:57 pm »

The function "allow_url_fopen" is already enabled according to my phpinfo file.
Logged
Pages: [1]   Go Up
 

Page created in 0.027 seconds with 19 queries.