Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Uploading error  (Read 2461 times)

0 Members and 1 Guest are viewing this topic.

tinorebel

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 87
  • live long and prosper!
    • www.tripodart.net
Uploading error
« on: November 07, 2008, 03:03:02 pm »

Hallo to all coppermine users!
I have a gallery with many inmages, i'm using 14.19 with stramm modepack watermarking pictures.

Today I found a problem uploading pictures:
The uploading process works fine, untill I add the picture to the album.
When I try uploading a big picture (2000 x 3000 pix) Then I get:

Fatal error: Out of memory (allocated 41156608) (tried to allocate 2008 bytes) in /home/tinorebe/public_html/website/gal/include/picmgmt.inc.php on line 442

If I upload a smaler picture (1000 pixels) everythings works fine.

Could this problem be related by the maximum memory my account is allowed to use on the server?.... I have been using the same configuration and did not find problems since now... possibly the watermarking process takes a lot of memory.... any idea would be apreciated!


Logged
Live long and prosper!
www.tripodart.net

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Uploading error
« Reply #1 on: November 07, 2008, 03:05:30 pm »

RTFM - has been asked and answered so often that it hurts having to read threads like yours over and over again. And yes: watermarking is resources-consuming.
Logged

tinorebel

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 87
  • live long and prosper!
    • www.tripodart.net
Re: Uploading error
« Reply #2 on: November 10, 2008, 02:06:00 pm »

I'm really sorry, I did not mean to hurt.... I apologize :-\

the fact is that since last week I never faced this error and I have uploaded many pictures in the same big resolution (2000x3000 pix)

The memory  limit I have on my server for PHP is 64 MB, wich should be fine for a picture of 2000x3000 pix -
(2000x3000x3)/1048576 = 17,16 MB - Ther memory needed to handle the picture.

Suddently I am facing this problem and I wondered if it could be caused by some bad config or else....

Anyway I'll continue investigating and I will post the solution when (and if) I find it .... just to help if someone hase same problem.
Logged
Live long and prosper!
www.tripodart.net
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 20 queries.