Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Blank Page for Large Files  (Read 9893 times)

0 Members and 1 Guest are viewing this topic.

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Blank Page for Large Files
« on: October 15, 2008, 11:10:48 pm »

I'm having difficulty getting large files to upload.
I can upload files that would not need resizing.
Large files, say they uploaded successfully, then when I click 'continue' instead of the albums page, I get a blank page.

Site: http://www.fishaholics.org

Username: tester
Password: tester

Debug mode is on.

All directories for upload are 777.
Changed my php.ini file to have max upload time 360 seconds,
max upload 5M
and script time to 90

Thanks,
Tim

(Gallery is bridged with forum, so you'll need to click the gallery link at the top of the page after logging in)
Most up to date theme is "serenity"
Logged

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Blank Page for Large Files
« Reply #1 on: October 16, 2008, 03:12:59 am »

Let me add also,
I did set upload_temp_dir to "/home/our_dir/public_html/tmp/"  which I created and gave permissions 777.
Thanks.
Tim

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Blank Page for Large Files
« Reply #2 on: October 16, 2008, 07:16:48 am »

You're probably running into server-sided limitations. Read up the sticky thread Trouble-shooting the upload process for an explanation what server-sided restrictions may apply for you. If you want details, do exactly as suggested in the upload troubleshooting section of the docs and the next section (named "asking for support on upload issues"). You have set the number of URI upload fields to 1 although you should have set it to 0.
In fact, the same restrictions apply that are being explained for the error message "Fatal error: Allowed memory size of XXXXXXX bytes exhausted"
Logged

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Blank Page for Large Files
« Reply #3 on: October 16, 2008, 06:19:22 pm »

I have read the help files several times and followed the steps in the first few posts.

Didn't see the resolution size is different than file size.
Thanks.
I'll change the setting from 5MB to 16MB and see if that resolves the issue.
If that's not successful, I'll look into the config file silly mode setting.

Also, didn't read down far enough in the docs to see the section on asking for support on upload issues.  I've read it in the past and knew I'd seen it somewhere, hence file settings to 1 and debug mode enabled, but I couldn't remember where I'd seen it last night.
I'll try to follow instructions next time.  ;D

I'll get back to you with my findings.
Thanks for pointing me in the right direction,
Tim
Logged

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Blank Page for Large Files
« Reply #4 on: October 16, 2008, 11:32:04 pm »

I changed the max file size to 16M.
Now when I try to upload an image as an admin, I get:
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3504 bytes) in /home/plecosco/public_html/holics/gallery/include/picmgmt.inc.php on line 262

What do I need to change to allocate more memory?  Or this a different problem.

I disabled the URL upload as you suggested.  Now when I'm logged in as a user, I get:
You don't have permission to perform this operation.

File: /home/plecosco/public_html/holics/gallery/db_input.php - Line: 286

Should I change permissions from 777 back to 755?  Seems like I'm running into multiple problems now.
Tim

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Blank Page for Large Files
« Reply #5 on: October 17, 2008, 07:08:52 am »

I changed the max file size to 16M.
Now when I try to upload an image as an admin, I get:
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3504 bytes) in /home/plecosco/public_html/holics/gallery/include/picmgmt.inc.php on line 262

What do I need to change to allocate more memory?
Yes and no - I already told you:
In fact, the same restrictions apply that are being explained for the error message "Fatal error: Allowed memory size of XXXXXXX bytes exhausted"
There are several settings that have an impact. Try increasing the memory allocation.

Should I change permissions from 777 back to 755?
No. Don't change several settings at once. Just change one thing, then test things. If the situation improves, leave the settings as they are. If it doesn't improve, go back to the original settings and then try something else.
Logged

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Blank Page for Large Files
« Reply #6 on: October 17, 2008, 11:17:35 pm »

Yes and no - I already told you:There are several settings that have an impact. Try increasing the memory allocation.

As stated earlier, I already changed memory allocation to 16MB.  The help file you directed me to said that should be sufficient.  I changed it to 32MB.  Still no success.
max input time and execution time were both changed to 360.  Still no help.
Really, I've increased all the settings I've seen anywhere in all the help files.
Still, no help.

Tim
Logged

Nibbler

  • Guest
Re: Blank Page for Large Files
« Reply #7 on: October 17, 2008, 11:30:50 pm »

If 32MB is not enough then increase it further.
Logged

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Blank Page for Large Files
« Reply #8 on: October 18, 2008, 03:50:17 am »

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 3072 bytes) in /home/plecosco/public_html/holics/gallery/include/picmgmt.inc.php on line 272

Now, I'm not saying that the memory size isn't the problem......
However, using the math from width x height x colors all divided by the number on the help page gave me 31.6MB using four colors.  I use RGB but used four just to be err on the side of caution.  My max upload size, memory size and max post is all set to 128 MB.  Now, I know I'm probably missing something, but there's got to be a point where we say, hmmmmm, maybe it's not the php.ini settings.
Tim

Logged

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Blank Page for Large Files
« Reply #9 on: October 18, 2008, 03:59:04 am »

Ignore the last post.  I'm too stupid to figure out how to delete or edit it.

I forgot to upload the php.ini file after changing it to 128MB.

64MB didn't work.  128MB did.
Tim

Logged

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Large File Upload Fixed for Admins, No uploads for users
« Reply #10 on: October 18, 2008, 04:39:34 am »

Since this seems to be a separate problem from the php.ini file and the permissions on the directorys, I'm starting a different thread.
The forum is bridged with phpBB3 using the unofficial bridge file posted in a thread on this site.
The debug information seems to indicate that Registered Users are not allowed to upload files.
Can upload pictures is set to 0.
Although, under the users permission tab, it's set to yes.
See attached image.
Cookie settings are set according to bridging instructions.
Logging into the forum logs the user into the gallery.
There was a point where users could upload files for a short while.
I believe I broke something trying to fix my file size problems.


USER:
------------------
Array
(
    [ID] => 93e4f99455f9ed453920998e62e8b418
    [am] => 1
    [theme] => Serenity
    [liv] => Array
        (
        )

    [sort] => da
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 2020
    [user_name] => Tester
    [groups] => Array
        (
           
  • => 2
  • [1] => 1472
            )

        [disk_max] => 51200
        [disk_min] => 51200
       
[can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 0
    [ufc_min] => 0
    [custom_user_upload] => 0
    [num_file_upload] => 1
    [num_URI_upload] => 0
    [can_post_comments] => 1
    [can_upload_pictures] => 0
    [can_create_albums] => 1
    [has_admin_access] => 0
    [pub_upl_need_approval] => 1
    [priv_upl_need_approval] => 1
    [group_name] => Registered
    [upload_form_config] => 0
    [group_quota] => 51200
    [can_see_all_albums] => 0
    [group_id] => 2
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM cpg130_filetypes; (0s)
  • [1] => select * from cpg130_plugins order by priority asc; (0s)
        [2] => SELECT * FROM cpg130_bridge (0s)
        [3] => SELECT u.user_id AS user_id, u.user_password AS password FROM `plecosco_holics`.phpbb_users AS u, `plecosco_holics`.phpbb_sessions AS s WHERE u.user_id=s.session_user_id AND s.session_id = 'b60b19c92ba3bf0abf42ba1b19467d4b' AND u.group_id != 6 AND u.group_id != 1 (0.001s)
        [4] => SELECT u.user_id AS id, u.username AS username, u.user_password AS password, ug.group_id AS group_id FROM `plecosco_holics`.phpbb_users AS u, `plecosco_holics`.phpbb_user_group AS ug WHERE u.user_id=ug.user_id AND u.user_id='2020' (0s)
        [5] => SELECT ug.group_id AS group_id, u.group_id AS maingroup FROM `plecosco_holics`.phpbb_user_group ug LEFT JOIN `plecosco_holics`.phpbb_users u ON u.user_id = ug.user_id WHERE u.user_id = 2020 AND u.group_id != 6 (0s)
        [6] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg130_usergroups WHERE group_id in (2,1472) (0s)
        [7] => SELECT group_name FROM  cpg130_usergroups WHERE group_id= 2 (0s)
        [8] => update `plecosco_holics`.phpbb_sessions set session_time='1224296363' where session_id='b60b19c92ba3bf0abf42ba1b19467d4b'; (0s)
        [9] => SELECT user_favpics FROM cpg130_favpics WHERE user_id = 2020 (0s)
        [10] => DELETE FROM cpg130_banned WHERE expiry < '2008-10-18 02:19:23' (0s)
        [11] => SELECT * FROM cpg130_banned WHERE (ip_addr='76.234.97.242' OR ip_addr='76.234.97.242' OR user_id=2020) AND brute_force=0 (0s)
        [12] => SELECT aid FROM cpg130_albums WHERE visibility != '0' AND visibility !='12020' AND visibility NOT IN (2,1472) (0s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
       
[album] => 103
    [MAX_FILE_SIZE] => 3686400
    [title] => Mr Green
    [caption] =>
    [keywords] =>
    [event] => picture
)

==========================
Page generated in 0.111 seconds - 13 queries in 0.001 seconds - Album set : AND aid NOT IN (95) ; Meta set: ;

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Blank Page for Large Files
« Reply #11 on: October 18, 2008, 11:07:04 am »

Merged the new thread into the existing one. I already told you what you need to do:
If you want details, do exactly as suggested in the upload troubleshooting section of the docs and the next section (named "asking for support on upload issues").
Those instructions clearly say what you need to do and even more: they tell you what you're not suppossed to do - you mustn't post debug_output unless we explicitely ask you to do so. Your posting clearly shows that you haven't read instructions carefully, so I'm not inclined to look into your issues. Now read up board rules, then read up the docs once more and do exactly as suggested there.
Logged

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Blank Page for Large Files
« Reply #12 on: October 18, 2008, 02:49:54 pm »

My apologies.

Step 1: Logged in as admin.
Step 2: Enabled debug mode for "Yes: Everyone"
Step 3: Turned off display notices
Step 4: Saved, went to groups
Step 5: Ensured that Fileuploads set to 1, URI set to 0, No. of boxes "fixed"
Step 6: Attempted the upload and got the same error I posted.
Step 7: Reread, the rest of section 4.11 in docs.  Error message did not match any of the messages on the table.
Asking for Support
Website: http://www.fishaholics.org
User account settings - Name: Tester
                                Pswd:  tester

Test user is not in the admin group.
Test user should have upload privileges.
Disabled admin approval requirements for now as recommended.
Again, looked at the common errors table.  My error is not there, so I searched the forum.
Found this thread and a thread where someone installed a plug-in which had changed a setting on their config table.
Read the entire thread on bridging for the bridge I'm using and found no resolution.
If I missed something I'm sure you'll let me know.
Tim

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Blank Page for Large Files
« Reply #13 on: October 18, 2008, 04:22:14 pm »

The error message I get when uploading a know-good file is
Quote
You don't have permission to perform this operation.

File: /home/plecosco/public_html/holics/gallery/db_input.php - Line: 286


Try to figure out if this is indeed related to bridging: Temporarily unbridge, create a non-admin test user account in your unbridged coppermine gallery, try uploading a file and see if the error returns. If it doesn't, re-enable bridging and post your test results.
Logged

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Blank Page for Large Files
« Reply #14 on: October 18, 2008, 05:20:37 pm »

Problem is related to bridging.
Created a new user, album for that user and uploaded a file without incident.
I'll install the bridge for phpBB3 that Nibbler wrote, remove the old one and move on from there.
If I encounter problems still, I'll ask for help in the proper forum using the template provided in the bridging section of the documentation.
All done with this thread.
Thanks,
Tim

Logged

TimN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Blank Page for Large Files
« Reply #15 on: October 18, 2008, 05:51:46 pm »

Replacing the original bridging hack with the one Nibbler wrote found:
http://forum.coppermine-gallery.net/index.php/topic,53678.0.html
Solved the rest of my problems.  The problems were two fold, php.ini settings needed to be set to a huge amount to allocate enough memory, and the old, unsupported bridging file did not properly work for setting group permissions.  Following bridging instructions with Nibblers file now allows me to use user post based groups.
Thanks for all the help, I hope to not need it again.
Tim

Logged
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 20 queries.