Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: Lost name when editing comments.  (Read 11560 times)

0 Members and 1 Guest are viewing this topic.

boii

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 65
Lost name when editing comments.
« on: October 15, 2003, 04:57:11 pm »

i dont know if this is theme related (hardwired), but i've upgraded to 1.2 and when i edit a comment already made, it erases the name field. i assume the addition to be able to edit your name now sends an empty result to the db since thers no where to fill in/edit your name..

all edited comments' msg_author ended up as blank fields in the db.

cheers.
ken
Logged

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
Lost name when editing comments.
« Reply #1 on: October 15, 2003, 05:02:46 pm »

Can you please try this with the default theme and confirm that this happens - Hardwired was edited once in the last days of RC1

In case you don't want your users to see the default theme you can change the theme just for yourself by adding

?theme=default to the URL of your gallery
Logged
SANIsoft PHP applications for E Biz

boii

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 65
Lost name when editing comments.
« Reply #2 on: October 15, 2003, 05:37:01 pm »

it happens in default too.

when you edit a comment, theres no field to edit your name, yet the name field is still sent in the UPDATE query i imagine. so it sets it to nothing.

cheers.
ken
Logged

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
Lost name when editing comments.
« Reply #3 on: October 15, 2003, 05:50:49 pm »

Can someone confirm this from the RC2 install - I did a check on the the CVS and cannot replicate this...
Logged
SANIsoft PHP applications for E Biz

jasendorf

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 350
    • http://www.338tharmyband.com
Lost name when editing comments.
« Reply #4 on: October 15, 2003, 05:58:44 pm »

I just did an upgrade from 1.1.0 to 1.2.0RC2 (not the CVS but from the actual downloaded RC2 install package) and it works fine in default and hardwired.  Must be a browser specific javascript issue.  I'm using IE6 on WinXP.
Logged
Read the Online DOCs,FAQ, and SEARCH the board BEFORE posting questions for help.

boii

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 65
Lost name when editing comments.
« Reply #5 on: October 15, 2003, 06:02:08 pm »

ie6 on win2k.

my db_input.php has the right UPDATE msg_author='$msg_author', so im assuming its not being posted from displayimage.php properly.

hmm.
Logged

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
Lost name when editing comments.
« Reply #6 on: October 15, 2003, 06:04:54 pm »

Can you post a URL
Logged
SANIsoft PHP applications for E Biz

Rodinou

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 346
  • Tournicoti, Tournicota
    • http://www.sortons.net
Lost name when editing comments.
« Reply #7 on: October 15, 2003, 06:53:48 pm »

I have tried with Hardwired, XP, IE 6 SP1

Any problem.

jasendorf

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 350
    • http://www.338tharmyband.com
Lost name when editing comments.
« Reply #8 on: October 15, 2003, 07:26:20 pm »

Quote from: "Rodinou"
Any problem.
Not sure what "any" problem means.  Does that mean there IS or IS NOT a problem?
Logged
Read the Online DOCs,FAQ, and SEARCH the board BEFORE posting questions for help.

Rodinou

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 346
  • Tournicoti, Tournicota
    • http://www.sortons.net
Lost name when editing comments.
« Reply #9 on: October 15, 2003, 09:01:35 pm »

Euh ... any problem = NO problem :)

boii

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 65
Lost name when editing comments.
« Reply #10 on: October 16, 2003, 02:26:02 am »

i tried re-uploading, displayimage.php and the hardwired theme.
but it still doesn't work.
tarique, ill pm you my url as i dont want my gallery to be public :D

cheers.
ken
Logged

Rodinou

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 346
  • Tournicoti, Tournicota
    • http://www.sortons.net
Lost name when editing comments.
« Reply #11 on: October 16, 2003, 02:27:50 am »

Quote from: "boii"
i tried re-uploading, displayimage.php and the hardwired theme.
but it still doesn't work.
tarique, ill pm you my url as i dont want my gallery to be public :D

cheers.
ken


Not cool : it's very important to see our galleries, to progress together :(

boii

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 65
Lost name when editing comments.
« Reply #12 on: October 16, 2003, 02:31:50 am »

Quote from: "Rodinou"
Not cool : it's very important to see our galleries, to progress together :(


are you kidding me.

cheers.
ken
Logged

Rodinou

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 346
  • Tournicoti, Tournicota
    • http://www.sortons.net
Lost name when editing comments.
« Reply #13 on: October 16, 2003, 02:46:40 am »

No, but the project is "open source" : so you want answers, the minimum is to show us your gallery : no ?

jasendorf

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 350
    • http://www.338tharmyband.com
Lost name when editing comments.
« Reply #14 on: October 16, 2003, 03:51:59 am »

Quote from: "boii"


are you kidding me.


Rod means well...  :roll:
Logged
Read the Online DOCs,FAQ, and SEARCH the board BEFORE posting questions for help.

boii

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 65
Lost name when editing comments.
« Reply #15 on: October 16, 2003, 03:54:32 am »

im sure  :) open soruce is one thing, ive shared code and mods with the board, i just dont think i need to share my personal life and pictures with it too  :P

anyhow, the other thread i created 'number of views under pictures' was 'moved', but i cant find what forum it was moved to.. anyone know ? id love a solution to that..

cheers.
ken
Logged

Tarique Sani

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 2712
    • http://tariquesani.net
Lost name when editing comments.
« Reply #16 on: October 16, 2003, 04:02:12 am »

OK this is a bug. Name editing is messed up when smilies are disabled.

Someone please confirm...
Logged
SANIsoft PHP applications for E Biz

boii

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 65
Lost name when editing comments.
« Reply #17 on: October 16, 2003, 04:35:02 am »

heres the fix for the bug:

in your theme.php:

find:
Code: [Select]
<!-- BEGIN edit_box_no_smilies -->

then under:
Code: [Select]
<form name="f{MSG_ID}" method="POST" action="db_input.php">
<input type="hidden" name="event" value="comment_update">
<input type="hidden" name="msg_id" value="{MSG_ID}">


add:
Code: [Select]
<tr>
         <td>
         <input type=text name=msg_author value={MSG_AUTHOR} class="textinput" size=10>
         </td>
</tr>


and now you can edt names when smilies are disabled. and it wont send a blank msg_author.

cheers.
ken

edit: obviously this only fixes the themes in which you edit the respective theme.php .. so if in th efuture you add the mod to select language/theme, it wont work unless youve corrected all the theme.php's. oh and ive only done the above for hardwired and never looked at another theme's theme.php file, if they have a different structure.. then make the approporate chnage by lookign above that codeblock no comment editing with enabled smilies and see how its done.
Logged

jasendorf

  • VIP
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 350
    • http://www.338tharmyband.com
Lost name when editing comments.
« Reply #18 on: October 16, 2003, 05:17:24 am »

It's a little more involved than that...

gotta fix up the row tags...

Actual fix should be something like:

Code: [Select]

  <td>
    <input type=text name=msg_author value={MSG_AUTHOR} class="textinput" size=10>
  </td>
</tr>
<tr>


To close the previous row tag (above the text marked as "after") and start the subsequent row tag.
Logged
Read the Online DOCs,FAQ, and SEARCH the board BEFORE posting questions for help.

lasa

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 84
    • Fotos.LaSa.nl
Lost name when editing comments.
« Reply #19 on: October 19, 2003, 06:05:37 pm »

No, the actual fix should be something like this :P :
Code: [Select]
                                               <input type="hidden" name="msg_author" value="{MSG_AUTHOR}">


Laurens.
Pages: [1] 2   Go Up
 

Page created in 0.02 seconds with 19 queries.