Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: upload error Script called without the required parameter(s). (GD not working)  (Read 6230 times)

0 Members and 1 Guest are viewing this topic.

7breaths

  • Coppermine newbie
  • Offline Offline
  • Posts: 1

I am having issues with uploading files and I do believe that the image size has something to do with it.

I have followed the "Asking for SUpport" section in docs and this is what i have:



Script called without the required parameter(s).

File: /www/justfree.com/f/l/i/fliayessa/htdocs/cmine/db_input.php - Line: 58

I am not going to post the debug as it says not to do that until asked.

I can upload smaller pics -- so i know size is an issue but what I was wondering is why the auto resize in config --> Files and thumbnails advanced settings   is not kicking in ---- i have it set to use gd v 2.x.  Should that not make it resize to within the settings?  I have found similar errors throughout but they do not seem to be the same as mine.  Also, I am hosted so i cannot alter php settings.

the link:

http://fliayessa.justfree.com/cmine/index.php

user : testuser  password: t3stus3r -- set for no approval


any help would be appareciated, hope i got everything required in here!

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de

Upgrade! You're using cpg1.4.9, while the most recent stable currently is cpg1.4.18.
Logged

Scott O

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

Hmm... I'm having this same error.

I get the message:

Critical error
Script called without the required parameter(s).

File: /db_input.php - Line: 58


I'm trying to upload a fairly large avi file (100+ MB).  I have read the support board and also the "4.11.4 Upload troubleshooting" of the documentation.  I have increased changed my configuration to allow for the size of the file I am trying to upload.

I searched the support forums and found this thread.  Since it was not flagged as "solved" I'm adding to this thread rather than starting a new one.  If you would prefer I start a new thread, please let me know.

I can create a test username/password if needed as well as provide the debug information if needed.

I am using Coppermine 1.4.19 with MySQL version 4.1 on php 5.2.6.  Dreamhost is my hosting company.
Logged

Nibbler

  • Guest

100 MB is too large for HTTP upload. Use FTP + batch add.
Logged

Scott O

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

After posting the above message, I discovered this Troubleshooting the upload process thread.  I had searched for my error on the forums rather than browsing for it, so I missed the thread for that reason.

I doubled-checked my permissions on the /ALBUMS, /ALBUMS/USERPICS, and /ALBUMS/EDIT directories and they are all set to 755.  I have been successful uploading regular photo files to my gallery before.

I did see the part about checking the PHP's configuration on my server.  Here's what I show:

max_execution_time   30   
max_input_nesting_level   64   
max_input_time      60   
memory_limit   90M   
upload_max_filesize   7M


I'm assuming that the last variable of 7m makes it impossible to upload a 100+ MB file, but I'm not sure.  Can anyone help me confirm that?
Logged

Scott O

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

Oops... posted my new response while Nibbler responded.  I will try the FTP + batch add as suggested.
Logged

Scott O

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

The FTP + batch add worked, however I'm beginning to see the faulty wisdom of uploading a 100+ MB file to begin with.  I'll try converting the file to another format or something, but my original issue is solved.  Thank you.
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 20 queries.