Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: users can't view pics - there was an error while processing a database query  (Read 3358 times)

0 Members and 1 Guest are viewing this topic.

vici

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38

few days ago while I was creating new albums I got the error: there was an error while processing a database query
I ignored it because albums were eventually created correctly, but today I got an email from one of the users who complained that they can't view ANY pics at all, I have checked it and indeed, no pics can be viewed - users always get the message: there was an error while processing a database query. to make it more complicated, me - as an admin - can still view all the pics
run a debug mode?

hope I didn't double any threads, I've already searched for similar topics but couldn't find anything like this
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

Please post a link to your gallery and enable debug mode.

olli

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

I have the same Problem...
when clicking a pic, the msg: " There was an error while processing a database query " comes up...
The page is: http://www.offroadkalender.com/coppermine/
Debug mode is on...
Thank You for help
Logged

olli

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

...I just found out: when i turn off statistic, it seems to be working...(?) What can this be?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de

You probably have a corrupt or broken database table. You shouldn't have hijacked this thread, but you should have started a new one, as "there was an error while processing a database query" is a generic error message and your issue probably totally unrelated to this thread. There are countless postings on this board that explain what you need to do when getting such a message: enable debug_mode and post that actual query that fails (not the debug_output).
Logged
Pages: [1]   Go Up
 

Page created in 0.032 seconds with 20 queries.