Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: 500 Error  (Read 1689 times)

0 Members and 1 Guest are viewing this topic.

porcelina

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
500 Error
« on: August 28, 2008, 09:51:35 am »

Can anyone help me?  This is a general coppermine/PHP question.

My gallery ws working just fine an hour ago, then I installed XAMPP because I'm taking a PHP class and my instructor said we need that software because it has Apache and PHP and MySQL, etc.  Anyway, so I configured that and now not onyl can i not install any new PHP scripts on my site (such as cutenews), but I get this error message when trying to access my gallery which is already installed and up and running:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@vivandlarry.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I have no idea how to fix this or really even what i did to mess it up in the first place.  Can anyone help me?  I uninstalled XAMPP but still no luck.

Thanks in advance!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: 500 Error
« Reply #1 on: August 28, 2008, 01:06:40 pm »

Are you self-hosted? Have you been self-hosted already before you installed XAMP? If yes, then your attempt to install a second instance of Apache on one machine blew off the lid. If you're not self-hosted, how should a local install make a difference for remotely-hosted packages? Clarify what you're trying to do. Note: we can't teach you how to set up and maintain a webserver - that's beyond the scope of this site.
Logged

porcelina

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: 500 Error
« Reply #2 on: August 28, 2008, 05:15:40 pm »

I'm hosted by lunarpages actually.

all i did was install XAMPP, which I tested and it said it was working.  I was then playing around with cutenews, which I had been able to install before (however, I didn't know how to use it, so it's just been sitting on my server), and when I tried to log-in/test it, I got the 500 error.  I thought it had something to do with the 777 or 755 chmod thing.  no matter what i tried, though, it wouldn't work. So i uninstalled cutenews.

now, my coppermine gallery has been on my site for over a year and has worked fine, until I installed XAMPP.  Now when I try and access it (and other people tell me they get the same error when trying to access my gallery), i get the 500 error.  Something obviously got overwritten, but I have no idea what that something is, as I haven't touched any of the files in my coppermine folder on my server.  thinking it's something to do with XAMPP, I uninstalled XAMPP, but it's still not working.  The files in my coppermine folder are all correctly chMODed, so I'm not sure what to do to get it back online.

Is this something I should contact my hosting site about?

Thanks
Logged

porcelina

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
Re: 500 Error
« Reply #3 on: August 28, 2008, 05:18:39 pm »

Apparently it fixed itself?  It's working now, i have no idea what the problem was.  But thanks anyway :)
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 19 queries.