Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: Fault: unable to upload any pics  (Read 16016 times)

0 Members and 1 Guest are viewing this topic.

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Fault: unable to upload any pics
« on: April 15, 2004, 01:31:45 pm »

hi i am currently receiving the following error:
Impossible to move Sample.jpg to albums/userpics/ !

ï"¿
Warning: move_uploaded_file(albums/userpics/Sample.jpg): failed to open stream: Permission denied in c:\inetpub\wwwroot\db_input.php on line 258

Warning: move_uploaded_file(): Unable to move 'C:\PHP\uploadtemp\php5.tmp' to 'albums/userpics/Sample.jpg' in c:\inetpub\wwwroot\db_input.php on line 258

the thing is  have been uploading my pics for a while now , & all of a sudden i cant any more.

is there any possability that id my webserver has suddenly rebooted , due to power failure , some of the php files might have been corupted.
i have checked my directory permisions , i have tried debug mode but that does not show any symptoms.

should i try silly safe mode ?
Logged
Go Big Or go the F*ck Home !!!!

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Fault: unable to upload any pics
« Reply #1 on: April 16, 2004, 07:47:13 am »

Logged

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Fault: unable to upload any pics
« Reply #2 on: April 16, 2004, 12:31:10 pm »

gaugau , at a gues which file would you think might be corupted for this problem to occur ?
Logged
Go Big Or go the F*ck Home !!!!

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Fault: unable to upload any pics
« Reply #3 on: April 16, 2004, 03:52:40 pm »

please watch the thread I linked instead of posting on this one - there's a guess at the bottom by oasis that I find very likely to be true.

GauGau
Logged

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Fault: unable to upload any pics
« Reply #4 on: April 18, 2004, 04:34:39 pm »

gau gau , i am not really worried at the moment why , i am getting strange characters , my biggest problem currently is that  i am not able to upload any pics at all

i will keep track of the other tread , for the solution.
Logged
Go Big Or go the F*ck Home !!!!

Nibbler

  • Guest
Fault: unable to upload any pics
« Reply #5 on: April 18, 2004, 11:26:25 pm »

Check the chmod permissions on your userpics directory, should be 777.
Logged

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Fault: unable to upload any pics
« Reply #6 on: April 18, 2004, 11:43:53 pm »

I am running a Windows IIS server.
but when i log in with a ftp app i have set the directory of albums to 777

i was wondering if it couldnt be a corrupt file perhaps
Logged
Go Big Or go the F*ck Home !!!!

Nibbler

  • Guest
Fault: unable to upload any pics
« Reply #7 on: April 19, 2004, 12:00:50 am »

and userpics ?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Fault: unable to upload any pics
« Reply #8 on: April 19, 2004, 12:12:39 am »

erm, Windows IIS and CHMOD :wink: ? Come on, be real... There's no CHMOD in Windows you can set using ftp (but of course there's an equivalent: file permissions for IUSR_hostname).

GauGau
Logged

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Fault: unable to upload any pics
« Reply #9 on: April 19, 2004, 12:40:44 am »

OK , i have checked the following:
IUSR has a guest account ,

& i have checked all the directories & they have read & write access enabled.

have a look.
http://iank.no-ip.com/index.php
user: cpm
pass: support
Logged
Go Big Or go the F*ck Home !!!!

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Fault: unable to upload any pics
« Reply #10 on: April 19, 2004, 12:43:27 pm »

Ok,
I logged on, and was unable to upload, because there are no albums which I had permission to upload to, and user cpm has no rights to create his own albums.

Please enable at least one album for the group cpm is in, so we can test this.  Or place cpm in a group with rights for personal albums.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Fault: unable to upload any pics
« Reply #11 on: April 19, 2004, 01:19:26 pm »

Ok , i have given the user cpm  its own group & i have created a album.

please can you have a look now.


Thanks casper.. well spoted.
i am such a noob  :roll:
Logged
Go Big Or go the F*ck Home !!!!

Echo5ive

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
    • http://frozenskies.net/
Fault: unable to upload any pics
« Reply #12 on: April 20, 2004, 04:06:43 am »

I figure I'll post here instead of creating a new thread, since I can't upload stuff either.

After a fresh first-time install, all I get is "Impossible to move" when uploading a file from my local computer, and "Cannot create write file" when I load an image URL.

I'm guessing it's something with write permissions somewhere, but I've chmodded all required directories as instructed during the install.

Any hints, anyone?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Fault: unable to upload any pics
« Reply #13 on: April 20, 2004, 09:10:52 am »

check the documentation that comes with coppermine, chapter Safe mode issues. Your problem is probably not related to xtreme's.

GauGau
Logged

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Fault: unable to upload any pics
« Reply #14 on: April 20, 2004, 09:14:59 am »

guys , i was wondering if this would help .
when i get the error:
Code: [Select]

Warning: move_uploaded_file(albums/userpics/Sample.jpg): failed to open stream: Permission denied in c:\inetpub\wwwroot\db_input.php on line 258

Warning: move_uploaded_file(): Unable to move 'C:\PHP\uploadtemp\php5.tmp' to 'albums/userpics/Sample.jpg' in c:\inetpub\wwwroot\db_input.php on line 258

i am not trying to upload to my userpics album , but it looks like it is trying to upload there anyway ...
might this be where the problem lies ?
Logged
Go Big Or go the F*ck Home !!!!

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Fault: unable to upload any pics
« Reply #15 on: April 20, 2004, 09:24:17 am »

yes, this is related. There's a folder for temporary files on your server the script needs write access to. Make sure IUSR_something and the other I_don't_remember_it's name_hostname (user name starting with capital "I" and hostname at the end) user have write access to 'C:\PHP\uploadtemp\'.

GauGau
Logged

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Fault: unable to upload any pics
« Reply #16 on: April 20, 2004, 11:52:43 pm »

gaugau , thanks ..but i have added those two user's to the uploadtemp dir & still same error .

i need you advise. i have been able to upload fine in the past .about  1month ago. but since then i havnt played with the configuration of cpm or the server at all.  i thinking that this has got o have happened when we had those series of power failures in my area..
i.e. causing some coruption  in the files !!!

now what i want to know .would it help me to reinstall php or cpm ...
even though i have modified some file .. this will tell me whether it is a cpm/php or server config prob ..

what ur your recommendation Please!!
Logged
Go Big Or go the F*ck Home !!!!

omniscientdeveloper

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 901
Fault: unable to upload any pics
« Reply #17 on: April 21, 2004, 01:01:30 am »

I would say reinstall coppermine first, if you're sure permissions are set correctly.
Logged

Echo5ive

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
    • http://frozenskies.net/
Fault: unable to upload any pics
« Reply #18 on: April 21, 2004, 08:43:02 am »

I tried using define('SILLY_SAFE_MODE', 1);, but I still can't upload pictures -- I get the same error messages. This is really ticking me off now...
Logged

xtreme

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 37
Fault: unable to upload any pics
« Reply #19 on: April 21, 2004, 10:33:11 pm »

:( guys , i have reinstalled cpm & same prob :(

is there a way i can test whether php  is working 100% without reinstalling ?

can i re-install /over install php4 on windowsXP , withouh causing moe damage ?


please guys i am losing hope that i am going to get this fixed !!!
Logged
Go Big Or go the F*ck Home !!!!
Pages: [1] 2   Go Up
 

Page created in 0.023 seconds with 19 queries.