Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: Troubles with uploading & db_input.php  (Read 5989 times)

0 Members and 1 Guest are viewing this topic.

delikatna

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
[Solved]: Troubles with uploading & db_input.php
« on: July 11, 2008, 10:21:11 pm »

Hello  :)

I had big trouble with `searchnew.php`
Well it didn't want to open. I was refreshing, overwriting it - ONE BIG NOTHING.
So i found this `troubleshooting` here and i found error - something with Line 311 in db_input.php

I searched through topics and found out that I need to talk to my webhost.
Answer was simple `We won't help you`

I tried once again and what i noticed - now db_input.php just doesn't work. Every time my gallery needs to use this file there's white page with these message :

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@billkaulitz.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log


So my first question :
How can i fix it ?

And what about `searchnew.php`
It was working once a day.
Today i changed its permissions from 644 to 744 and now it's working more often.

My second question :
What can i do to make it working all the time ?  ???
« Last Edit: July 14, 2008, 05:21:45 pm by Joachim Müller »
Logged

delikatna

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Troubles with uploading & db_input.php
« Reply #1 on: July 11, 2008, 10:22:28 pm »

Ahh, forgot to say - my gallery url is www.billkaulitz.org/galeria/index.php

If it's needed...
Logged

Nibbler

  • Guest
Re: Troubles with uploading & db_input.php
« Reply #2 on: July 11, 2008, 10:29:37 pm »

My guess would be your host disabled it due to excessive use of resources (batch adding). You should ask them.
Logged

delikatna

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Troubles with uploading & db_input.php
« Reply #3 on: July 11, 2008, 11:15:49 pm »

It is to searchnew.php only or both of them ?
Logged

Nibbler

  • Guest
Re: Troubles with uploading & db_input.php
« Reply #4 on: July 11, 2008, 11:23:11 pm »

You need to talk to your webhost. If you are on shared hosting you need to be very careful about batch adding either large pics or a large number of pics.
Logged

delikatna

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Troubles with uploading & db_input.php
« Reply #5 on: July 12, 2008, 10:08:57 pm »

I asked them if they made any changes in my server and so, and they asked if i need anything new to upload to my server such a modules or so.  ??? ???
i think they just don't understand me.  :-[
what can i do ?  ???
Logged

Nibbler

  • Guest
Re: Troubles with uploading & db_input.php
« Reply #6 on: July 12, 2008, 10:27:23 pm »

You need to tell them what the problem is.

http://www.billkaulitz.org/galeria/db_input.php should not give a 500 error.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Troubles with uploading & db_input.php
« Reply #7 on: July 12, 2008, 10:43:33 pm »

If they then still don't know what to do (take a look at the server's error logs), you should look for another webhost.
Logged

delikatna

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Troubles with uploading & db_input.php
« Reply #8 on: July 14, 2008, 01:52:39 pm »

Hello guys.
So, my webhost helped me with repairing this 500 error and now db_input.php works. (there was something with permission)
But I still have troubled with searchnew.php...
It doesn't work.
They told me that they haven't made any changes in my server - the only thing that can makes searchnew.php is that the script has got limited time for every session and after some time passed it can stopped working for a while.
But what if it doesn't work anytime ?  ???

Soo..
What can i do to make searchnew.php working again ?  :-[ :-[ :'(
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Troubles with uploading & db_input.php
« Reply #9 on: July 14, 2008, 05:21:31 pm »

We have a strict "one issue per thread" policy that you agreed to respect when signing up. Issues with uploading (no matter what upload method you have issues with) should go into the uploads sub-board. Start a new thread there with the needed information after having read the docs, sections "upload troubleshooting" and "asking for support on upload issues". Read those sections carefully and do exactly as suggested there. Locking this thread, marking as "solved".
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 19 queries.