Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: [Solved]: Problem with new server migration  (Read 2938 times)

0 Members and 1 Guest are viewing this topic.

artisticlight

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
[Solved]: Problem with new server migration
« on: April 29, 2008, 12:57:50 am »

I read the steps needed to move cpg to a new server. I backed up my db using MyPhpAdmin, and backed up my entire site. I reloaded to my new site and had the hosting company load my db from the backup. I changed the permissions on the entire cpg directory, including albums, to 777. I changed include/config.inc.php to point to the new DB with the appropriate password and userid.

When I try to access cpg on the new server (http://artrevealed.net/cpg/) I get the following error...

Quote
Coppermine critical error:
Unable to connect to UDB database !

MySQL said:

That is it. There is nothing after "MySQL said:".

To test what was going on installed a new copy of cpg on my new server and changed the config.inc.php file to point to my db just to see if it would connect. I get the same message as above. However, if I change config.inc.php to point to another set of tables in the same db by changing the table prefix, it will connect. You can see that here http://artrevealed.net/cpg2/. It looks all goofy because there aren't any albums in cpg2. I just point it to the same db as cpg.

If I try to connect to tables prefixed with "cpg_" it will not connect. If I connect to tables prefixed with "cpgWIP_" it will connect. The tables prefixed with "cpgWIP_" were created a while back when I was testing cpg. I updated the debug flag in the cpg_config table hoping it might give me a better error message, but it doesn't. I assume it really isn't connecting.

Any thoughts on what maybe wrong? The tables are large. There are over half a million records in cpg_hit_stats. I moved servers to access newer versions of PHP and MySQL. If those were issues I don't think I could connect to cpg or cpg2.

Any help would be greatly appreciated. Thank you.

« Last Edit: April 29, 2008, 06:41:06 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: Problem with new server migration
« Reply #1 on: April 29, 2008, 10:16:59 am »

Go to bridgemgr.php and disable the bridge. Then update your gallery and redo the bridge.
Logged

artisticlight

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Problem with new server migration
« Reply #2 on: April 29, 2008, 06:28:13 pm »

Thank you, thank you, thank you!

That did the trick nibbler. I'm back up and running.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: [Solved]: Problem with new server migration
« Reply #3 on: July 11, 2008, 06:10:31 pm »

An unrelated reply to this thread has been split into a separate thread. Locking.

@the moderator who split this thread: don't just split - make loose ends fit, or don't split at all.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.