Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 [3]   Go Down

Author Topic: [cpg1.4.x]: PHPBB3 bridge  (Read 95272 times)

0 Members and 1 Guest are viewing this topic.

Nibbler

  • Guest
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #40 on: October 10, 2008, 11:16:05 pm »

That happens if you set the gallery to be available to logged in users only. If it doesn't recognise you as a user you will get redirected to the forum to login.
Logged

Enrick

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #41 on: October 19, 2008, 12:32:27 am »

Hi,

I´ve installed phpBB3 and Coppermine, both are working properly standalone.
Now I´ve tried to bridge Coppermine and the board.
The bridging has finished, but now I have some problems :

1. After login oder logout in Coppermine, the user will be directed to my phpBB3-forum.

2. No link to coppermine appears in the menu - or anywhere else - of my phpBB3 forum.

Coppermine install: http://enrick.cwsurf.de/gallery
Forum install: http://enrick.cwsurf.de/phpBB3
Coppermine Version: 1.4.19
PHPBB Forum Version: 3.0.2

Test Account
User Name: Testuser
Password: tousefortest

BridgeManager settings
Bridge app URL : Sorry, but I don´t understand this !
Relative path to your bridge app´s config file : ../phpBB3
Use post-based groups : 1

The Testuser-account has admin rights

I hope there´s a solutions for this problem.

Regards,

Mat
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #42 on: October 19, 2008, 03:00:55 pm »

1. After login oder logout in Coppermine, the user will be directed to my phpBB3-forum.
That's expected behaviour.

2. No link to coppermine appears in the menu - or anywhere else - of my phpBB3 forum.
That's expected behaviour as well.

Read up the bridging documentation!

The Testuser-account has admin rights
Yikes! Don't do that. Test user mustn't have admin powers. Remove admins powers from that user immediately.
Logged

attempt

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 26
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #43 on: October 30, 2008, 09:33:32 pm »

That happens if you set the gallery to be available to logged in users only. If it doesn't recognise you as a user you will get redirected to the forum to login.

It happend to me after a default install.
How can I change that if I can't acces anymore admin.php in Coppermine?
Logged

Nibbler

  • Guest
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #44 on: October 30, 2008, 11:24:09 pm »

Disable the bridge as described in the manual.
Logged

johnny-b

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #45 on: November 07, 2008, 03:45:16 am »

i have tryed this bridge and it does work for 90%

but the only issue i am having is:
When phpbb3 and coppermine are bridged and i log out on phpbb3 or coppermine with my admin user account, i can not approace the coppermine link to just login there, in a bridged status.

when i type in my coppermine link (while bridged)

http://mydomain.com/fotogallery/index.php and i hit enter?

i get this:

http://www.mydomain.com/ucp.php?mode=login&redirect=http%3A%2F%2Fwww.mydomain.com%2Ffotogallery%2F

the phpbb3 bridge in coppermine is using the phpbb3 cookie that must be right?
or is it something rong in the phpbb3.inc.php bridge file that is rong?

how can i prevent this from happening?

Logged

johnny-b

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #46 on: November 07, 2008, 03:48:27 am »

also my coppermine is assigned only that registered users can see inside my coppermine.
but my phpbb3 has permissions to see as guest but not to comment in it.
Logged

chrishoggy

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #47 on: November 11, 2008, 05:29:05 pm »

Hi guys.
I have the following issue with permissions and phpbb3 groups.

phpbb3's "Pre-defined" groups and permissions work perfectly, and I can change permissions/options etc in cpg. However, the "User defined" groups in phpbb3, are not working/bridging correctly. If I go in to the cpg permissions settings, all the user defined groups show up fine etc, and permissions can be changed. But cpg only seems to be using the permissions set by the "Pre-defined" user groups, eg, administrator,global mod, registered etc When I look at users in cpg, all carry the standard "Pre-defined" user group titles. I've bridged with and without post based groups, and get the same results.

Versions:
cpg 1.4.x = latest updated version
phpbb 3.0.2 = latest updated version
cpg cookie name = one found in pbpbb3 cookie settings.

If anybody could give me some pointers on how to get cpg to accept "User defined" group settings, as well as "Pre-defined", it would be much appreciated.
Logged

chrishoggy

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #48 on: November 11, 2008, 05:43:30 pm »

Feel really stupid now, as I've sorted it within mins of posting.
Here is where I was going wrong, and this may be where others go wrong too.
When I've added users to a user defined group, I've literally just added that group to the users groups list, and this works fine for phpbb. In order for a phpbb user defined group permission to work in cpg, you have to set it as that users "default group" in phpbb3 member control.

So to put it simply, cpg only uses the phpbb members default user group. It will not take in to account any other user groups that person may be in/added to.
I was using smf bridged with cpg before, and the bridge gave permissions for all groups that member was in, rather than just their default group.

Sorry for the confusion, and thanks again for this bridge 8)
Logged

edenffs

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #49 on: November 11, 2008, 08:37:49 pm »

Is it possible to include files that are attached to phpbb3 forum posts to the coppermine gallery?
by attached I mean files that are uploaded as attachments to forum posts.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: [cpg1.4.x]: PHPBB3 bridge
« Reply #50 on: November 12, 2008, 12:15:33 am »

Start a thread of your own, doing exactly as suggested in the sticky thread on the bridging support board cpg1.4 (BBS) integration / bridging named "When requesting bridge support - mandatory!". To avoid this thread from getting cluttered even more with individual issues I have to lock it *sigh*.
Logged

Chone

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Patch for phpbb3 bridge
« Reply #51 on: March 20, 2009, 03:00:04 pm »

Problem: When a user is a member of many groups, and the administrators group is not his default group (but this user is a member of the administrators group), he's not an admin within Coppermine.

Attached to this post is a patch, which should be run against the phpbb3.inc.php file as found on http://forum.coppermine-gallery.net/index.php/topic,53678.0.html.

I am definitely new to Coppermine, so I don't know exactly if this is the correct way or not, but it works for me.

Nibbler, would it be able to apply this patch to the download you are offering?
Logged
Pages: 1 2 [3]   Go Up
 

Page created in 0.115 seconds with 23 queries.