Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: 500 Internal Server Error - on new server  (Read 3982 times)

0 Members and 1 Guest are viewing this topic.

whats_up_skip

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 52
[Solved]: 500 Internal Server Error - on new server
« on: June 25, 2008, 09:02:59 am »

I have move one of my sites to a new server. The site has two installations of Coppermine on it. One of these is working properly, but the other one is receiving the:

"500 Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@japaneselifestyle.com.au and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. "

This error occurs even when I try to access the main page.

From searching the forum I notice that some people had problems with ".htaccess" file and related plug in. I deleted this file, but it made no difference, so I put it back again.
« Last Edit: June 27, 2008, 07:05:34 am by Nibbler »
Logged

Nibbler

  • Guest
Re: 500 Internal Server Error - on new server
« Reply #1 on: June 25, 2008, 11:05:55 am »

Check the error log as suggested. A link to your gallery might be helpful too.
Logged

eaf

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: 500 Internal Server Error - on new server
« Reply #2 on: June 25, 2008, 01:06:48 pm »

Hi,
I am having a very similar problem.  I successfully installed ver cpg1418 on a Bizland server last week as a test and have been able to use the full functionality with no problems into my account.  Yesterday, I setup a new Bizland client account and received the following error when attempting to run install.php:

The server encountered an unexpected condition which prevented it from fulfilling the request.
The script had an error or it did not produce any output. If there was an error, you should be able to see it in the error log.

I copied all the files into a directory on the server, changed permissions to 777 and setup the databsed as directed.

Any ideas why I am receiving this error message?


Suggestions/assistance would be greatly appreciated.
eaf
Logged

Nibbler

  • Guest
Re: 500 Internal Server Error - on new server
« Reply #3 on: June 25, 2008, 01:12:17 pm »

Start a new thread please. And at least do as suggested above.
Logged

whats_up_skip

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 52
Re: 500 Internal Server Error - on new server
« Reply #4 on: June 25, 2008, 01:18:50 pm »

The galleries are:
Not Working: http://www.japaneselifestyle.com.au/japan_picture

Working: http://www.japaneselifestyle.com.au/japanese_friends/japanese_girls/

I have gone looking all over the place. Where should I be able to find the error logs.
Logged

Nibbler

  • Guest
Re: 500 Internal Server Error - on new server
« Reply #5 on: June 25, 2008, 01:36:56 pm »

Depends on how your server is setup. Try looking in your home directory or talk to your webhost. Make sure permissions are correct on the japan_picture folder and compare the permissions to those on the folder that works.
Logged

whats_up_skip

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 52
Re: 500 Internal Server Error - on new server
« Reply #6 on: June 27, 2008, 05:49:28 am »

Thanks for you help with this one.

I went over the directory attributes again and compared the two. When I changed them to exactly the same it worked. Some of the directories were marked 777 instead of 755.
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 20 queries.