Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Problem batch adding pics  (Read 5763 times)

0 Members and 1 Guest are viewing this topic.

lovinglynam

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Problem batch adding pics
« on: June 08, 2008, 09:42:45 am »

I can add pics to my albums one at a time but it will not let me batch add. I have double checked my permissions and they are correct. When I created the album, went to batch add files, it says to select the directory. I do this. Then it tells me to select the album to save it to, I do this. Click insert selected files and it takes me right back to the select a directory page. It does not give me any kind of error. Just sends me in circles. HELP???
Logged

lovinglynam

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Problem batch adding pics
« Reply #1 on: June 08, 2008, 06:39:07 pm »

Here is what comes up in debug mode:
Code: [Select]
USER:
------------------
Array
(
    [ID] => 4a3687563dfbc053cbb9336168824b60
    [am] => 1
    [lap] => 1
    [liv] => Array
        (
            [0] => 8472
            [1] => 8731
            [2] => 8089
            [3] => 8092
            [4] => 40389
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => lisacase
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg11d_filetypes; (0s)
    [1] => select * from cpg11d_plugins order by priority asc; (0s)
    [2] => delete from `lisacase_`.cpg11d_sessions where time<1212939316 and remember=0; (0s)
    [3] => delete from `lisacase_`.cpg11d_sessions where time<1211733316; (0s)
    [4] => select user_id from `lisacase_`.cpg11d_sessions where session_id = 'b26bad75d180044d71f2e9775efd0460' (0s)
    [5] => select user_id as id, user_password as password from `lisacase_`.cpg11d_users where user_id=1 (0s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `lisacase_`.cpg11d_users AS u INNER JOIN `lisacase_`.cpg11d_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
    [7] => SELECT user_group_list FROM `lisacase_`.cpg11d_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg11d_usergroups WHERE group_id in (1) (0s)
    [9] => SELECT group_name FROM  cpg11d_usergroups WHERE group_id= 1 (0s)
    [10] => update `lisacase_`.cpg11d_sessions set time='1212942916' where session_id = 'b26bad75d180044d71f2e9775efd0460' (0s)
    [11] => SELECT user_favpics FROM cpg11d_favpics WHERE user_id = 1 (0s)
    [12] => DELETE FROM cpg11d_banned WHERE expiry < '2008-06-08 16:35:16' (0s)
    [13] => SELECT * FROM cpg11d_banned WHERE (ip_addr='74.240.74.6' OR ip_addr='74.240.74.6' OR user_id=1) AND brute_force=0 (0s)
    [14] => SELECT aid, title FROM cpg11d_albums WHERE 1 (0s)
    [15] => SELECT COUNT(*) FROM cpg11d_pictures WHERE approved = 'NO' (0.003s)
    [16] => SELECT filepath, filename FROM cpg11d_pictures WHERE filepath LIKE '6-6-08ironhorse%' (0.008s)
    [17] => SELECT aid, title FROM cpg11d_albums WHERE category = 0 (0s)
    [18] => SELECT DISTINCT a.aid as aid, a.title as title, c.name as cname FROM cpg11d_albums as a, cpg11d_categories as c WHERE a.category = c.cid AND a.category < '10000' (0s)
    [19] => SELECT aid, CONCAT('(', user_name, ') ', a.title) AS title
                                                        FROM cpg11d_albums AS a
                                                        INNER JOIN `lisacase_`.cpg11d_users AS u
                                                        ON category = (10000 + 1) AND user_id = 1 ORDER BY title (0s)
)

==========================
GET :
------------------
Array
(
    [startdir] => 6-6-08ironhorse
)

==========================
POST :
------------------
Array
(
)

==========================
VERSION INFO :
------------------
PHP version: 5.2.5 - OK
------------------
mySQL version: 5.0.45-community
------------------
Coppermine version: 1.4.18(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.34 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support:
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 5.0.45
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib64 -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.3
Linked Version 1.2.3
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/usr/lib/php:/usr/local/lib/php | .:/usr/lib/php:/usr/local/lib/php
open_basedir | /home/lisacase:/usr/lib/php:/usr/local/lib/php:/tmp | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /usr/sbin/sendmail -t -i | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 2M | 2M
post_max_size | 8M | 8M
==========================
Page generated in 0.114 seconds - 20 queries in 0.011 seconds - Album set : ; Meta set: ;
« Last Edit: June 09, 2008, 09:45:07 am by Hein Traag »
Logged

lovinglynam

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Problem batch adding pics
« Reply #2 on: June 08, 2008, 06:42:40 pm »

This is under notcies:

/include/functions.inc.php

    * Notice line 2688: Undefined variable: i

/searchnew.php

    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 101: Undefined variable: sel_album
    * Notice line 169: Undefined variable: fullimagesize
    * Notice line 170: Undefined variable: fullimagesize
    * Notice line 169: Undefined variable: fullimagesize
    * Notice line 170: Undefined variable: fullimagesize
    * Notice line 169: Undefined variable: fullimagesize
    * Notice line 170: Undefined variable: fullimagesize
    * Notice line 169: Undefined variable: fullimagesize
    * Notice line 170: Undefined variable: fullimagesize
    * Notice line 169: Undefined variable: fullimagesize
    * Notice line 170: Undefined variable: fullimagesize
    * Notice line 169: Undefined variable: fullimagesize
    * Notice line 170: Undefined variable: fullimagesize
    * Notice line 169: Undefined variable: fullimagesize
    * Notice line 170: Undefined variable: fullimagesize
    * Notice line 169: Undefined variable: fullimagesize
    * Notice line 170: Undefined variable: fullimagesize
    * Notice line 169: Undefined variable: fullimagesize
    * Notice line 169: Undefined variable: fullimagesize
    * Notice line 170: Undefined variable: fullimagesize
    * Notice line 169: Undefined variable: fullimagesize

    and so on
« Last Edit: June 09, 2008, 09:46:49 am by Hein Traag »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problem batch adding pics
« Reply #3 on: June 08, 2008, 06:44:48 pm »

Stop it! You're doing the opposite of what you're suppossed to do. RTFM! Is the gallery in question per chance http://www.lovinglynam.com/gallery/ ?
Then you must be Lisa (Loving Lynam) and shouldn't have signed up with another username.
Logged

lovinglynam

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Problem batch adding pics
« Reply #4 on: June 09, 2008, 01:28:48 am »

I havent used the forum in a LONG time I am sure and didnt even remember my old accountifo. Yes it is the same site. If you would kindly tell me what info you could that would Help my situation instead of biting my head off it would be greatly appreciated. I read through all the FAQ thing on uploading problems, I spent 3 hours doing that last night. I would not have bothered to post here if it wasnt necessary. So, any clue as to what could be going on? Or is there something I can do to help you to help me resolve this?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problem batch adding pics
« Reply #5 on: June 09, 2008, 07:42:46 am »

I already told you what to do. Let me quote from the section of the docs that I have refered to:
Quote
4.11.5 Asking for support on upload issues
When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested. If you want fast results, you should disable admin approval for the group the test user is in, so supporters can tell instantly what is wrong without needing to double-check.

When people have issues with uploading and decide to post their question on the Coppermine support board, they usually are told to read this upload troubleshooting section. Many of them fail to do so properly, which results in frustration both for users as well as supporters. To make this absolutely clear: the above mentioned steps are absolutely mandatory, no matter what skill level you have, no matter what upload method you have troubles with. Failing to do exactly as suggested will result in your request for help being ignored. Yes, this applies to you. We mean it!
Logged

lovinglynam

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Problem batch adding pics
« Reply #6 on: June 10, 2008, 08:43:45 am »

Test account is set up
username: testuser
password: testpass


Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problem batch adding pics
« Reply #7 on: June 10, 2008, 09:22:25 am »

Again: do as suggested in the docs. The number of file upload fields is set to 5 (should be 1), the number of URI upload fields is set to 3 (should be 0), debug_mode is off (should be on). I really hate it to be forced to repeat the instructions over and over. Read the instructions extra-carefully!!!
Logged

lovinglynam

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Problem batch adding pics
« Reply #8 on: June 10, 2008, 03:42:35 pm »

Debug was on...
and I have set the settings.
Still doesnt work
Logged

lovinglynam

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Problem batch adding pics
« Reply #9 on: June 10, 2008, 04:09:24 pm »

I was finally able to upload pics via the web transfer section, but the Batch Upload is still not working.
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Problem batch adding pics
« Reply #10 on: June 10, 2008, 04:19:33 pm »

Read this thread and the suggested in there by Nibbler: http://forum.coppermine-gallery.net/index.php/topic,52656.0.html
Logged

lovinglynam

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Problem batch adding pics
« Reply #11 on: June 10, 2008, 04:53:22 pm »

Where is the php.ini file located? I read in that thread to change add this in the php.ini file and cannot find it.
suhosin.post.max_vars = 1000
suhosin.request.max_vars = 1000

Did you go into the test area and verify my problem with this?
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Problem batch adding pics
« Reply #12 on: June 10, 2008, 04:54:55 pm »

I managed to login and upload 1 pic yes. If you can not find php.ini then go contact your host for support with that.
Logged

lovinglynam

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Problem batch adding pics
« Reply #13 on: June 10, 2008, 05:29:58 pm »

I said in the very beginning that i can upload 1 pic. The problem lies in the Batch Upload.  Thats what I need help with.
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Problem batch adding pics
« Reply #14 on: June 10, 2008, 08:05:38 pm »

a quote from that thread i mentioned a few post earlier:
Quote
My issue is that after uploading the images via FTP, I select Batch Upload Files. I see the directory and select it. All thumbnails are visible and I select the album and 'Insert Selected Files'.

I then go immediately go back to the Batch Add Files Select Directory Screen

Looks to be very much the same problem does it not ? Contact your host and have them reconfigure php.ini using the info from that thread , if you can not do that yourself.

Hein
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 20 queries.