Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: how to set permissions for users  (Read 5999 times)

0 Members and 1 Guest are viewing this topic.

basicxman

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
how to set permissions for users
« on: June 07, 2008, 02:27:48 am »

How do I set what albums normal (non-admin) users can upload to?
« Last Edit: June 07, 2008, 06:51:06 pm by just_some_guy »
Logged

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Re: how to set permissions for users
« Reply #1 on: June 07, 2008, 02:53:53 am »

Logged
Read Docs and Search the Forum before posting. - Soporte en espaņol
--*--
Fabricio Ferrero's Website

Catching up! :)

basicxman

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: how to set permissions for users
« Reply #2 on: June 07, 2008, 05:46:13 pm »

i read those but i finally found my problem, i thought visitors meant the 'guests' group or other non-registered people
Logged

basicxman

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: how to set permissions for users
« Reply #3 on: June 07, 2008, 06:37:01 pm »

no never mind this is not solved, my users can still not go on my gallery

user: demo_user
pass: awesome
Logged

basicxman

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: [Solved]: how to set permissions for users
« Reply #4 on: June 07, 2008, 06:39:56 pm »

all the albums are set to Visitors can upload files and all registered and admin users can upload to personal and public galleries
their quota is set to max
but i still get the error `0 uploads were successful `

all the needed drectories are set to 777 or 755 for permissions so what is going on!?
Logged

basicxman

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: how to set permissions for users
« Reply #5 on: June 07, 2008, 06:41:27 pm »

lol i keep forgetting stuff

i know there are no PHP errors because as an admin i'm able to upload stuff and a user was previously able to upload to his personal gallery
Logged

just_some_guy

  • Supporter
  • Coppermine addict
  • ****
  • Offline Offline
  • Posts: 539
  • I am currently on holiday, back in a few weeks. :D
Re: how to set permissions for users
« Reply #6 on: June 07, 2008, 06:55:33 pm »

Ok, I have changed the topic back to unsolved. You have not provided a link to your gallery, you need to do this and also ensure you have done what has been said in the "Upload Troubleshooting" section of the documentation and also read the sticky thread in this board. Plus, enable debug mode and post the error message you receive when you try to upload files.
Logged
Tambien, Hablo Espaņol      PHP - Achieve Anything
"The Internet is becoming the town square for the global village of tomorrow. " - Bill Gates
Windows 7 Forums

basicxman

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: how to set permissions for users
« Reply #7 on: June 07, 2008, 07:03:10 pm »

lol srry: http://theroboticsuniverse.com/GalleryR/

all the PHP stuff is set properly in php.ini

error:
USER:
------------------
Array
(
    [ID] => a0fc21bd645f2e0c84668dc9a1837510
    [am] => 1
    [lang] => english
    [liv] => Array
        (
        )

    [search] => Array
        (
            [search] => Gear Shifter
            [album] => search
            [title] => on
            [newer_than] =>
            [caption] => on
            [older_than] =>
            [keywords] => on
            [type] => AND
            [params] => Array
                (
                    [title] => on
                    [caption] => on
                    [keywords] => on
                )

        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 5
    [user_name] => demo_user
    [groups] => Array
        (
           
  • => 2

        )

    [disk_max] => 2147483647
    [disk_min] => 2147483647
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 1
    [num_file_upload] => 10
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 0
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Registered
    [upload_form_config] => 3
    [group_quota] => 2147483647
    [can_see_all_albums] => 0
    [group_id] => 2
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM filetypes; (0s)
  • [1] => select * from plugins order by priority asc; (0s)
        [2] => delete from `therobo1_ss4553`.sessions where time<1212854565 and remember=0; (0s)
        [3] => delete from `therobo1_ss4553`.sessions where time<1211648565; (0s)
        [4] => select user_id from `therobo1_ss4553`.sessions where session_id = '1efb379143be63875c19accf2003fecf' (0s)
        [5] => select user_id as id, user_password as password from `therobo1_ss4553`.users where user_id=5 (0s)
        [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `therobo1_ss4553`.users AS u INNER JOIN `therobo1_ss4553`.usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='5' (0s)
        [7] => SELECT user_group_list FROM `therobo1_ss4553`.users AS u WHERE user_id='5' and user_group_list <> ''; (0s)
        [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM usergroups WHERE group_id in (2) (0s)
        [9] => SELECT group_name FROM  usergroups WHERE group_id= 2 (0s)
        [10] => update `therobo1_ss4553`.sessions set time='1212858165' where session_id = '1efb379143be63875c19accf2003fecf' (0s)
        [11] => SELECT user_favpics FROM favpics WHERE user_id = 5 (0s)
        [12] => DELETE FROM banned WHERE expiry < '2008-06-07 17:02:45' (0s)
        [13] => SELECT * FROM banned WHERE (ip_addr='24.141.143.234' OR ip_addr='24.141.143.234' OR user_id=5) AND brute_force=0 (0s)
        [14] => SELECT aid FROM albums WHERE visibility != '0' AND visibility !='10005' AND visibility NOT IN (2) (0s)
        [15] => SELECT aid, title FROM albums WHERE category < 10000 AND uploads='YES' AND (visibility = '0' OR visibility IN (2)) ORDER BY title (0s)
        [16] => SELECT aid, title FROM albums WHERE category='10005' ORDER BY title (0s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
       
[control] => phase_1
)

==========================
Page generated in 0.054 seconds - 17 queries in 0 seconds - Album set : AND aid NOT IN (1,3,5,6,7,8,9,10,11,12,13) ; Meta set: ;
Logged

just_some_guy

  • Supporter
  • Coppermine addict
  • ****
  • Offline Offline
  • Posts: 539
  • I am currently on holiday, back in a few weeks. :D
Re: how to set permissions for users
« Reply #8 on: June 07, 2008, 07:11:10 pm »

That's the debug output not the error, there will be an error message below the -  "0 uploads were successful".

Please enable debug mode for everybody so supporters can test the upload.

I see that Coppermine has been installed using an auto installer, this is not the recommended way of installing.
Logged
Tambien, Hablo Espaņol      PHP - Achieve Anything
"The Internet is becoming the town square for the global village of tomorrow. " - Bill Gates
Windows 7 Forums

basicxman

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: how to set permissions for users
« Reply #9 on: June 07, 2008, 07:13:00 pm »

it is done
Logged

just_some_guy

  • Supporter
  • Coppermine addict
  • ****
  • Offline Offline
  • Posts: 539
  • I am currently on holiday, back in a few weeks. :D
Re: how to set permissions for users
« Reply #10 on: June 07, 2008, 07:30:08 pm »

Your gallery seems to have some form of suppressed debug mode, it is missing the information about the PHP configuration etc in the output. There should be a more detailed error message shown when an upload fails and debug mode is enabled, currently there is no error message showing on your site, be it a consequence of using an auto installer and/or having a different debug mode i am not sure. Make sure that the width & max file size options in the config are great enough for the files you are trying to upload. Review your file permissions and PHP settings also.
Logged
Tambien, Hablo Espaņol      PHP - Achieve Anything
"The Internet is becoming the town square for the global village of tomorrow. " - Bill Gates
Windows 7 Forums

basicxman

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: how to set permissions for users
« Reply #11 on: June 07, 2008, 07:55:31 pm »

i used an auto installer -> should I manual install?  how I can stop it from losing all my photos, i could save thme all but i would rather not have to upload so many photos
Logged

basicxman

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: how to set permissions for users
« Reply #12 on: June 07, 2008, 07:59:54 pm »

it is missing the information about the PHP configuration etc in the output.

there is under the debug mode click display phpinfo, it shows a bunch of stuff
Logged

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Re: how to set permissions for users
« Reply #13 on: June 08, 2008, 01:57:45 am »

Quote
should I manual install?

It's always better.
Logged
Read Docs and Search the Forum before posting. - Soporte en espaņol
--*--
Fabricio Ferrero's Website

Catching up! :)

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: how to set permissions for users
« Reply #14 on: June 08, 2008, 02:01:00 am »

No, just perform an upgrade as we suggest in the docs.
Logged

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Re: how to set permissions for users
« Reply #15 on: June 08, 2008, 10:04:20 pm »

Quote
It's always better.

Sorry, I just try to explain that if he is going to install again (and decide not follow your advises) I recommend to do a manual installing. I mean, in general terms, always is prefered a manual installing.
Logged
Read Docs and Search the Forum before posting. - Soporte en espaņol
--*--
Fabricio Ferrero's Website

Catching up! :)

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: how to set permissions for users
« Reply #16 on: June 09, 2008, 07:39:43 am »

Sure, manual installs as we suggest them in the docs are in fact the only supported install method. But if someone has used an auto-installer, we recommend not to perform a fresh install, but perform an upgrade, see http://documentation.coppermine-gallery.net/en/auto-installers.htm#no_support
Logged
Pages: [1]   Go Up
 

Page created in 0.037 seconds with 20 queries.