Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: Problems Moving Gallery to New Host  (Read 2572 times)

0 Members and 1 Guest are viewing this topic.

AriannaErin

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
[Solved]: Problems Moving Gallery to New Host
« on: June 01, 2008, 10:17:19 pm »

Sorry if this was answered already but I've read through a few of the posts and I still can't figure out what I'm doing wrong.

I had my site (http://www.nicholecordova.org) hosted at http://www.orangesarecool.com and the gallery http://www.nicholecordova.org/gallery was there as well.

recently I've moved the site to http://www.fan-sites.org. I saved the gallery.sql.gz file and tried to "restore it" in my new cpanel, moved the actually gallery files to the new site, 'cmod'ed everything to '777' but when I tried to start the gallery again, basically it's a blank gallery. http://www.nicholecordova.org

I'm not sure what step I'm missing but I really hope I dont have to redo the entire gallery :(

Can anyone help, and what info (if any) do you need to help me, I'm so lost so sorry if this is really stupid...

Thanks in Advance! :D
« Last Edit: June 04, 2008, 09:32:47 pm by just_some_guy »
Logged

Riox

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: Problems Moving Gallery to New Host
« Reply #1 on: June 01, 2008, 11:38:02 pm »

Unzip/Untargz (winrar or 7zip can handle .gz). Open the .sql file with a editor that can handle UTF8
Search and Replace nicholecordova.org with fan-sites.org

rezip and replace the db in phpmyadmin.

Note: You have to fix config.inc.php if the DB name changed
Logged

AriannaErin

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Problems Moving Gallery to New Host
« Reply #2 on: June 02, 2008, 06:29:02 am »

Hey thanks for trying to help, the old host was actually orangesarecool.com but I can't find either it or nicholecordova.org in the file in order to change it to fan-sites.org and rezip it.

Any ideas?
Logged

Riox

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: Problems Moving Gallery to New Host
« Reply #3 on: June 02, 2008, 11:37:39 am »

D'ah.. I thought that where your new and old domain names.. >.<

Try to not use fantastico from the cPanel and install CPG the hard way. If thats up and running, replace the DB. If you still get a white page... maybe you had a custum themen that dosn't come with the default installation?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Problems Moving Gallery to New Host
« Reply #4 on: June 02, 2008, 05:06:20 pm »

That's not the recommended way (installing from fresh and then replacing the db). Read up the docs and the FAQ, they explain both questions in abundance.
However, Riox is right in the aspect of auto-installers like Fantastico: they suck and are neither recommended nor supported.
Logged

AriannaErin

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Problems Moving Gallery to New Host
« Reply #5 on: June 04, 2008, 08:26:32 pm »

Thanks guys, I did as much as I could on my own and had my host give me a hand, but thanks so much for your advice and time ;)

Logged
Pages: [1]   Go Up
 

Page created in 0.059 seconds with 19 queries.