Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: added own logo etc to main page ages ago - now can't find file  (Read 4243 times)

0 Members and 1 Guest are viewing this topic.

arjay

  • Coppermine newbie
  • Offline Offline
  • Posts: 11

I do apologise for this post.  I HAVE tried to search and read everything I can find in the support pages, in the manual and via google, but can't find what i am looking for.

I changed the display of the gallery on our web site ages ago by adding our own club logo, and adding a link to "Return to the Main Website".  I now want to make another minor change but cannot find the modified file/s.  I have looked in /images/gallery/themes/classic (which i think is our theme) and opened template.html and theme.php.  Neither appear to have been modified.  None of the other themes have been modded either.

The website is  www.solclassiccarclub.net. The gallery is under Photos/Members Cars.  If I go to that page and then "View Source" I get (relevant part):

Code: [Select]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html dir="ltr">
<head>
<title>Sol Classic Car Club - Home > Cars</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="Pragma" content="no-cache" />

<link rel="stylesheet" href="themes/classic/style.css" type="text/css" />
<script type="text/javascript" src="scripts.js"></script>
<!-- $Id: template.html,v 1.18 2005/10/25 01:16:24 gaugau Exp $ -->
</head>
<body>
 
  <table width="100%" border="0" cellpadding="20" cellspacing="20">

    <tr>
      <td valign="top" style="border: 1px solid #666666;background-color:#FFFFFF;">
        <table width="100%" border="0" cellspacing="0" cellpadding="0">
          <tr>
            <td>
              <a href="index.php"><img src="themes/classic/images/site_logo.png" border="0" alt="" /></a><br />
            </td>
            <td width="100%" align="center">
              <h1>Sol Classic Car Club</h1>

              <h3>Displaying pictures of members &amp; their cars</h3><br />
                          <!-- BEGIN home -->
        <a href="http://solclassiccarclub.net/index.html " title="Go to the home page">HOME (BACK TO MAIN WEBSITE)</a> ::

Any help would be appreciated.  I presume i have done something silly (apart from not record what I changed!)
Logged

arjay

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: added own logo etc to main page ages ago - now can't find file
« Reply #1 on: May 22, 2008, 01:14:50 pm »

Oooops - I think I found it in the Config section of the actual website gallery's main page.  I am just experimenting with it now.

Hope this will avoid anyone having to search me an answer.

Unless you think different!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: added own logo etc to main page ages ago - now can't find file
« Reply #2 on: May 22, 2008, 02:23:16 pm »

Actual ink to gallery is http://www.solclassiccarclub.net/images/gallery/
The file to edit (with a plain text editor) is http://www.solclassiccarclub.net/images/gallery/themes/classic/template.html
Warning: you're using cpg1.4.2, while the most recent stable release currently is cpg1.4.18, so you're running 16 versions behind. All versions before cpg1.4.18 that contain security flaws that are actively being exploited. Before doing anything else it's absolutely mandatory to upgrade right now!!!
Logged

arjay

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: added own logo etc to main page ages ago - now can't find file
« Reply #3 on: May 22, 2008, 02:48:41 pm »

Actual ink to gallery is http://www.solclassiccarclub.net/images/gallery/
The file to edit (with a plain text editor) is http://www.solclassiccarclub.net/images/gallery/themes/classic/template.html

Thanks for the information.  Actually, I checked the file you pointed me to but it has never been modified - strange.  I found that I could do the same thing by opening the gallery as the admin user and making the changes in the Config section of the gallery itself, if that makes sense.  I think that is where I did it in the first place.

Quote
Warning: you're using cpg1.4.2, while the most recent stable release currently is cpg1.4.18, so you're running 16 versions behind. All versions before cpg1.4.18 that contain security flaws that are actively being exploited. Before doing anything else it's absolutely mandatory to upgrade right now!!!

Oooops thanks for the warning.  Our host PagesGarden went through a period of 6 months of offering no tech support, including warnings about updates - so we are in the process of moving the site to a new host.  I suppose I should have checked but am ashamed to say I never did.  Luckily, the gallery has not been affected by anything untoward up till now.  I will definitely do an upgrade as soon as the site has been transferred to the new host (taking place in the next few days)


Thanks for bearing with me.  This is my first web site.  Newbie is hardly a sufficient description!
Logged

arjay

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: added own logo etc to main page ages ago - now can't find file
« Reply #4 on: May 22, 2008, 03:55:35 pm »

BTW - I see from our new hosts website that they are offering cpg 1.3.3 and you are worried about me using 1.4.2!!

Also - perhaps you could help out here.  I have already uploaded all my cpg files to the new website.  How do I upgrade/update to 1.4.18 without messing up all my files, databases etc?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: added own logo etc to main page ages ago - now can't find file
« Reply #5 on: May 23, 2008, 01:47:47 am »

Transfering a gallery from one server to the other is being explained in the FAQ. Upgrading is explained in the docs. You agreed to read the docs before being allowed to post here. Do so now!
Logged
Pages: [1]   Go Up
 

Page created in 0.042 seconds with 21 queries.