Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Gallery won't let me put pictures in it  (Read 5910 times)

0 Members and 1 Guest are viewing this topic.

sparrow-in-flight

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Gallery won't let me put pictures in it
« on: October 22, 2008, 09:12:42 pm »

Hello there!
I have a problem with my coppermine gallery and I hope someone here can help me.

I am able to upload pictures of ftp of course, but it will not let me put the pictures into the gallery itself. It does not say that there are any errors or anything, it simply directs me back to the list of albums on the ftp sever.
I tried to upload a single picture, but the gallery would not let me put it into an album either... :-\

I would much apperciate your help! Thanks in advance!

Hannah
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Gallery won't let me put pictures in it
« Reply #1 on: October 23, 2008, 07:41:57 am »

Do exactly as suggested in the docs, section "asking for support on upload issues".
Logged

sparrow-in-flight

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Gallery won't let me put pictures in it
« Reply #2 on: October 24, 2008, 12:34:10 pm »

link: http://www.sparrow-in-flight.com/awe/index.php
user: test
pass: tset

As stated, we only use the mass import function. When using the 755 rights it mocks it wants to have 755 or 777  rights.
I attached two debug files, one before the import(on the file select page) and one after.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Gallery won't let me put pictures in it
« Reply #3 on: October 24, 2008, 10:14:39 pm »

Quote
Sorry there is no album where you are allowed to upload files
That's what I get when logging in with the test user account and clicking on the upload link. What should I test with? Make sure that you have tested the test user account for yourself before wasting supporter's time.
Logged

sparrow-in-flight

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Gallery won't let me put pictures in it
« Reply #4 on: October 25, 2008, 10:06:53 am »

I made a group called upload and gave it a quotum and upload rights (rights: yes, approval: no), the test user is member of that group.
A wanted to select an album for this group but gallery states "This group has no special access'". So i could not select one.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Gallery won't let me put pictures in it
« Reply #5 on: October 25, 2008, 11:26:22 am »

The link you followed is labelled "assigned albums". You can view assigned albums there. You can not assign albums there to that group, as the link is not named "assign albums". Read up the documentation, I'm not ready to read the docs for you aloud. Hint: look up "album properties" to allow that group to upload to a public album. Alternatively, allow that group to have personal galleries on the groups control panel.
Logged

sparrow-in-flight

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Gallery won't let me put pictures in it
« Reply #6 on: October 26, 2008, 04:08:17 pm »

Hey,
I attached 3 files which show what happens when I try to batchupload images. I really do not know what I have to do... For some reason the gallery does allow me now to upload single pictures, but the batchupload continues bitching.

regards,
Hannah
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Gallery won't let me put pictures in it
« Reply #7 on: October 26, 2008, 08:16:18 pm »

Do exactly as suggested in the docs, section "asking for support on upload issues".
You haven't done so. The test user account now has permissions to upload, but the number of file and uri upload fields is still not set up properly. Stop wasting supporter's time. Do exactly as suggested.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.