Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: blank page  (Read 4266 times)

0 Members and 1 Guest are viewing this topic.

damjan

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
[Solved]: blank page
« on: May 13, 2008, 11:18:47 pm »

Hi,
I have a strange problem:
I get blank page when I try to open gallery but only when I try to see gallery with IE7 or Firefox 2 - if I browse with Firefox 3 it works without problem:
www.ribica.si/gallery
I deleted caches, I tried on 4 different computers, but it's allways the same - blank page with IE7 or Firefox 2.
Where is the problem ????
Thanks.
« Last Edit: May 27, 2008, 06:58:49 am by Joachim Müller »
Logged

Nibbler

  • Guest
Re: blank page
« Reply #1 on: May 13, 2008, 11:34:25 pm »

You need to update your gallery. 1.4.18 is the current version. I only have FF3 so I can't replicate your issue. My only guess would be your IE7 and FF2 are set to Russian and your FF3 is english/slovenian/croatian ?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: blank page
« Reply #2 on: May 14, 2008, 08:52:36 am »

German is my default language in my browser, so going to http://www.ribica.si/gallery/ would be the same as if I went to http://www.ribica.si/gallery/?lang=german. Both pages are blank for me as well (using FF2). Forcing the english language file by going to http://www.ribica.si/gallery/?lang=english works as expected: the page isn't blank, but display as expected.
Therefor, as Nibbler already proposed: there is something fishy with your language files. Get a vanilla coppermine package and upload the language files (all files that reside inside the lang-folder to your server, overwriting the exiting ones (as some of the existing ones appear to be broken).
Logged

damjan

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: blank page
« Reply #3 on: May 18, 2008, 10:37:41 pm »

Thanks for help.
Yes, it's some kind of language problem.
I've updated gallery to latest version, deleted and uploaded languages again, but nothing changes. English works, but other languages do not. My browsers are set to Slovenian where the gallery still show blank page. It works if I force English, otherwise not. There is language problem, but not with language files.
Any other idea?

Logged

Nibbler

  • Guest
Re: blank page
« Reply #4 on: May 18, 2008, 11:13:15 pm »

Delete all files other than english.php from your lang directory as a work-around.
Logged

damjan

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: blank page
« Reply #5 on: May 20, 2008, 09:48:16 am »

I did it - the gallery works fine - in english.
Then I added slovenian.php only, but http://www.ribica.si/gallery/?lang=slovenian still shows blank page - the same as http://www.ribica.si/gallery/?lang=german (there is no german.php file in lang folder at the moment).
So the gallery is only able to read english language file, but it can't read other language files.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: blank page
« Reply #6 on: May 20, 2008, 09:58:17 am »

There is indeed no German language file (http://www.ribica.si/gallery/lang/german.php returns a 404), so going to http://www.ribica.si/gallery/?lang=german should have the same result as going to http://coppermine-gallery.net/Obsolete?lang=doesnt_exist
As this is not the case for you, there is something fishy in another file. I suggest performing a complete upgrade (even though you're already running the most recent stable release cpg1.4.18) as suggested in the docs. My guess is that another file is broken or corrupted.
Logged

damjan

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: blank page
« Reply #7 on: May 21, 2008, 10:52:50 am »

I've installed a fresh copy (downloaded from your site and saved into new folder) to another folder - galerija - on the site with another database. There were no problem with instalation. I didn't make any modification. The problem is the same:
http://www.ribica.si/galerija/?lang=english - works
http://www.ribica.si/galerija/?lang=slovenian - blank page
http://www.ribica.si/galerija/?lang=german - blank page
 ???
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: blank page
« Reply #8 on: May 21, 2008, 12:41:10 pm »

I didn't suggest to perform a fresh install, but an upgrade. Do as I suggested. Make sure that your FTP app is set up properly (FTP mode!).
Logged

damjan

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: blank page
« Reply #9 on: May 21, 2008, 03:07:00 pm »

I upgraded gallery yesterday, following the documentation steps at 3.1.3 - with no luck:
http://www.ribica.si/gallery - english works
http://www.ribica.si/gallery/?lang=slovenian - blank page

That's why I installed new gallery under new folder with new database (without any modification, with default theme) today:
http://www.ribica.si/galerija/?lang=english - it works
http://www.ribica.si/galerija/?lang=slovenian - or any other language - blank page
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: blank page
« Reply #10 on: May 21, 2008, 05:49:54 pm »

Make sure that your FTP app is set up properly (FTP mode!).
Did you review the settings of your FTP app? What are they?
Logged

damjan

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: blank page
« Reply #11 on: May 23, 2008, 08:40:08 am »

I use CuteFTP - Auto-detect transfer type, for php files ASCII transfer is defined.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: blank page
« Reply #12 on: May 23, 2008, 08:43:27 am »

Try something different and check if the situation improves then.
Logged

damjan

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: blank page
« Reply #13 on: May 23, 2008, 10:56:00 am »

I uploaded php files again using Unix/PASV/ASCII - nothing...
I deleted /galerija and install it again using Fantastico - still the same problem. Maybe there is some setting on server causing that problem? But I have another gallery on same server and it works: jazbec.si/gallery
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: blank page
« Reply #14 on: May 23, 2008, 01:03:20 pm »

install it again using Fantastico
Don't use Fantastico - it sucks and goes unsupported. The only supported install method is the one we describe in our docs.
Logged

damjan

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: blank page
« Reply #15 on: May 26, 2008, 10:33:26 pm »

I was thinking what did I change on server in last few weeks: I added addon domain. So I removed that domain, I uploaded languages again and they start to work...
I put addon domain back and now everything works.???
But I will not complain...
Logged
Pages: [1]   Go Up
 

Page created in 0.074 seconds with 22 queries.