Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: Search problem  (Read 2847 times)

0 Members and 1 Guest are viewing this topic.

Kayleigh

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
[Solved]: Search problem
« on: May 03, 2008, 10:39:14 pm »

Hi,

I hope somebody can help me. I'm creating a gallery and all is working fine, except the search.

I search the forums and didn't find the solution to the problem, tryied google and didn't have an answer.
I did read in the forums that Coppermine isn't Case Sensitive by default, but I didn't change anything and in my gallery it is case sensitive. My gallery is cpg1.4.18, it's on Linux server and the collation in my database is utf8_unicode_ci. In the same host I have a forum, and the search is case insensitive.

I'm trying to find a solution for this, anyone knows how to solve? please


Thks
« Last Edit: May 06, 2008, 06:39:30 pm by Joachim Müller »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Search problem
« Reply #1 on: May 03, 2008, 11:09:28 pm »

Let's see a link to your gallery for a start.
Logged

Kayleigh

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Search problem
« Reply #2 on: May 03, 2008, 11:16:57 pm »

Here it is.

Thks
Logged

Nibbler

  • Guest
Re: Search problem
« Reply #3 on: May 03, 2008, 11:22:56 pm »

Are the pictures table and the individual fields in the pictures table utf8_unicode_ci also?
Logged

Kayleigh

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Search problem
« Reply #4 on: May 03, 2008, 11:39:00 pm »

That tables is, but the fiels are in utf8_bin, I did tryied to change utf8_unicode_ci but I got this error:


Code: [Select]
ALTER TABLE `cpg14x_pictures` CHANGE `caption` `caption` TEXT CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL

Mensagens do MySQL : 

#1283 - Column 'caption' cannot be part of FULLTEXT index
Logged

Kayleigh

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Search problem
« Reply #5 on: May 04, 2008, 12:19:22 am »

I tryed again to change the collation on the fields and now all are utf8_unicode_ci and now I can do the search for "sempa" or "Sempa" and got results. Thanks for the tip  :)
But in my language we have words like: bicafé, café, identificação... and if I write cafe, bicafe or identificacao I have no results. That is not related to the collation?
Logged

Nibbler

  • Guest
Re: Search problem
« Reply #6 on: May 04, 2008, 12:53:31 am »

I don't think so. I don't know about Portuguese, but in many languages the diacritics should not be ignored in a search. For example, in German schön is not the same as schon.
Logged

Kayleigh

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Search problem
« Reply #7 on: May 04, 2008, 06:29:51 pm »

In portuguese, we do have words like that. But some people tend to forget that. There is no way to make the search report words with an "é" and a "e", for example?

Thks
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Search problem
« Reply #8 on: May 06, 2008, 07:45:55 am »

Afaik: no.
Logged

Kayleigh

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Search problem
« Reply #9 on: May 06, 2008, 02:07:02 pm »

ok. Thank you very much for your help  :)
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 20 queries.