Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: A couple of cosmetic problems after upgrading  (Read 4473 times)

0 Members and 1 Guest are viewing this topic.

aldog

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 29
[Solved]: A couple of cosmetic problems after upgrading
« on: April 25, 2008, 08:17:01 pm »

I just upgraded to 1.4.18 (a little slow, I know). I found this thread that stramm replied to, but I didn't want to get yelled at for bumping it

Save your modifications (compare an 1.4.10 modpack CPG with your 1.4.10 moadpack CPG using a diff viewer like winmerge) so you can redo everything on a later stage.

If you've modified your themes make sure neither the orig CPG nor the modpack overwrite them
Upgrade CPG http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upgrade

Upgrade the modpack (upload and replace the existing files, run update.php)

Finally reapply your mods



1. I was just wondering what files I should be comparing with winmerge in order to get my gallery looking like it did before? I've went through the files that I can think would be affected but not everything is fixed yet.
This is my gallery: http://ad6storieshigh.com/gallery/
if you scroll down you'll notice the right border isn't lining up with the right side, I know this is because my logo is a good 150+ px wider than the original one, but I had this same problem when I first applied the modpack+oranje and managed to fix it then, I just can't seem to do it again.
the only file that i've checked with winmerge that's needed any changes was template.html in the orange theme folder.


2. also, slightly off topic, what file stores the information for thumbnail sizes? specifically category thumbnail sizes. in the middle of upgrading I saw what my thumbnails would look like without my changes and I preferred it (vertical pictures stayed vertical) I used to think I wanted them all to be square, but seeing that makes me change my mind...that might be a stupid question, I'm sorry if it is.

thanks for the great mod stramm
« Last Edit: April 27, 2008, 02:45:17 pm by Stramm »
Logged

aldog

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 29
Re: A couple of cosmetic problems after upgrading
« Reply #1 on: April 25, 2008, 08:22:31 pm »

I apologize for this bump, I knew there was 1 more question I had, but I can't seem to see an edit button.

I was wondering if there's a way to put an image behind the menu on the right of oranje.

"
Home
Register
Login

etc..."

just something to make it stand out from the image part of the page.
I will search for this, so if noone wants to answer that's fine. I just wanted to put this in here really quick so if I search for a couple hours and then ask, you guys don't think I'm just bumping.
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: A couple of cosmetic problems after upgrading
« Reply #2 on: April 26, 2008, 06:36:37 pm »

If you have modified your coppermine and you want to keep this changes after the upgrade, then you should find out what has been done (if you do not know that already). For that you compare an unmodified coppermine version with yours. If you upgrade from 1.4.12, then 1.4.12 with your old coppermine. The differences are your mods. These you can apply again after upgrading to 1.4.18.

The thumb size is stored in the database (pfx_config). If you already run the admin tools and changed thumb size, then the database entry doesn't matter anymore as the old thumbs have been overwritten with the newly created ones. You'll need to change thumb size to your preferences and run the admin tools again.

Please only one question per thread.


aldog

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 29
Re: A couple of cosmetic problems after upgrading
« Reply #3 on: April 27, 2008, 12:23:42 am »

sorry about asking multiple questions, I was taking a guess that you would prefer that instead of multiple threads.

Thank you for the information on the thumbnails, I now have it back to what I like.

For comparing old to new, what files should I be looking at? I have a backup of my gallery, I've went through what I thought were the files that would affect the thing with the borders being off, but it's still having the problem. I was running 1.4.13 if that makes a difference. Thank you very much for your help stramm
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: A couple of cosmetic problems after upgrading
« Reply #4 on: April 27, 2008, 09:10:43 am »

all files and start with themes folder.
However I'd start with config... first of all reduce the number of thnumbs in a row as I think the main table needs an exact width. If some content is to broad, it'll move the navigation to the right. Same for the header image.

aldog

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 29
Re: A couple of cosmetic problems after upgrading
« Reply #5 on: April 27, 2008, 11:17:01 am »

Okay I finally remembered what I did the first time to fix the issue with the border being off center. the bg.gif image inside your image folders is normally 764x1, I had to change it to fit my theme after adding my bigger header. So my bg.gif file is now 940x1.

There are still some little differences that I'm noticing but going through the config is helping, I'm going to go back through the themes folder again with winmerge.
Also trying different settings for the thumb rows until I get it how it was.

Thank you stramm for your help, you can mark this solved.
Logged
Pages: [1]   Go Up
 

Page created in 0.043 seconds with 20 queries.