Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Uploading Trouble!  (Read 2489 times)

0 Members and 1 Guest are viewing this topic.

sianii

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Uploading Trouble!
« on: April 26, 2008, 09:22:01 pm »

I can't upload images to my gallery. I've tried single uploads &  batch uploads, but nothing.
It recognises that the files are there and I can access the files by typing in the URL but when I try to upload it just
comes up as a little box with a red X instead of a preview of the image.
And i get this message:

"The previous file could not be placed.

You have successfully placed all the files."

All permissions are set to 777.

I've tried both:
http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_trouble
http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_support

I did everything the first link said. And now i get this message:

The file 'albums/userpics/633442845600000000~1.jpg' can't be inserted in the album

Error executing ImageMagick - Return value: 139


Cmd line :
/usr/bin/convert -quality 80 -antialias -geometry 100x100 'albums/userpics/633442845600000000~1.jpg' 'albums/userpics/thumb_633442845600000000~1.jpg'



The convert program said:
File: /home/sianii/public_html/knoxville/gallery/db_input.php - Line: 402




The second link did'nt really help.


My gallery website is  http://www.knoxville.violet-rose.org/gallery

My tester account is :
Username :  tester1
Password :  tester

Thanks
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Uploading Trouble!
« Reply #1 on: April 27, 2008, 07:20:58 pm »

Don't use cpg1.4.16 (which is outdated and contains a serious security flaw) if you're starting from scratch - use cpg1.4.18 (currently the most recent stable release) to start a new gallery. You appear to have used an auto-installer, which probably made you use ImageMagick as method for resizing images. If you have issues with ImageMagick, use GD2 instead. Go to coppermine's config and change the corresponding section.
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.