Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: No mods working  (Read 2431 times)

0 Members and 1 Guest are viewing this topic.

Halfhidden

  • Guest
No mods working
« on: April 17, 2008, 01:12:17 am »

I've noticed that since the upgrade to 1.4.17 none of my previously working mods are any longer. Now I know that when an upgrade is performed then mods need to be replaced.... and I know that's why plugins are preferred because of this, but in the case of these mods... no plugin's exist.
At first I thought I had incorrectly upgraded or perhaps used some of the old php files that had been replaced in the upgrade. But I've noticed that some important mods are no longer.
I no longer have watermarks, moderators and picture of the day is broken. I have tried to re create these mods but non work and yes it could well be me... Missing something.... but I have tried these mods over and over again.

Sorry this isn't a specific topic (well it is... it's about mods) but not necessarily about one subject, and for that I apologise, however it has to do with one upgrade!
Regards,
Steff
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: No mods working
« Reply #1 on: April 17, 2008, 07:40:33 am »

Usually, mods work between maintenance releases. The exception to this rule is when something in the core code is pateched that the mods relied upon. There can be no general recommendation, so you'll need to look into this on a per-mod base.
Logged

Halfhidden

  • Guest
Re: No mods working
« Reply #2 on: April 18, 2008, 12:19:15 am »

 I'm downgrading to the previous version. All of my mods have stopped working and some of my plugins have become temperamental. Picture of the week, for instance will only select pictures from particular users. I understand that you will not support me during this downgrade, but I have to consider the gallery's dysfunctional position and upgrade verses the possible security risk.
regards,
Steff
Please close this ticket

PS
I also noticed that when running the version comparison it says that The folder &quot;<i>plugins</i>&quot; is writable. This is an unnecessary risk, Coppermine only needs read/execute access.
Doesn't that stop admins from uploading plug ins if it's changes from writeable? I had to change mine to 555 before version comparison stopped nagging me!
« Last Edit: April 18, 2008, 01:18:58 am by Halfhidden »
Logged

Halfhidden

  • Guest
Re: No mods working
« Reply #3 on: April 18, 2008, 01:27:23 am »

In fact... I've noticed that a lot of directories needed for mods and plugins had been marked in the version checker as needing to be completely 555 to stop the nag or it will continue to tell you that Coppermine is at risk. No wonder I cannot replace mods or the plug ins if version checker is telling me to lock them down. That explains why when I uploaded a zipped plug in within the plug in manager nothing happened... the directory is no longer writeable. The lang folder is also marked as make 555 and therefore any changes uploaded by FTP will be dropped! or changes even within the Coppermine config panel.

 ??? ??? ??? ??? ???

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: No mods working
« Reply #4 on: April 18, 2008, 08:24:17 am »

That's nonsense - the language folder doesn't need to be writable. The plugin folder only needs to be writable if you want to install a plugin and use the plugin manager interface to upload and unzip it.
I told you in your other thread that downgrading is not an option at all. In fact, it's utter nonsense as well. I rather guess that you have made a mistake performing the upgrade. That changes between versions have not been that significant, it's quite impossible that all of your mods and plugins broke; it must be something you did.
Your posting is encouraging others to downgrade and makes them feel that this is a solution if they encounter a problem, but the opposite is true. Downgrading is wrong. You're drawing the false conclusions.
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 20 queries.