Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [cpg1.4.x]: Default color in pm messages doesn't work!  (Read 4979 times)

0 Members and 1 Guest are viewing this topic.

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
[cpg1.4.x]: Default color in pm messages doesn't work!
« on: April 18, 2008, 04:36:59 am »

Every time I send a pm mesage leaving the Default color (black) I got a non color mesage, in white indeed.

What is going on?

(sorry my english)

My web: www.elgranalbum.com (i'm alredy testing colors, in case you see an ugly combination)

Test user created...

user: one
pass: 123


user2: two
pass: 123

can anybody help?
« Last Edit: April 21, 2008, 05:16:59 pm by Stramm »
Logged
Read Docs and Search the Forum before posting. - Soporte en español
--*--
Fabricio Ferrero's Website

Catching up! :)

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Default color in pm messages doesn't work!
« Reply #1 on: April 18, 2008, 08:01:32 am »

Probably a style definition renders the font white... the default color isn't set inline but by css for p. Only the set colors are definied inside a span tag. Check that with a tool like the 'developer toolbar' or 'firebug' (my fav)

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Re: Default color in pm messages doesn't work!
« Reply #2 on: April 19, 2008, 05:39:19 pm »

Code: [Select]
I think the problem it's not that. I checked and tha css of that is alt1 and I got defined in color 000000 so, it's has to be black. I test some things. I changed the default color at the second line and I put blue in the first line and that color doesn't work right now, so I know that it's a problem whit the color thats ubicated in the first line (of colors in the pms_send.php).

Indeed, dreamweaver (I only use it on code view not design) the first line it's not in the same colors than the others, so, there must be a coding mistake.

I post my pms_send.php, please, try to find the mistake.

[code  <option style="color:#000000; background-color: #FAFAFA" value="black">Default</option>
 <option style="color:darkred; background-color: #FAFAFA" value="darkred" class="genmed">Dark red</option>
 <option style="color:red; background-color: #FAFAFA" value="red" class="genmed">Red</option>
 <option style="color:orange; background-color: #FAFAFA" value="orange" class="genmed">Orange</option>
 <option style="color:brown; background-color: #FAFAFA" value="brown" class="genmed">Brown</option>
 <option style="color:yellow; background-color: #FAFAFA" value="yellow" class="genmed">Yellow</option>
 <option style="color:green; background-color: #FAFAFA" value="green" class="genmed">Green</option>
 <option style="color:olive; background-color: #FAFAFA" value="olive" class="genmed">Olive</option>
 <option style="color:cyan; background-color: #FAFAFA" value="cyan" class="genmed">Cyan</option>
 <option style="color:blue; background-color: #FAFAFA" value="blue" class="genmed">Blue</option>
 <option style="color:darkblue; background-color: #FAFAFA" value="darkblue" class="genmed">Dark Blue</option>
 <option style="color:indigo; background-color: #FAFAFA" value="indigo" class="genmed">Indigo</option>
 <option style="color:violet; background-color: #FAFAFA" value="violet" class="genmed">Violet</option>
 <option style="color:white; background-color: #FAFAFA" value="white" class="genmed">White</option>
 <option style="color:black; background-color: #FAFAFA" value="black" class="genmed">Black</option>
</select> &nbsp;</font><br />


Thanks in advance...

PS: I already translate your modpack to spanish in another thread and you don't include as an option. why?
Logged
Read Docs and Search the Forum before posting. - Soporte en español
--*--
Fabricio Ferrero's Website

Catching up! :)

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Re: Default color in pm messages doesn't work!
« Reply #3 on: April 19, 2008, 05:41:06 pm »

Sorry, I put all my mesagge as a code...

I wrote: "I think the problem it's not that. I checked and tha css of that is alt1 and I got defined in color 000000 so, it's has to be black. I test some things. I changed the default color at the second line and I put blue in the first line and that color doesn't work right now, so I know that it's a problem whit the color thats ubicated in the first line (of colors in the pms_send.php).

Indeed, dreamweaver (I only use it on code view not design) the first line it's not in the same colors than the others, so, there must be a coding mistake.

I post my pms_send.php, please, try to find the mistake."

and then the code...
Logged
Read Docs and Search the Forum before posting. - Soporte en español
--*--
Fabricio Ferrero's Website

Catching up! :)

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Default color in pm messages doesn't work!
« Reply #4 on: April 19, 2008, 06:17:24 pm »

Code: [Select]
default [color=black]black[/color]would render as
Code: [Select]
<p>default <span style="color: black;">black</span></p>
So you see what happens... if you leave the default color no inline style's getting defined. If you chose a color (including black and white), it's added as inline style to a span tag. There's a reason for that. Some themes may render a black background, then usually the defaulot color is not black but gray or white or whatever. Would the deafult render black you'd have black on black... somehow silly.

Again, to be able to find the cause of such css problems you've tools like the above mentioned. If you think there's another cause for your issue, then search through the code and tell me where you'd make changes.

Please post the link to your contribution. I probably have overlooked it the last time I went through the forum and picked up the lang files.

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Re: Default color in pm messages doesn't work!
« Reply #5 on: April 21, 2008, 04:19:14 pm »

Now it works!!! Firebug for Firefox, NICE TOOL!

Well, Firebug allows me to see quickly where is getting the color from. So, I only change that and done.

Go to line 222, style.css

Code: [Select]
p {
        color: #FFFFFF;
        font-family: Verdana, Helvetica, sans-serif;
        font-size: 100%;
        margin: 2px 0px;
}

Change #FFFFFF to #000000 (or the color you want) and, that’s it.

Well, thanks again.

PS: As I promised I attach the Spanish file, so, now it's available for everyone on my language. (several threads ask for it)
Don't hesitate to e-mail me when you come up whit a new feature or modification to translate it. I mean it. (e-mail on Spanish file)
Logged
Read Docs and Search the Forum before posting. - Soporte en español
--*--
Fabricio Ferrero's Website

Catching up! :)

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: [cpg1.4.x]: Default color in pm messages doesn't work!
« Reply #6 on: April 21, 2008, 05:17:30 pm »

Thanks for your contribution. I'll add it to the next modpack version.
Pages: [1]   Go Up
 

Page created in 0.037 seconds with 19 queries.