Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: mySQL error: Got error 134 from storage engine  (Read 11032 times)

0 Members and 1 Guest are viewing this topic.

marcus123

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
[Solved]: mySQL error: Got error 134 from storage engine
« on: April 14, 2008, 10:09:56 am »

Hi there,

Our client has been using your gallery for a couple of months with no problems, but now when they try to view gallery (www.domain/gallery/index.php) it shows fatal error.

We saw posting and have activated debug mode, and it now displays mySQL error: Got error 134 from storage engine

There is more text displayed in the error message, but you request not to put debug output in a posting??

Gallery is version 1.4.1

Can someone help please?

Many thanks,
Marcus
« Last Edit: April 14, 2008, 04:46:04 pm by Nibbler »
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: mySQL error: Got error 134 from storage engine
« Reply #1 on: April 14, 2008, 10:13:56 am »

Your cpg is outdated. First you need to upgrade. Wait and watch the frontpage of this site as 1.4.18 is about to be released and is the latest stable version. or upgrade now to 1.4.17 and then later to 1.4.18

Houdoe
Hein
Logged

marcus123

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: mySQL error: Got error 134 from storage engine
« Reply #2 on: April 14, 2008, 11:33:57 am »

Hi Hein,

Okay, have downloaded 1.4.17. Where do i find a simple set of instructions to perform an upgrade?

I want to make sure we do this right, as the client's gallery is a key part of their site, and they have several months of active/live images etc...

Thanks,
Marcus
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: mySQL error: Got error 134 from storage engine
« Reply #3 on: April 14, 2008, 11:42:52 am »

http://coppermine-gallery.net/demo/cpg14x/docs/index.htm

Open the documentation , all the instructions you need to perform a upgrade are in there.

Houdoe
Hein
Logged

marcus123

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: mySQL error: Got error 134 from storage engine
« Reply #4 on: April 14, 2008, 01:09:18 pm »

Hi Hein,

Done upgrade to 1.4.17, error message still appearing as before. Do you want me to post full error message?

Marcus

Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Logged

marcus123

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: mySQL error: Got error 134 from storage engine
« Reply #6 on: April 14, 2008, 03:34:56 pm »

Hi Hein,

Yes, I searched before posting, on error 134, and the other part of error text, but forum search comes up with no entries.

The full error message is:

While executing query "SELECT session_id FROM `databasename`.cpg140_sessions WHERE session_id=MD5('4e2108e892f31ce1f435fcb1b3196031e428fd4f5b017e504d6e74f430ca9589')" on Resource id #5

mySQL error: Got error 134 from storage engine


What could be causing this?

Marcus
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: mySQL error: Got error 134 from storage engine
« Reply #7 on: April 14, 2008, 03:39:49 pm »

It's a problem with your database. Run a repair using phpmyadmin or contact your host.
Logged

marcus123

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: mySQL error: Got error 134 from storage engine
« Reply #8 on: April 14, 2008, 04:22:01 pm »

Hi Hein,

Contacted host and they did repair, and now working fine again.

Many thanks for your help.

Marcus
Logged
Pages: [1]   Go Up
 

Page created in 0.044 seconds with 20 queries.