Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Ecard sender can fill in random email adres  (Read 3897 times)

0 Members and 1 Guest are viewing this topic.

Flappo

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Ecard sender can fill in random email adres
« on: April 06, 2004, 03:09:00 pm »

When you send an ecard, the user can fill in every email adres what he wants at the sender. So he can also use the email adres of someone else (thats what happened at mine), so is it possible to get the email adres from the user table from the database for the user who is logged on at that moment ?!?

tnx

Flappo
« Last Edit: January 05, 2005, 10:08:41 pm by TranzNDance »
Logged

Nibbler

  • Guest
Ecard sender can fill in random email adres
« Reply #1 on: April 06, 2004, 03:16:31 pm »

Yup,

If you are using cpg standalone mode, then see this thread.

If you have some kind of integration, read this one as well.
Logged

Flappo

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Ecard sender can fill in random email adres
« Reply #2 on: April 06, 2004, 03:28:24 pm »

tnx fot the quick reply..

and sorry that i posted a new topic, but i could not find the other one
Logged

TerryG

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Posts: 45
Re: Ecard sender can fill in random email adres
« Reply #3 on: July 30, 2004, 09:34:32 pm »


Cool!  This was exactly what I was looking for!  I did, however, change the sender's email to be READONLY instead of hidden, so that it is shown, but not user modifiable.

Cheers!

Terry
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Re: Ecard sender can fill in random email adres
« Reply #4 on: July 31, 2004, 09:57:19 am »

Terry,

if you needed this, it means you are still using a version 1.2x or earlier.
This is included in 1.3.1, and you are advised to upgrade.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here
Pages: [1]   Go Up
 

Page created in 0.036 seconds with 21 queries.