Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: intergration error with SMF 2.0 Beta 3 Public  (Read 5852 times)

0 Members and 1 Guest are viewing this topic.

lyssa

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
intergration error with SMF 2.0 Beta 3 Public
« on: March 25, 2008, 05:30:11 pm »

I followed the directions.. i have a link on my SMF Forum.. that goes to the gallery, but i'm having problems with the integration on the gallery side.

I have the following issue when trying to bridge coppermine and SMF:
Critical error
There was an error while processing a database query

Coppermine install: http://charmed.simplyenraged.com/gallery/
Forum install: http://charmed.simplyenraged.com/RPG-Board/
Coppermine version: cpg1.4.16
Forum version: SMF 2.0 Beta 3 Public
Test user account: test / blah

BridgeManager settings:
Forum URL:    http://charmed.simplyenraged.com/RPG-Board
Relative path to your BBS's config file:    ../RPG-Board/
Use post-based groups?:    0
Logged

Nibbler

  • Guest
Re: intergration error with SMF 2.0 Beta 3 Public
« Reply #1 on: March 25, 2008, 05:31:41 pm »

Enable debug mode so you can see the database error message.

http://coppermine-gallery.net/tutorial/debug_mode.php
Logged

lyssa

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: intergration error with SMF 2.0 Beta 3 Public
« Reply #2 on: March 25, 2008, 08:19:47 pm »

Alright..
The error states as follows:

Code: [Select]
Critical error

There was an error while processing a database query.

While executing query "SELECT * FROM charmedgallery_banned WHERE (ip_addr='71.38.51.225' OR ip_addr='71.38.51.225' OR user_id=) AND brute_force=0" on 0 mySQL error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND brute_force=0' at line 1


File: E:\inetpub\vhosts\simplyenraged.com\subdomains\charmed\httpdocs\gallery\include\functions.inc.php - Line: 249

this is the debug info

Code: [Select]
USER:
------------------
Array
(
    [ID] => 27486a70feadec88cca2f17d179df890
    [am] => 1
    [lang] => english
)

==========================
USER DATA:
------------------
Array
(
    [user_id] =>
    [user_name] =>
    [groups] => Array
        (
            [0] => 2
        )

    [disk_max] => 1024
    [disk_min] => 1024
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 0
    [has_admin_access] => 0
    [pub_upl_need_approval] => 1
    [priv_upl_need_approval] => 0
    [group_name] => Registered
    [upload_form_config] => 3
    [group_quota] => 1024
    [can_see_all_albums] => 0
    [group_id] => 2
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM charmedgallery_filetypes; (0s)
    [1] => select * from charmedgallery_plugins order by priority asc; (0s)
    [2] => SELECT * FROM charmedgallery_bridge (0s)
    [3] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM charmedgallery_usergroups WHERE group_id in (2) (0s)
    [4] => SELECT group_name FROM  charmedgallery_usergroups WHERE group_id= 2 (0s)
    [5] => DELETE FROM charmedgallery_banned WHERE expiry < '2008-03-25 19:09:32' (0.001s)
    [6] => SELECT * FROM charmedgallery_banned WHERE (ip_addr='71.38.51.225' OR ip_addr='71.38.51.225' OR user_id=) AND brute_force=0 (0s)
)

==========================
GET :
------------------
Array
(
    [referer] => groupmgr.php
)

==========================
POST :
------------------
Array
(
)

==========================
Page generated in 0.292 seconds - 7 queries in 0.001 seconds - Album set : ; Meta set: ;

Can anyone help??
Logged

Nibbler

  • Guest
Re: intergration error with SMF 2.0 Beta 3 Public
« Reply #3 on: March 25, 2008, 11:26:57 pm »

What bridge are you using? the SMF2 from the Coppermine package?
Logged

lyssa

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: intergration error with SMF 2.0 Beta 3 Public
« Reply #4 on: March 26, 2008, 12:29:28 am »

I'm assuming so..However it doesn't ask me .. when i go through it.. So i might be using the wrong one :(
Logged

lyssa

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: intergration error with SMF 2.0 Beta 3 Public
« Reply #5 on: March 26, 2008, 12:51:03 am »

I got it to work.

Thank you.
Logged

Nibbler

  • Guest
Re: intergration error with SMF 2.0 Beta 3 Public
« Reply #6 on: March 26, 2008, 01:00:48 am »

Please post what you did for the benefit of others.
Logged

briar21

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: intergration error with SMF 2.0 Beta 3 Public
« Reply #7 on: March 30, 2008, 07:06:07 pm »

This is exactly the same problem (with the debug error phrased exactly the same) I had been having, and was rather disappointed when the creator of this thread didn't reply on what they did to correct the problem.

For others that may come after, the solution for me was rather embarrassing. I had indeed used the wrong version of the SMF bridge. Using the correct version solved it immediately.
Logged

sherpa

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: intergration error with SMF 2.0 Beta 3 Public
« Reply #8 on: April 12, 2008, 09:20:20 am »

Faced same problem after upgrading to SMF 2.0 Beta 3 Public from 1.1.4
include\functions.inc.php - Line: 249

Reason why?
I forgot to disable bridge between forum and gallery

How did I solved the problem

Go to phpMyAdmin >> click on cpg14x_bridge (you can find it at left side bare)

[Edit GauGau] Replaced hotlinked image with attachment bridgeet3.jpg [/Edit]

Click on Browse>> (you can find it at right top)

Crosser down and change the correct value of

short_name = smf20
db_database_name = database name of your forum
db_hostname = normally localhost
db_username = database username of your forum
db_password = database password of your forum

To change this value click on [Edit GauGau] Replaced hotlinked image with attachment beditru3.png [/Edit]  icon

[Edit GauGau] Replaced hotlinked image with attachment epan0.jpg [/Edit]

Hope this will helps
« Last Edit: April 12, 2008, 11:07:46 am by Joachim Müller »
Logged
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 20 queries.