Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: '0 uploads were successful' please help  (Read 8652 times)

0 Members and 1 Guest are viewing this topic.

l33Ryan

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
'0 uploads were successful' please help
« on: April 11, 2008, 03:30:43 pm »

Please can someone help me?

Today i went to upload pictures and i get the message '0 uploads were successful'. I have read the 'Trouble-shooting the upload process.' topic but didn't see anything there to help me. All my permissions are set to 777. I have never had this issue before so i don't really understand what to do and i have searched.

www.allriseforlee.net/gallery

Code: [Select]
USER:
------------------
Array
(
    [ID] => a42077ac51f32e5f7ab38bbb220aaf7b
    [am] => 1
    [lang] => english
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => *****
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 1
    [ufc_min] => 1
    [custom_user_upload] => 0
    [num_file_upload] => 10
    [num_URI_upload] => 0
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 1
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg1411_filetypes; (0s)
    [1] => select * from cpg1411_plugins order by priority asc; (0s)
    [2] => delete from `leeryan_copp`.cpg1411_sessions where time<1207916895 and remember=0; (0s)
    [3] => delete from `leeryan_copp`.cpg1411_sessions where time<1206710895; (0s)
    [4] => select user_id from `leeryan_copp`.cpg1411_sessions where session_id=md5("36e73ae45dea9295d58bff12e680ae70a0c029b6af63fa5e1218ebb931568242"); (0s)
    [5] => select user_id as id, user_password as password from `leeryan_copp`.cpg1411_users where user_id=1 (0s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.avatar_url AS avatar_url, u.enable_admin_email AS notify, u.auto_subscribe_post AS auto_subscribe_post, u.auto_subscribe_comment AS auto_subscribe_comment, u.user_group+100 AS group_id FROM `leeryan_copp`.cpg1411_users AS u INNER JOIN `leeryan_copp`.cpg1411_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
    [7] => SELECT user_group_list FROM `leeryan_copp`.cpg1411_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg1411_usergroups WHERE group_id in (1) (0s)
    [9] => SELECT group_name FROM  cpg1411_usergroups WHERE group_id= 1 (0s)
    [10] => update `leeryan_copp`.cpg1411_sessions set time='1207920495' where session_id=md5('36e73ae45dea9295d58bff12e680ae70a0c029b6af63fa5e1218ebb931568242'); (0s)
    [11] => SELECT user_favpics FROM cpg1411_favpics WHERE user_id = 1 (0s)
    [12] => SELECT count(*) FROM  cpg1411_pms WHERE owner=1 (0s)
    [13] => SELECT count(*) FROM  cpg1411_pms WHERE owner=1 AND showed='0' (0s)
    [14] => SELECT count(*) FROM  cpg1411_buddy WHERE user_id=1 (0s)
    [15] => SELECT count(*) FROM  cpg1411_buddy_req WHERE buddy_to=1 (0s)
    [16] => DELETE FROM cpg1411_banned WHERE expiry < '2008-04-11 13:28:15' (0s)
    [17] => SELECT * FROM cpg1411_banned WHERE (ip_addr='81.169.145.28' OR ip_addr='172.188.169.248' OR user_id=1) AND brute_force=0 (0s)
    [18] => SELECT aid, title FROM cpg1411_albums WHERE category < 10000 ORDER BY title (0.002s)
    [19] => SELECT aid, title FROM cpg1411_albums WHERE category='10001' ORDER BY title (0s)
    [20] => SELECT COUNT(*) FROM cpg1411_pictures WHERE approved = 'NO' (0s)
)

==========================
GET :
------------------
Array
(
)

==========================
POST :
------------------
Array
(
    [control] => phase_1
)

==========================
VERSION INFO :
------------------
PHP version: 5.2.5 - OK
------------------
mySQL version: 4.1.22-standard
------------------
Coppermine version: 1.4.12 modpack v2(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.34 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support:
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 4.1.22
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.1.2
Linked Version 1.2.1.2
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | Off | Off
include_path | .:/usr/lib/php:/usr/local/lib/php | .:/usr/lib/php:/usr/local/lib/php
open_basedir | /home/leeryan:/usr/lib/php:/usr/local/lib/php:/tmp | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /usr/sbin/sendmail -t -i | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 16M | 16M
post_max_size | 32M | 32M
==========================
Page generated in 0.023 seconds - 21 queries in 0.002 seconds - Album set : ; Meta set: ;
Logged

l33Ryan

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: '0 uploads were successful' please help
« Reply #2 on: April 11, 2008, 06:20:38 pm »

I have been to both those links and can't find the answer to my problem. Am i just completely missing it? Also, i have updated to the newer version and no joy, still will not work. I have also created a test user...

Login: testuser Password: testuser

and set to allow uploads but i still get 'Sorry there is no album where you are allowed to upload files'.

Sorry for being a pain but i really want to get this sorted asap. Gallery worked fine last week.
Logged

Nibbler

  • Guest
Re: '0 uploads were successful' please help
« Reply #3 on: April 11, 2008, 06:34:35 pm »

Error message is:

Code: [Select]
No file was uploaded !

If you have really selected a file to upload, check that the server allows file uploads...

Check that file_uploads is enabled in your phpinfo.php (http://www.leeryan.fan-sites.org/gallery/phpinfo.php). If it is you'll need to ask your host for support to find out why uploads are not working.
Logged

l33Ryan

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: '0 uploads were successful' please help
« Reply #4 on: April 11, 2008, 07:45:05 pm »

It says...

Directive            Local Value            Master Value
file_uploads            Off                       Off

How do i enable file uploading if the above means it is disabled?
Logged

Nibbler

  • Guest
Re: '0 uploads were successful' please help
« Reply #5 on: April 11, 2008, 08:12:26 pm »

It means your host disabled file uploads. Might like to talk to them about that.
Logged

l33Ryan

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: '0 uploads were successful' please help
« Reply #6 on: April 11, 2008, 09:44:12 pm »

ok thank you for your help
Logged

bigcatch

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: '0 uploads were successful' please help
« Reply #7 on: April 23, 2008, 07:52:21 am »

Hi I am receiving this error also and I have checked my PHP settings and the setting mentioned here is correct.

Any other ideas.

Cheers

Error message is:

Code: [Select]
No file was uploaded !

If you have really selected a file to upload, check that the server allows file uploads...

Check that file_uploads is enabled in your phpinfo.php (http://www.leeryan.fan-sites.org/gallery/phpinfo.php). If it is you'll need to ask your host for support to find out why uploads are not working.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: '0 uploads were successful' please help
« Reply #8 on: April 23, 2008, 08:09:15 am »

File uploads are disabled in php.ini or there is a permissions issue. Check if there's a problem with HTTP uploads on your server - this feature may have been disabled or improperly configured. In phpinfo(), check that "file_uploads" is ON, "upload_max_filesize" is something like 2M and "upload_tmp_dir" is a valid directory! Make sure to review your file/folder permissions as well. Start a thread of your own instead of trying to hijack this thread, doing exactly as suggested in the docs sections that related to uploading.
Logged

bigcatch

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: '0 uploads were successful' please help
« Reply #9 on: April 23, 2008, 08:52:00 am »

File uploads are disabled in php.ini or there is a permissions issue. Check if there's a problem with HTTP uploads on your server - this feature may have been disabled or improperly configured. In phpinfo(), check that "file_uploads" is ON, "upload_max_filesize" is something like 2M and "upload_tmp_dir" is a valid directory! Make sure to review your file/folder permissions as well. Start a thread of your own instead of trying to hijack this thread, doing exactly as suggested in the docs sections that related to uploading.

thank you for you info, I will look into these issues.  :)  On a side note I am a little confussed about your comment that I am hijacking this thread, if I started another wouldn't I then get told that there was already another thread on this topic.
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: '0 uploads were successful' please help
« Reply #10 on: April 23, 2008, 10:15:27 am »

The answer to your last question is simply "No". It would be another thread on the same subject at first glance. But it is always better to start your own thread because it does happen that the problem seems the same but has a different solution etc etc..
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: '0 uploads were successful' please help
« Reply #11 on: April 23, 2008, 10:27:04 am »

To add to what Hein said: "0 uploads were successful" is a generic error message that will appear for different reasons. So your issue might appear to be identical, but it is not. That's why you should have started a thread of your own. The corresponding section in the docs say so as well.
Logged
Pages: [1]   Go Up
 

Page created in 0.031 seconds with 19 queries.