Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Photo Shop 1.5 Plugin fatal error  (Read 7926 times)

0 Members and 1 Guest are viewing this topic.

erika_conn

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 91
Photo Shop 1.5 Plugin fatal error
« on: April 10, 2008, 07:17:42 pm »

http://www.ceconn.com/photo_gallery

Coppermine 1.4.13 WP theme Andreas09 http://ceconn.com/photo_gallery

Regarding Plugin-in Photo shop v1.5.  Not to be confused with Adobe Photoshop.

I thought it so cool that I could sell my pictures.  The plug-in doesn't work I get the following error message when I try to install.

Fatal error: copperad_install(): Failed opening required 'plugins/copper_ad/include/init.inc.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/cecon46/public_html/photo_gallery/plugins/copper_adv_124/codebase.php on line 36

Any ideas?
Logged

Nibbler

  • Guest
Re: Photo Shop 1.5 Plugin fatal error
« Reply #1 on: April 10, 2008, 07:31:46 pm »

Did you rename the folder? It needs to be named 'copper_ad' not 'copper_adv_124'.
Logged

erika_conn

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 91
Re: Photo Shop 1.5 Plugin fatal error
« Reply #2 on: April 22, 2008, 12:26:31 pm »

I did as you said and renamed the plugin but then i got a fatal error so I had to change it back
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Photo Shop 1.5 Plugin fatal error
« Reply #3 on: April 22, 2008, 12:38:08 pm »

Disable/uninstall the plugin, then rename it as Nibbler suggested, the install it (using the plugin manager).
Logged

wing

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Photo Shop 1.5 Plugin fatal error
« Reply #4 on: September 03, 2009, 08:32:26 am »

I have been searching for relevant topic to my problem, I guess it is as close as I could find.   My problem is

Since the first method on installing the plugin failed, I attempted to use method 2 to ftp the plugin files to the plugin directory.  BTW. the plugin is photoshop anyway.   However, after all the files are in the proper places, I cannot see the newly ftp plugin reflected in the plugin manager.   The only plugin that I could see on the listing is the sample.    Any ideas on how that has happened and how to make the plugin manager recognize that there is a new plugin folder created in the plugin directory. 

My installation side is http:\\studio.fusionliquid.com, althoguh never can be seen in the context.

The plugin folder is "photo_shop"
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Photo Shop 1.5 Plugin fatal error
« Reply #5 on: September 03, 2009, 10:17:47 am »

http://studio.fusionliquid.com/plugins/photo_shop/codebase.php

the webserver doesn't see the URL... if you've uploaded the files to the correct place then probably something's wrong with permissions

wing

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Photo Shop 1.5 Plugin fatal error
« Reply #6 on: September 03, 2009, 10:26:23 am »

What permission should I expect the new plugin folder and files should be?  Can I use the sample folder as a reference?
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Photo Shop 1.5 Plugin fatal error
« Reply #7 on: September 03, 2009, 06:28:24 pm »

The sample plugin can be seen from the web... so I assume that'll be a good start
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.