Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: Getting avatar Placed for my theme  (Read 10237 times)

0 Members and 1 Guest are viewing this topic.

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
[Solved]: Getting avatar Placed for my theme
« on: April 09, 2008, 01:44:35 pm »

I would like to place the Avatar image independently on the index page . i need to link the Avatar to the Profile of the user ..how can this be done

Place holders will be fine ...cos i have no probs with html or css

please help me :)

« Last Edit: April 27, 2008, 02:45:50 pm by Stramm »
Logged

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #1 on: April 10, 2008, 06:21:35 pm »

I added the scripts that u have provided at
http://forum.coppermine-gallery.net/index.php/topic,46692.20.html

after adding this to the theme.php i get an error message when clicking on the online users (nibblers mod)

Quote
Fatal error: Call to a member function get_user_infos() on a non-object in /home/glamour/public_html/themes/vista_aero/theme.php on line 329

Please help me fix this error

Thanks

Logged

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #2 on: April 10, 2008, 06:38:35 pm »

I managed to move the image around the theme with css , but now the second problem remains

please login with


username:stramm
Password:coppermine

Clicking on a user link to profile shows the error i ve posted above

Please help me
Logged

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #3 on: April 10, 2008, 06:39:44 pm »

Oops i forgot to type my site name ..its www.liveglamour.com , i wish there was an edit button  ;D
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Getting avatar Placed for my theme
« Reply #4 on: April 11, 2008, 08:24:17 pm »

theme issue... the classic theme works as expected

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #5 on: April 11, 2008, 08:28:22 pm »

theme issue... the classic theme works as expected

but i have Altered the Dew drops theme for my current theme , what exactly in my theme needs to be change to get that final part to work fine ? :(


Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Getting avatar Placed for my theme
« Reply #6 on: April 11, 2008, 08:37:31 pm »

I have no clue what the problem may be as I do not know what you've changed

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #7 on: April 11, 2008, 08:49:03 pm »

I have atached the files , please try this
Logged

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #8 on: April 13, 2008, 10:15:49 pm »

Yes stramm the problem is with the theme , its working fine with kuberick theme , i just tried now :( , can u please get it working on my theme ?
Logged

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #9 on: April 14, 2008, 09:39:45 am »

Yes stramm the problem is with the theme , its working fine with kuberick theme , i just tried now :( , can u please get it working on my theme ?

sorry , its not working with other themes too :(
Logged

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #10 on: April 26, 2008, 06:35:41 pm »

any clues Stramm :(
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Getting avatar Placed for my theme
« Reply #11 on: April 26, 2008, 07:03:11 pm »

I've tried your theme and it works as expected for me... avatar shows and is linked to the profile

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #12 on: April 27, 2008, 03:53:28 am »

I've tried your theme and it works as expected for me... avatar shows and is linked to the profile

But on clicking on the avatar it dosent go to the profile instead shows an error :(
Logged

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #13 on: April 27, 2008, 08:57:32 am »

U mean its working fine when u have tried ? ?

what would have gone wrong with me ? ?
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Getting avatar Placed for my theme
« Reply #14 on: April 27, 2008, 09:05:06 am »

No clue... you'd need to upload the modified theme so I can see the error

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #15 on: April 27, 2008, 09:10:30 am »

Its already attached stramm see post # 7
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Getting avatar Placed for my theme
« Reply #16 on: April 27, 2008, 09:13:01 am »

I mean on your live site... as I can't replicate the problem on my testbed I'd need to see it on your site.

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #17 on: April 27, 2008, 09:52:50 am »

I mean on your live site... as I can't replicate the problem on my testbed I'd need to see it on your site.

Sent the details on PM with new password
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Getting avatar Placed for my theme
« Reply #18 on: April 27, 2008, 09:53:56 am »

in your theme.php find
Code: [Select]
global $CONFIG, $lang_loginform, $REFERER;and replace it with
Code: [Select]
global $CONFIG, $lang_loginform, $REFERER, $cpg_udb;
That may be the problem...

dumbo

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 112
Re: Getting avatar Placed for my theme
« Reply #19 on: April 27, 2008, 12:06:51 pm »

Yes that was the problem , every thing solved now :)

Thank you starmm
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 20 queries.