Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: Fatal Error solution not in FAQ  (Read 4886 times)

0 Members and 1 Guest are viewing this topic.

Understudy

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 51
    • Another boring website
[Solved]: Fatal Error solution not in FAQ
« on: March 18, 2008, 03:52:08 pm »

Hi,

I am receiving
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 12288 bytes) in /usr/home/www/vhosts/brendhanhorne.com/public_html/coppermine_dir/include/picmgmt.inc.php on line 262

I do not want to change the image sizes.
Running on FreeBSD 6.3
Coppermine version is 1.4.16
http://www.brendhanhorne.com/coppermine_dir/index.php

Based on the forum's suggestions I did the following:
Read http://forum.coppermine-gallery.net/index.php/topic,24088.0.html   [done]
Read http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_trouble   [done]

1. Checked Permissions
drwxrwxrwx  7 brendhanhorne  www  2048 Mar 10 01:23 public_html
drwxrwxrwx   12 brendhanhorne  www   2048 Mar 10 10:04 coppermine_dir
drwxrwxrwx  142 brendhanhorne  www    3584 Mar 18 08:13 albums
drwxrwxrwx    3 brendhanhorne  www    1024 Mar 10 10:05 include
drwxrwxrwx    3 brendhanhorne  www    512 Mar  9 20:53 userpics
drwxrwxrwx    2 brendhanhorne  www  7168 Mar 18 09:34 10001
All album folders with pictures are 777.
http://www.brendhanhorne.com/files/album_permissions.log

I have modified the php.ini
http://www.brendhanhorne.com/files/php.ini

clone# grep -n max_input_time /usr/local/etc/php.ini
240:max_input_time = 90 ; Maximum amount of time each script may spend parsing request data

clone# grep -n upload_max_filesize /usr/local/etc/php.ini
499:upload_max_filesize = 16M

clone# grep -n post_max_size /usr/local/etc/php.ini
383:post_max_size = 16M

clone# grep -n memory_limit /usr/local/etc/php.ini
242:memory_limit = 32M      ; Maximum amount of memory a script may consume (8MB)

clone# grep -n file_uploads /usr/local/etc/php.ini
492:file_uploads = On   <-- This is the default setting

clone# grep -n upload_tmp_dir /usr/local/etc/php.ini
496:;upload_tmp_dir =  <-- This is the default setting

clone# grep -n max_execution_time /usr/local/etc/php.ini
239:max_execution_time = 30     ; Maximum execution time of each script, in seconds
I do not believe this needed to be changed

clone# grep -n safe_mode /usr/local/etc/php.ini
167:safe_mode = Off
171:; then turn on safe_mode_gid.
172:safe_mode_gid = Off
174:; When safe_mode is on, UID/GID checks are bypassed when
178:safe_mode_include_dir =                                             
180:; When safe_mode is on, only executables located in the safe_mode_exec_dir
182:safe_mode_exec_dir =
192:safe_mode_allowed_env_vars = PHP_
196:; protected even if safe_mode_allowed_env_vars is set to allow to change them.
197:safe_mode_protected_env_vars = LD_LIBRARY_PATH
625:sql.safe_mode = Off

I logged in as admin
went to config screen and modified settings according to
http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_trouble
changed settings in groups panel

Attempted to upload single picture.
img_0354.jpg 1.2M 3072x2304  72x72 Ppi
and the error message is what is at the top of the screen.

Documentation recommends creating a test user.
user test-user
pass password
album http://www.brendhanhorne.com/coppermine_dir/thumbnails.php?album=138 test_album

Using the test_user in debug mode I get a blank screen when I try to upload the same file.
If I upload a smaller file it goes fine. I only see the error message if I am logged in as admin.

If there is some other action I can perform to assist in this please let me know.

Sincerely,
Brendhan

« Last Edit: March 18, 2008, 04:51:24 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: Fatal Error solution not in FAQ
« Reply #1 on: March 18, 2008, 03:54:35 pm »

Error message says it all. Your memory limit is 32M but the image requires more to process. Increase the limit.
Logged

Understudy

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 51
    • Another boring website
Re: Fatal Error solution not in FAQ
« Reply #2 on: March 18, 2008, 04:34:25 pm »

Okay done. Problem appears to be solved.

clone# grep -n memory_limit /usr/local/etc/php.ini
242:memory_limit = 128M      ; Maximum amount of memory a script may consume (8MB)

Now my question is this.
72 x 72=5184  Ppi x Ppi =Pa
5184 x 3=15552 Pa x RGB
15552/1048576 = 67.423868 MB
Would this be correct?

Sincerely,
Brendhan

Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 19 queries.