Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: disapearing albums  (Read 1930 times)

0 Members and 1 Guest are viewing this topic.

Halfhidden

  • Guest
disapearing albums
« on: March 04, 2008, 05:09:32 pm »

Hi I've got an odd problem happening in coppermine. Just to let you know its bridged to phpbb3 and that's all that shares the sql database.
I created a user folder after installing the mod (http://forum.coppermine-gallery.net/index.php?topic=32399.new;topicseen#new) Everything has been fine up until this morning. The album I created has disappeared and the files within it have been copied into main gallery albums. I also had a user who created a album and uploaded to it. But when he checked he noticed that all of his pictures were in an different album within his collection. Now that could possible be the user renaming an existing album, whilst thinking that he had created on. But the album I created still cannot be explained.
The rest of the site is ok.
Any ideas please?
Regards,
Steff (a very grateful coppermine user)
Logged

Halfhidden

  • Guest
Re: disapearing albums
« Reply #1 on: March 04, 2008, 05:22:01 pm »

A quick update to the above post. It seems that the missing album isn't the case. because the pictures were elsewhere and not in the album (by design) doesn't show the album up, not even to admin. None the less I still have a problem with pictures that are uploaded to one album, checked and visited in that album, end up later on in a completely different album.
Logged

Halfhidden

  • Guest
Re: disapearing albums
« Reply #2 on: March 04, 2008, 09:43:52 pm »

I've just tried this again (uploaded 8 images to a private album (not batch upload)). And any pictures uploaded to private albums seem to be in the correct albums. I was able to search for them and view them as normal. After about an hour ALL of the pictures are scattered randomly throughout the public gallery and the private album becomes hidden from view. I'm deeply concerned that I have a database error or a compromise somewhere.
Regards,
Steff
Logged

Halfhidden

  • Guest
Re: disapearing albums
« Reply #3 on: March 04, 2008, 10:08:58 pm »

I think I've solved the mystery.. but I wont fully know until tomorrow. But here is the theory behind the logic.

The problems started after I installed the mod (http://forum.coppermine-gallery.net/index.php?topic=32399.new;topicseen#new) . I haven't found anything wrong with the mod, but this is when things started to go screwy.
I installed the mod because some users on my site are either to lazy or to challenged to put their pictures on our site (sorry to sound so blunt about our users, but I'm blessed with quite a few)). Anyway the mod allowed me to create a private folder and upload to it. Fantastic! But I think I've discovered a bug.
If the user has already created an album in their account but hasn't uploaded any pictures to it and then the administartor creates an album for the private user..... and both of these albums have the same name. Then a recipe for disaster yes?
If I'm right then this will happen again. I will see the user tomorrow and check to see if they have created an album of the same name (as I suspect) and report my findings to this thread. I guess this mistake could happen again because the administrator cannot see empty albums for private users (only populated albums).

Regards,
Steff
Logged

Halfhidden

  • Guest
Re: disapearing albums
« Reply #4 on: March 05, 2008, 05:51:52 pm »

Hello its me as promised an update.

Turns out that I was correct in my theory. I created an album called "The Mike Gendall Collection" and uploaded images to it. The Album was created in the users gallery by means of a mod and uploaded by admin. The problem was that the user (who claimed that they couldn't create an album) had in fact created an album in their account as well with exactly the same name. How odd is that. But because the user didn't upload any images to it, the album was invisible to the administrator. Anyway I can't imagine that this will happen again in the same way unless both albums have been left with the default name "New album". To correct this I deleted both albums and re created one album only with the above name and uploaded the images to it. This time the images stayed in the album and did not populate to the main gallery.
Hope someone finds this useful in the future. Please marked this subject as solved.
Thanks,
Steff
Logged

Nibbler

  • Guest
Re: disapearing albums
« Reply #5 on: March 05, 2008, 07:17:58 pm »

I think you linked to the wrong mod.
Logged

Halfhidden

  • Guest
Re: disapearing albums
« Reply #6 on: March 05, 2008, 08:12:38 pm »

Hi Nibbler,
Yes you are correct I linked to the wrong mod. The link should have been http://forum.coppermine-gallery.net/index.php/topic,26386.0.html
 :PSorry for any confusion.

Regards,
Steff
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 19 queries.