Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: editpics: Script called without the required parameter(s)  (Read 4098 times)

0 Members and 1 Guest are viewing this topic.

mcoates

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
editpics: Script called without the required parameter(s)
« on: February 29, 2008, 12:48:24 am »

Hello Everyone,

I've been having some problems with my gallery lately. 
http://forum.coppermine-gallery.net/index.php/topic,50723.msg244655.html#msg244655

Most recently, I'm getting this error when trying to 'apply modifications' from the Edit Files page. 

Script called without the required parameter(s). (aid1552)

File: /home/jamieand/public_html/coppermine/editpics.php - Line: 84


I have tried deleting editpics.php and uploading a fresh copy as suggested in this thread:
http://forum.coppermine-gallery.net/index.php/topic,50026.0.html
I have not deleted the User galleries category as was the problem for this poster.   

I am running 1.4.16 and I have run versioncheck.php to confirm that all my files are up to date. 
I have checked that all the tables in my database are repaired or error free. 

My gallery is here:
http://www.jamieandmelissa.org/coppermine/

Thanks
Logged

Nibbler

  • Guest
Re: editpics: Script called without the required parameter(s)
« Reply #1 on: February 29, 2008, 12:52:57 am »

Does it work with a small number of images in the album and then suddenly stop when you reach a certain number? If so then it's probably a 'security' restriction imposed by your webhost.
Logged

mcoates

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: editpics: Script called without the required parameter(s)
« Reply #2 on: February 29, 2008, 01:18:16 am »

Possibly.  I just tried editing the files in a small album (8 files) and it worked just fine.  The album I had been working on when I got the error may be my biggest album (69 files) to date.  And it seems that it has saved the file information for the first 22 of 25 files even though I got the error after hitting 'apply modifications' after modifying all 25 files.    Previously I have had albums as big as 58 files without this error. 

So does this sound like a 'security' restriction?  Is there anyway to work around it?

Thanks for your quick response,
Melissa
Logged

Nibbler

  • Guest
Re: editpics: Script called without the required parameter(s)
« Reply #3 on: February 29, 2008, 01:37:40 am »

If you have a decent webhost they might increase the limit for you. Otherwise you could mod editpics to work on only 20 pics per page.
Logged

mcoates

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: editpics: Script called without the required parameter(s)
« Reply #4 on: February 29, 2008, 02:09:37 am »

Thanks.

I doubt my webhost is 'decent' but if I were going to ask them to make a change, what would I ask for exactly?

Logged

Nibbler

  • Guest
Re: editpics: Script called without the required parameter(s)
« Reply #5 on: February 29, 2008, 02:18:50 am »

Ask for the limit on the number of POST form fields to be increased or removed. They are using suhosin or a similar hardening patch for PHP.
Logged

mcoates

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: editpics: Script called without the required parameter(s)
« Reply #6 on: February 29, 2008, 08:08:08 pm »

Thanks!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: editpics: Script called without the required parameter(s)
« Reply #7 on: March 01, 2008, 01:06:15 am »

Issue solved then?
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.